Skip navigation
JMaiMai
Currently Being Moderated

Photoshop elements 10 launches very slow with internet connection

Sep 13, 2013 5:09 PM

I've installed both Photoshop elements and Premier Elements 10 on my Windows7 64bit OS Laptop.  If I disable/turn off my internet connection then both applications launches normally.  However, if internet connection is on, it takes at least 5 minutes to launch the app (the circle keeps spinning...).  I would prefer not having to turn off my internet connection when launching these apps because I need to access share drive.  My Laptop is a company PC and is protected by proxy firewall and Mcaffee enterprise.

Please help...Thanks

 
Replies
  • Currently Being Moderated
    Sep 13, 2013 5:24 PM   in reply to JMaiMai

    Moving discussion to Elements forum.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2013 6:54 PM   in reply to JMaiMai

    The problem is that the welcome screen is trying to connect to photoshop.com, which no longer exists. Go into the program files or program files(x86) for a 64-bit system and find the actual .exe files for the editor and/or organizer and make a desktop shortcut. In future use that to launch PSE. Be sure you are signed out of your photoshop.com account if you had one, and that backup/sync is disabled.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 25, 2013 11:22 PM   in reply to JMaiMai

    I have exactly the same problem. Anyone has new idea please?

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points