Skip navigation
Currently Being Moderated

Record stream with H.264 and PCMU: is it supported?

Sep 20, 2013 8:49 AM

Tags: #error #h264 #stream #record #pcmu #noaccess

I tried to record a stream which is published with H.264 codec and the telephony (PCMU) codec with a Flash Player 11+ client. The stream plays fine live but when I try to record it, I get the following error on the status of the stream: NetStream.Record.NoAccess. The file is created on disk but has only 21 KB, never more, never less. This is my log:

 

10:21:49.550  info   Stream (record_Aaj3g/u28_T32l87h.f4v) status: NetStream.Data.Start (level: undefined, length: 0 sec.)

10:21:49.554  info   Stream (record_Aaj3g/u28_T32l87h.f4v) status: NetStream.Publish.Start (level: status, length: 0 sec.)

10:21:49.556  info   Stream (record_Aaj3g/u28_T32l87h.f4v) status: NetStream.Play.Reset (level: status, length: 0 sec.)

10:21:50.107  info   Stream (record_Aaj3g/u28_T32l87h.f4v) status: NetStream.Record.Start (level: status, length: 0 sec.)

10:21:59.962  info   Stream (record_Aaj3g/u28_T32l87h.f4v) status: NetStream.Record.NoAccess (level: status, length: 0 sec.)

10:21:59.966  info   Stream (record_Aaj3g/u28_T32l87h.f4v) status: NetStream.Record.Stop (level: status, length: 0 sec.)

 

I digged the problem a little and found that I also have an error in the Windows Event Viewer from AMSCore:

Error from libmp4.dll:Received an audio packet of unknown type..

 

I even tried to publish the stream in "record" mode instead of "live" directly from the client to see if it does the same thing. It does, I get exactly the same result.

 

I searched on the web hoping to find something about the problem but without any result. The only reference I see is a table in the AMS documentation listing the supported file types and codecs but there is no mention of the PCMU/PCMA codecs. Here: http://help.adobe.com/en_US/adobemediaserver/techoverview/WS07865d390f ac8e1f-4c43d6e71321ec235dd-7fff.2.3.html#WS5b3ccc516d4fbf351e63e3d119e d944a1a-7fe7.2.3

 

In last resort, I tried to publish the file as RAW. It seems to work but I can hardly use this format since it is only usable by Flash Player I think. I cannot convert or reuse the file on another platform.

 

By the way, I had the same result on FMS 3.5.3 and AMS 5.0.1

 

Any idea? Is this normal or what?

 
Replies

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points