Skip navigation
Currently Being Moderated

WORKAROUND/POSSIBLE SOLUTION: Chrome 30 for Mac and Edge Inspect CC sec-WebSocket-Protocol error

Oct 2, 2013 7:19 PM

Tags: #chrome #websocket #adobe_edge_inspect #chrome_extension

I came across this thread (How to solve the sec-WebSocket-Protocol error in Chrome 30.0.1599.66 m) and applying the same edit to the inspect.js file for the Edge Inspect Chrome Extension solved the WebSocket error immediately, the issue most of us have been experiencing with the latest Chrome version: 30.0.1599.66.  We couldn't revert back to Chrome 29 (latest known version working with Edge Inspect) because we couldn't find it, but in any case Chrome will auto-update to version 30.

 

My system info: OSX 10.7.5, Chrome Extension Adobe Edge Inspect CC 1.0.424.1, Adobe Edge Inspect CC 1.0.407, Chrome 30.0.1599.66

 

Disclaimer: This steps will modify the Adobe Chrome Extension as installed from the Chrome Web Store.  I will not be held responsible for any other issues this may cause.  I'm just reporting a fix that immediately worked for me.  I'm assuming you can always remove the extension from chrome and reinstall from the store.

 

Step 1: Disable Edge Inspect Chrome extension

  1. Browse to chrome://extensions and uncheck/Disable Adobe Edge Inspect CC 1.0.424.1

 

Step 2: Browse to the inspect.js file

  1. In Finder, Cmd-Shift-G or from the Menu bar Go > Go to folder...
  2. Copy/paste
    ~/Library/Application Support/Google/Chrome/Default/Extensions/ijoeapleklopieoejahbpdnhkjjgddem/1.0.424.1_0/js/

 

Step 3: Edit inspect.js file

  1. Select inspect.js and edit it any text editor (TextEdit, TextWrangler, or even Edge Code CC)
  2. On line 61 look for the following code:
    this._wshandle = new WebSocket(this._protocol + "://" + this._host + ":" + this._port + "/", "shadow");
  3. Edit the line to remove , "shadow" (note the comma and space is also to be removed).  So you're resulting code should be:
    this._wshandle = new WebSocket(this._protocol + "://" + this._host + ":" + this._port + "/");
  4. Save changes

 

Step 4: Enable Edge Inspect Chrome extension

  1. Browse to chrome://extensions and check/Enable Adobe Edge Inspect CC 1.0.424.1
  2. The icon in your toolbar should change immediately from grayed out to full color brown and everything should function as usual

 

Again, I'm not sure if this is the ultimate fix, but at least Edge Inspect works again until the Chrome extension is fixed or Chrome changes the way WebSockets are handled.

 

Hope this helps!!

 

-Arnold

 
Replies
  • Currently Being Moderated
    Oct 3, 2013 4:31 AM   in reply to ArnoldD

    Thanks Arnold for the workaround.

    We are aware of this issue and working actively to resolve it. Will keep you posted.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 3, 2013 10:02 AM   in reply to ArnoldD

    Worked perfectly for me. Thanks for this.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 3, 2013 3:13 PM   in reply to DariaKempkaCC

    Worked for me as well. Many thanks for the fix.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 4, 2013 8:38 AM   in reply to ArnoldD

    Thank bejesus. That worked. Good instructions. I have zero js experience but figured it out. My finder couldn't find the folder however so I had to manually go and look for it in my library folder FYI.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 4, 2013 1:22 AM   in reply to ArnoldD

    Just in case that anyone is working with Windows 7, you should change the location to this one:

     

    C:\Users\<your_user_name>\AppData\Local\Google\Chrome\User Data\Default\Extensions\ijoeapleklopieoejahbpdnhkjjgddem\1.0.424.1_0\ js

     

    Confirmed that it works also on Windows 7.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 4, 2013 4:38 AM   in reply to ArnoldD

    Fantastic! That worked.

    For those of you who are on mac and can't find the folder directly - Look in your

    ~/Library/Application Support/Google/Chrome/<PROFILE>/Extensions/ijoeapleklopieoejahbpdnhkjjgddem/1.0.424.1_0/js/


    Essentially check each profile folders and find that directory and modify as Arnold stated. Cheers.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2013 9:35 PM   in reply to ArnoldD

    Worked for me, a great Sunday Night Save. Thank you.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 7, 2013 1:13 AM   in reply to ArnoldD

    Same problem was on my Windows 7 64bit.

     

    I found "inspect.js" in my Profile-Directory in AppData (is hidden folder)  -- > AppData\Local\Google\Chrome\User Data\Default\Extensions\ijoeapleklopieoejahbpdnhkjjgddem\1.0.424.1_0\ js

     

    Thank you it was very very helpful!!!

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 7, 2013 5:04 AM   in reply to ArnoldD

    Thanks, you saved my day! :-)

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 7, 2013 9:01 AM   in reply to ArnoldD

    A solution that actually works?!?! How about that!  Thanks so much you have saved the day!

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 9, 2013 11:49 PM   in reply to ArnoldD

    Thank you so much kind sir.

     

    I'm kind of upset and puzzled that adobe isn't on top of this.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 10, 2013 9:17 AM   in reply to ArnoldD

    Thanks!  Worked a charm.

     

    //Edit

    To get Edge inspect working with the Chrome that Brackets starts up via live preview, I performed the same edit in inspect.js found in the following location on my Windows machine.  Hope this helps someone else.

     

    C:\Users\<USERNAME>\AppData\Roaming\Brackets\live-dev-profile\Default\ Extensions\ijoeapleklopieoejahbpdnhkjjgddem\1.0.424.1_0\js

     

    //Edit2

    I also had to add the Edge inspect extension for this Chrome by the way (seems to be a separate configuration)

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 10, 2013 7:24 PM   in reply to ArnoldD

    They have since updated the extention to version 1.0.424.2. It appears they have put this fix in it, but it still does not work:(

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 12, 2013 6:31 AM   in reply to Zedmus

    The chrome extension is updated with the fix. Do you still see an "unexpected token" error, with the new version?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 12, 2013 7:21 AM   in reply to Vishakha

    I'm not getting a token error in the console log, but the extention still is grayed out and does not respond.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 12, 2013 8:54 AM   in reply to Zedmus

    I'm assuming the edge inspect app is running and you are signed in with your adobe id? Can you click on the toggle switch for synchronous browsing, on the upper right corner of extension popup? Whats the message that you see on the chrome extension popup? Can you paste a screenshot here or send it to me at vvaidya@adobe.com.

     

    ~Vish

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 15, 2013 8:26 AM   in reply to Vishakha

    I uninstalled and re-installed the extension. That worked, not sure why since I had updated it earlier (after the fix).

     

    Thank you for your help and quick reponse.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 16, 2013 8:55 AM   in reply to ArnoldD

    I tried to uninistall and re-install (1.0.424.2) without any success. I changed the JavaScript per the instruction, and instead of getting an error in console.log within Chrome, I get no error but it doesn't communicate with my Samsung Galaxy S3. I even unistall the Chrome extension and the free version on my phone.

     

    Any help would be appreciated.

     

     

    environment: Windows 8, Google Chrome n 30.0.1599.101 m,

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 16, 2013 8:59 PM   in reply to patitdude

    Do you see a "waiting for connection" in the extension popup? Or is the extension greyed out?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2013 9:03 AM   in reply to Vishakha

    The extension is not greyed out out, but waiting for connection.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2013 10:46 PM   in reply to patitdude

    Please try the following -

    1> Ensure Edge Inspect app is running and listensing to port 7682, using Netstat command.

    2> Ensure device and desktop can talk to each other across port 7682, you might have to disable/modify firewall settings

    3> use the ip shown in extension popup to connect from device.

     

    Let me know how it goes.

     

    ~ Vish


     
    |
    Mark as:
  • Currently Being Moderated
    Dec 11, 2013 7:38 AM   in reply to Vishakha

    I did get it to work on Chrome 32.0.1700.41 (beta).

     
    |
    Mark as: