Skip navigation
singh_harmeet13
Currently Being Moderated

Error: Definition mx.core:RSLData could not be found.

Oct 10, 2013 4:18 AM

Tags: #error #command #flex4

When i try to run this command :

 

"mxmlc -static-link-runtime-shared-libraries=true -debug=true -load-config=C:\TestFlex4\flex-config1.xml -output=C:\TestFlex4\web\test1.swf c:\TestFlex4\web\test1.mxml"

 

The follwing error stach trace shown:

 

C:\TestFlex4\web>mxmlc -static-link-runtime-shared-libraries=true -debug=true -load-config=C:\TestFlex4\flex-config1.xml -output=C:\TestFlex4\web\test1.swf c:\infoTrakFlex4\web\test1.mxml

 

Loading configuration file C:\TestFlex4\flex-config1.xml

_test1_mx_managers_SystemManager.as(135): c

ol: 35 Error: Access of possibly undefined property RSL_ADD_PRELOADED through a

reference with static type Class.

 

 

        addEventListener(RSLEvent.RSL_ADD_PRELOADED, addPreloadedRSLHandler, fal

se, 50);

                                  ^

 

 

_test1_mx_managers_SystemManager.as(159): c

ol: 35 Error: Access of possibly undefined property RSL_ADD_PRELOADED through a

reference with static type Class.

 

 

        addEventListener(RSLEvent.RSL_ADD_PRELOADED, addPreloadedRSLHandler, fal

se, 50);

                                  ^

 

 

_test1_mx_managers_SystemManager.as(171): c

ol: 13 Error: Access of undefined property allowDomainsInNewRSLs.

 

 

        if (allowDomainsInNewRSLs && _allowDomainParameters)

            ^

 

 

_test1_mx_managers_SystemManager.as(180): c

ol: 13 Error: Access of undefined property allowInsecureDomainsInNewRSLs.

 

 

        if (allowInsecureDomainsInNewRSLs && _allowInsecureDomainParameters)

            ^

 

 

_test1_mx_managers_SystemManager.as(16): co

l: 15 Error: Definition mx.core:RSLData could not be found.

 

 

import mx.core.RSLData;

              ^

 

i have an existing code, whch i  want to try to run, but this error fail my compilation. i am new in flex, please tell me some solution.

 
Replies
  • Currently Being Moderated
    Oct 10, 2013 10:02 AM   in reply to singh_harmeet13

    Sounds like the flex-config1.xml doesn't include the necessary library SWCs.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points