Skip navigation
Currently Being Moderated

Flash Pro CC AIR for Android Publish Never Finishes

Oct 10, 2013 12:25 PM

Tags: #android #actionscript_3 #cc #flash_pro

I am having so much trouble with the new CC flash pro. Simply, it does not publish to devices - at all.

I was able to get the proper driver so that Flash Pro recognises my device (which was a challenge in itself). Now, when I go to publish it never finishes. Apparently they removed the timer from the publish window - a bad choice IMO because now I'm going to be waiting hours for it to finish when it actually has frozen.

 

 

On android, the "Publishing..." box comes up and never goes away. There are no errors. It just simply does not work when I push the publish button, any of them. I have no idea what the problem could be or how I am supposed to fix this so any help is greatly appreciated. thanks.

 
Replies
  • Currently Being Moderated
    Oct 16, 2013 10:34 PM   in reply to YourLoftiness

    Is this happening for a specific file or for all fla files on your machine? Can you share the fla file for us to investgate further.

     

    -Sujai

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2013 2:59 AM   in reply to SujaiS

    I'm having the same problem with Flash CC on Mac OS 10.8.5 using AIR 3.6 and 3.9 beta sdks publishing to Android.

    Essentially Flash CC builds the apk just fine then hangs at 00:05 when it should be installing the apk to the device.

    In looking at Activity Monitor I noticed I had two adb processes launched which could be part of the problem.

     

    I then tried publishing through Flash CC but installing on devices via the command line when I've now run into another error:

     

    $ adb install Untitled-1.apk

    1311 KB/s (9427446 bytes in 7.021s)

              pkg: /data/local/tmp/Untitled-1.apk

    Failure [INSTALL_PARSE_FAILED_NO_CERTIFICATES]

     

    Apparently the apk isn't signed despite including my certificate in the publishing settings (along with the password) and the publishing process finishing without error.

    An unsigned APK will not install on devices, which *could* be related to the problem of Flash CC never finishing publishing when 'install on device(s)' is selected in the publishing options. If Flash CC is waiting for a 'success' event to be fired from adb it may simply never be receiving one and therefore never finishing the publishing process… (just speculating).

     

    Also, this is happening with *ANY* FLA I try to publish to Android.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 28, 2013 8:37 AM   in reply to bryanrieger

    I'm having a lot of trouble getting apps to publish to iPads (probably any device) after recent updates. This was happening before Mavericks on my Mac, but continues after that OS update. I have to fiddle around with wi-fi and bluetooth. I can't pinpoint this. Sometimes it's turning off all internet connectivity on my Mac, sometimes it works when I turn off wifi and bluetooth on the iPad. It get's worse when more than one testing device are nearby.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 25, 2013 3:08 AM   in reply to SujaiS

    I am having the same problem - was this ever resolved? I am testing with a very minimal fla in Flash Pro CC trying to publish to a Samsung Galaxy Tab2 10.1 on Windows 7 Ultimate 64 bit. The publish process never finishes as described by YourLoftiness and cancelling the operation causes Flash to crash (i.e. Not Respond forcing a cntrl-alt-del End Task). The problem seems to occur when trying to 'install application on selected Android device' Publishing locally is succesful. But what to do with the .apk file?

     

    Do I need to install the Android SDK? I thought this was not required with Flash Pro CC? Can you help?  Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 25, 2013 8:42 AM   in reply to Mister D

    Run "adb devices" and make sure you see your serial number next to "device" and not "unauthorized" or "offline". I get this behavior across products when the device (with USB Debugging enabled) doesn't read the OS RSA cert and prompt me to grant the computer it's connected to permission. Toggling the USB debugging, dis/reconnecting the USB cord and power toggling computer or device just never brings this prompt up in some 4.2.2 and up devices (Samsung Galaxy Tab 3 8.0" running 4.2.2 for me, constantly listed as "unauthorized").

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 26, 2013 1:39 AM   in reply to sinious

    Thanks for your response sinious. I installed the Android SDK.  I too experience "unauthorized" and also this

     

    C:\android-sdk\platform-tools>adb devices

    adb server is out of date.  killing...

    ADB server didn't ACK

    * failed to start daemon *

    error:

     

    Only once so far have I seen my device apparently authorized in adb devices but when I tried to publish to the device in that condition from Flash CC I experienced the original 'never completes' error described above.

     

    Is publishing to devices running  4.2.2 even possible? 

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 26, 2013 9:25 AM   in reply to Mister D

    Yes, I have a Sony Xperia Tablet Z running 4.2.2 and it publishes perfectly to it. I often only have this issue specifically with Samsung products.

     

    I did read somewhere (can't find it atm) to replace the adb.exe, AdbWinApi.dll, AdbWinUsbApi.dll and aapt.exe with the updated version of your Android SDK (e.g. C:\AndroidSDK\sdk\platform-tools) and it can help. You can find those files in your AIR\lib\android\bin folder (e.g. C:\Program Files (x86)\Adobe\Adobe Flash CS6\AIR3.9\lib\android\bin for CS6). Then flash reads a higher version of adb which may give better device information.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points