Skip navigation
kcookcreative
Currently Being Moderated

Irregular spaces after pasting in ID

Oct 25, 2013 7:56 AM

Tags: #spacing #cs6" #formatting_error #pasting_text

When I copy text from either Word or Text Editor into ID, there are irregular spaces between sentences throughout the 200 page document.

I am a newbie to ID, but I have been trying a multitude of things to fix this...and still have the problem. Can someone please help?

(A little background...the person who sent me these files, sent them in individual emails in which I had to copy and paste in Word. They inserted spaces, returns, etc. manually.)

 
Replies
  • Currently Being Moderated
    Oct 25, 2013 8:02 AM   in reply to kcookcreative

    Use Find/Change. At the top of the Find/Change dialog, see the Query: menu for useful preset operations to solve your problems; namely Multiple Return to Single Return, Multiple Space to Single Space, and perhaps Remove Trailing Whitespace

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2013 8:43 AM   in reply to kcookcreative

    If that's the case, then you're either describing the problem wrongly, or you're missing/missetting a piece of the Find/Change operation. Be sure the Search: menu is set to Document.

     

    Tip: When you try something that doesn't appear to work, to get help with it, it's best if you elaborate more. What happened when you tried? In detail; what exactly did you do, and what exactly was the result?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2013 8:45 AM   in reply to kcookcreative

    Can you post a screen shot that shows the problem?

     
    |
    Mark as:
  • Rob Day
    3,126 posts
    Oct 16, 2007
    Currently Being Moderated
    Oct 25, 2013 10:22 AM   in reply to kcookcreative

    If the text is justified the paragraph Hyphenation and Justification settings will determine the word spacing.

     

    The same text with different settings:

     

    Screen Shot 2013-10-25 at 1.21.38 PM.png

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2013 4:53 PM   in reply to kcookcreative

    kcookcreative wrote:

     

    the person who sent me these files, sent them in individual emails in which I had to copy and paste in Word.

    This is probably the source of the problem. Email programs tend to add extra returns to control line lengths.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2013 8:15 PM   in reply to kcookcreative

    Don't know if this will help you at this point, but I would copy/paste from email to word using "Paste As Unformatted Text". That might help a bit.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2013 10:03 PM   in reply to kcookcreative

    That's because your margins are a bit wider in Word. There's a hard return at the end of each line in the email, and in Word. Turn on invisible characters (at the bottom of the Type dropdown menu) in InDesign to see the return symbols. I can't recall where that control is in Word, but I'd bet that they're present there as well.

     

    There may be some way to extract the content from the source emails without the hard returns at the end of the lines, but if you've already copy/pasted all the emails once, it may be less painful than just combing through manually. If you are a fast keyboarder and have an End key on your keyboard, you might get really fast at whacking the down arrow, the End key, the Delete key, the down arrow twice, the End key, the Delete key... it's awfully hard to automate this cleanup job, unfortunately.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2013 12:26 AM   in reply to kcookcreative

    Some of us older folks who grew up with typewriters learned that you have to hit the return key (or worse...hit the carriage-return lever...GASP!) at the end of the line, and it could be that the person who keyed this in did that instead of letting Word do the automatic wrapping. How ever it got that way, Joel is right in that you need to remove them.

     

    Another way you may consider is using Find/Change. Enter ^p into the Find field (that's the code for a paragraph return), place the cursor at the beginning of your text and hit the Find button. When it finds the first paragraph return, decide if you want to keep it or not. If you want to remove it, hit either the Change button, then the Find button to move to the next one, or use the Change/Find button to change and find in one step.

     

    Without anything entered into the Change field, it will replace the paragraph return with nothing, which may or may not be what you want. If there is no space between the last character of the line and the paragraph return, you will likely get the last word of one line combined with the first word of the next line, and you really don't want to have to clean that up. Instead, consider replacing the paragraph returns with a space (by typing a space into the Change field). This may give you some double spaces to clean up later, but you can fix that fairly easily.

     

    At the top of the Find/Change window, you will see Query:. If you click the blue arrows to the right, you can select from a number of GREPs. One of them is Multiple Space to Single Space. If you choose it, it will load a bunch of code into the find and change fields. If you hit Change All, it will find any instance of two spaces or more in a row and change them to single spaces within the selection, story, document or what ever you have selected in the Search: field. If there is any reason you need some instances to remain two spaces or more, don't use Change All. Instead, use find, change, find next, change/find or which ever combination you're comfortable with. You may find that people who hit return at the end of each line also use two spaces after each sentence, which is also a typewriter convention that we don't use any longer in electronic typesetting. This is a good way to fix that problem too.

     

    Also common are two returns to separate paragraphs, which should be done with paragraph spacing, but that's another story, so one step at time.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2013 2:41 AM   in reply to kcookcreative

    Your screen shot is typical of text pasted from an email. Can you get your friend to send you the file as an attachment you can save and place?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2013 8:33 AM   in reply to kcookcreative

    Use space after or space before for setting the spacing between paragraphs.

     

    Mike

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2013 8:36 AM   in reply to kcookcreative

    There are many paragraph attributes. Two of them are "space before" and "space after." The first will add space to the top of each paragraph, and the other will add space at the bottom. Many people use one or the other, or possibly some combination. With these, you only need one paragraph return for each paragraph. You can read more about the features of InDesign in the help files, but many on the forum have recommended Sandee Cohen's Visual QuickStart Guide, which you can find on amazon or where ever you buy books.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2013 11:03 AM   in reply to kcookcreative

    Glad I could help.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points