Skip navigation
Currently Being Moderated

Photoshop Elements 12 Organizer Crashing When Trying To Import Photos

Oct 27, 2013 5:15 AM

Just downloaded and started using PSE 12 Editor and Organizer about a week ago.  (An upgrade fron PSE11).  Today for whatever reason, when trying to import any file, say from my desktop or a download foler, the list of locations to import appears for a second, then disappears. I am unable to do any other action and have to quit or force quit.  In PSE Editor, I am able to open a file, but when trying to save it, I get an error that "Could not complete your request due to a Program Error".  I use a Mac and just recently upgraded to OS Maverick.  Anyone having the same issue or can suggest a potential fix?  I also tried using PSE 11 and run into the same problem.  Thanks.

 
Replies
  • Currently Being Moderated
    Oct 27, 2013 6:27 AM   in reply to bueddro

    Since you are on MAC, you must be getting Adobe Crash Reporter report after crash. Can you please copy paste its content here or share with me through a private message?

     

    Thanks

    Andaleeb

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2013 1:43 PM   in reply to andaleebfatima1

    I too have this and managed to get round it by importing direct from the SD card, it will not look to the folders on the drive at all.

     

    Very irritaing

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2013 2:23 PM   in reply to Barbara B.

    Sill not working unfortunately.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2013 3:08 PM   in reply to Captain Birdseye

    Have you upgraded to mavericks since installing PSE?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 22, 2013 10:23 AM   in reply to Barbara B.

    Hi Barbara B,

     

    Yeah, I have 'upgraded' to Mavericks and it is since then that I have had the issue - all was fine and dandy before.

     

    Really appreciate you taking the time to help.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 22, 2013 10:35 AM   in reply to Captain Birdseye

    It's very important to delete the existing preferences on upgrading to Mavericks.

     

    You want

     

    com.adobe.PhotoshopElements.plist

    Adobe Photoshop Elements 12 paths

    Adobe Photoshop Elements 12 settings

     

    and then for the organizer anything like com.Adobe.Elements Organizer.12.0.plist. You'll find at least two files with the number for the organizer entered differently.

     

    Those files are all in your user>library>preferences folder. Here's how to see it in 10.9:

    http://www.cultofmac.com/251544/mavericks-makes-it-way-easier-to-acces s-your-library-folder-os-x-tips/

     

    While you're in there go to the Saved Application States folder and clean out anything related to PSE.

     

    Repair permsisions and try again.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 22, 2013 2:46 PM   in reply to Barbara B.

    Hi, tried several times without success (on Elements 11). Still need to force quit after trying to import from files.

     

    Maybe I will try again tomorrow and re-start before trying again.

     

    Thanks for your assistance anyway.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 22, 2013 2:59 PM   in reply to Captain Birdseye

    What do you mean by "tried several times without succes"? You couldn't find the files (sorry about the version number in my previous post, but I'm sure you figured that out), or it made no difference?

     

    If you create a new catalog does the same thing happen?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 23, 2013 1:19 AM   in reply to Barbara B.

    Apologies, I was not that specific was I.

     

    I found the files and deleted them (to trash) and it made no difference to the issue I was / am having.

     

    Not sure about the catalogue process though. I will try again later and advise, really appreciate your help and wonder if it is a common problem that may be resolved with an update?

     

    Regards

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 23, 2013 12:13 PM   in reply to Captain Birdseye

    No, it's not a known issue, so we need to figure out what's happening on your machine. To create a new catalog, start the organizer while holding down the shift key. That should bring up the catalog manager where you can create a new catalog. See what happens when you test it with that.

     

    I've been assuming you repaired and optimized your existing catalog as part of your troubleshooting, but if not, try that first.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 24, 2013 2:03 PM   in reply to Barbara B.

    Hi again, I have done these steps (not deleting Adobe Photoshop CS5 settings), should I?

     

    Disk permissions and repairs complete.

     

    New catalogue created and issue persists. All options 'greyed out' only way out is to force quit.

     

    BUT......I have found a way round it - Flie>Get Photos and Videos>By Searching.

     

    So, not resolved at the Import box but managed to make it workable.

     

    Thanks for your help.

     

    Regards

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 24, 2013 4:07 PM   in reply to Captain Birdseye

    I have done these steps (not deleting Adobe Photoshop CS5 settings), should I?

    No, that shouldn't affect PSE.

     

    If you create a new admin user (system prefs>users&groups) and log in there, can you run organizer okay there?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 25, 2013 3:34 PM   in reply to Captain Birdseye

    Please remove me from your address book.

     

     

     

    Mike

     

     

     

    <mailto:grampamk@alum.rpi.edu> grampamk@alum.rpi.edu

     

    If you have other E-mail addresses for me

     

    in your contacts list, please delete them.

     

     

     

    <http://www.pbase.com/mostly_birds> www.pbase.com/mostly_birds

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 25, 2013 5:34 PM   in reply to grampamk

    Mike, it sounds like maybe you've inadvertently signed up for notifications for this thread. To stop them, go to

     

    http://forums.adobe.com/thread/1322862?tstart=0

     

    and look at the right side of the page under the Actions menu. You'll see a place to stop email notifications there.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 7, 2014 2:40 AM   in reply to bueddro

    Hi,

     

    Please go to Help > Updates and install PhotoshopElements 12.1 update available now.

    Let us know if this update resolves your issue.

     

    Thanks

    Andaleeb

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 7, 2014 3:38 AM   in reply to andaleebfatima1

    Thanks. I will try.

     

    Regards

     

    Nev

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 11, 2014 1:28 PM   in reply to Captain Birdseye

    Hi, I am running 11 and there are no updates available. To get round the issue I am importing from the card and am not have any issues.

     

    I may try the import from file method as an experiment in the future.

     

    Thanks for taking the time to reply after all this time, maybe there was an issue?

     

    Regards

     

    CB

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points