Skip navigation
Currently Being Moderated

Ray-tracing & GPU on 12.1

Nov 2, 2013 10:51 AM

Hi,

 

When opening 12.1 I now get this message:

 

Ray-tracing on the GPU requires an approved NVIDIA graphics card

and CUDA 5.0 or later. For now, ray-tracing will be used by the CPU.

 

I have a GTX285 updated to 5.5.28 - any idea what's going on?

 

Thanks.

Branched to a new discussion.
 
Replies
  • Currently Being Moderated
    Nov 2, 2013 1:19 PM   in reply to Norma3n
     
    |
    Mark as:
  • Currently Being Moderated
    Nov 2, 2013 2:21 PM   in reply to Norma3n

    Oops. Sorry. Wrong message.

     

    Let me look into what might be causing yours.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 2, 2013 5:45 PM   in reply to Todd_Kopriva

    Add me to the list as well.  Have AE Creative Cloud (latest release) with an IMac Late 2013 with the following NVIDIA chipset:

    NVIDIA GeForce GTX 780M 4096 MB.  System has 32GB of RAM as well.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 2, 2013 5:49 PM   in reply to Todd_Kopriva

    //Previous post was by previously logged in account. BosleyBeats is having the similar issue.

     

    //REPOST:

     

    Add me to the list as well.  Have AE Creative Cloud (latest release) with an IMac Late 2013 with the following NVIDIA chipset:

    NVIDIA GeForce GTX 780M 4096 MB.  System has 32GB of RAM as well.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 2, 2013 7:36 PM   in reply to Norma3n

    Solved this issue on my system with the following CUDA drivers: http://www.nvidia.com/object/macosx-cuda-5.5.28-driver.html

     

    If you're using a PC, I suggest looking up the equivalent drivers on Nvdia website and give that a try.

     

    Good Luck.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2013 5:49 PM   in reply to Norma3n

    Hi all -

     

    TRY THIS:

     

    #1: open up AE and jump into preferences.

    #2: select the PREVIEWS panel and then GPU INFORMATION

    #3: Select your GPU under the Raytracing dropdown and click the ENABLE UNTESTED, UNSUPPORTED... checkbox

    #4: It still may say 'unsupported', but ignore that and OK everything you just did.

    #5: Shut down and restart AE.

     

    This worked for me. If it doesn't immediately work for you, you might want to throw a system restart after step 5 and see if it "takes" your card.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2013 6:03 PM   in reply to Norma3n

    have you restarted your system lately?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2013 6:18 PM   in reply to Norma3n

    Same screen?

     

    Ok. I am going to assume you are on a Mac. You know how to add your card to the supported card lists? If not, simple version is to "show package contents" when right clicking on AE. In the Contents folder are two txt files that are apparently no longer relevant with the new CC update, BUT I'd throw your card in them anyway. File names are: intel_ogl_supported_cards.txt and raytracer_supported_cards.txt

     

    Add your card as 'GeForce GTX 285'

     

    If that doesnt clear it up or if you've done that already let me know... I'll keep thinking.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2013 6:30 PM   in reply to Norma3n

    Hey, I notice that you still had CPU selected from the drop down. Can you send me a screenshot of what it looks like when you have your GPU selected?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2013 7:40 PM   in reply to Norma3n

    Copy and paste the txt file to your desktop so you can open and edit it there. Then copy it back. Make sure its the same name.

     

    That is just to be sure it doesn't easily solve your problem. It very well may not, but let's eliminate what we can.

     

    Do you have CUDA fully installed? You should be at version 5.5.28 in System Preferences.

     

    Screen Shot 2013-11-04 at 7.39.24 PM.png <<<

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2013 8:39 PM   in reply to Norma3n

    Hey, you made a mistake and placed your card in the UNSUPPORTED ogl .txt file. Remove it from there and put it in the SUPPORTED .txt.

     

    Let me know what happens.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2013 9:01 PM   in reply to Norma3n

    You removed it from the UNSUPPORTED txt though, yeah? You can add in the following txt file by just duplicating any of the others and put your card in it:

     

    intel_ogl_supported_cards.txt

     

    Then restart and let me know what happens.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2013 9:18 PM   in reply to Norma3n

    What is all the code in that file? Pretty sure GPU sniffer is what allows Adobe products to recognize your card. Nothing too special. Here is what My intel_ogl txt file looks like:

     

    Screen Shot 2013-11-04 at 9.17.35 PM.png

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2013 1:00 AM   in reply to Norma3n

    I had your same problem, but I solved it by re-installing again the nvidia driver and the cuda installer.

    now I can select the GPU and the "Enable unsupported..." and everything looks normal again.

    hope it helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2013 5:26 AM   in reply to raffaele mariotti

    > Anymore info Todd?

     

    First of all, there is no reason for any of you to be doing anything with the intel_ogl_supported_cards file. That has nothing whatsoever to do with CUDA and ray-tracing. That is for Intel GPUs only, and it is for OpenGL features. Furthermore, we've stopped checking against that file for anything in the current version. Details are here:

    http://blogs.adobe.com/aftereffects/2013/09/gpu-changes-for-cuda-and-o pengl-in-after-effects-cc-12-1.html

     

    The message that you got is telling you that you either have incompatible hardware or the wrong CUDA driver. Since you say that you have a GTX 285 (which is a supported card), then the issue seems to be the CUDA driver version. I'm looking into why you might be getting that message for a recent CUDA driver. Messing around with text files listing supported cards is not going to get you anywhere.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2013 5:21 AM   in reply to Todd_Kopriva

    simply reinstalling the drivers and the CUDA worked for me, no messing around with the text files is needed.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2013 9:36 AM   in reply to Norma3n

    I'm having this same warning, on a mac. But i have an AMD graphics card, not one of nvidea. Though the warnings states: "requires an approved nvidia graphics card".

    I didn't have that warning before the latest update. I can't select GPU as well in the 'preferences < previews < GPU information' panel

     

    OSX Lion 10.7.5
    AMD Radeon HD 6770M 1024 MB

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points