Skip navigation
Currently Being Moderated

In Export module, Simple watermark does not appear in my photos

Nov 17, 2013 10:15 PM

I make it a habit to always place a simple watermark on all my photos during Export. When i was using LR3 this always worked, but when I recently updated to LR5.2 the Copyright watermark does not show in my photos. I tried several repetitions exporting to .JPEG files, making sure that the Watermarking box is checked. Still, the photos do not show the Copyright symbol and my name.

 

What is happening?

 
Replies
  • Currently Being Moderated
    Nov 17, 2013 10:56 PM   in reply to birderpp

    Try creating a new watermark using Edit Watermarks… and make sure the opacity is 100%, it is a bright color, the font is large and something standard like Arial, and put it in the center of the photo and see if that works.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 19, 2013 5:49 AM   in reply to birderpp

    I've just uploaded an image with a watermark, and it did appear OK in my Flickr photostream.

     

    Have you tried a simple export to your hard drive, using the exact settings as your Flickr service, to check that the watermark is appearing OK? There's an old bug in the watermark process that depends on a combination of font type, export file size, and proportional watermark size....when these all align, the watermark isn't produced. So suggest you check that first before you start investigating a possible Flickr problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 20, 2013 1:55 AM   in reply to birderpp

    Not sure why you checked the metatdata panel, that has nothing to do with watermarks.

     

    What you need to do, as I said, is do a simple export of one of you files, applying your watermark and with the same image sizing settings as you use in your Flickr uploads. Then check the exported file to see if the watermark has been applied. If it has, then the problem likely lies with Flickr, but if it hasn't we'll need to explore your export and watermark settings to try to work out what's going wrong. I thought Arial was an OK font, but I didn't test all possible combinations, which is why we'd need your specific settings.

     

    If this is that old Watermark bug, upgrading the the 5.3RC won't cure it.....I've already confirmed that the bug is still present.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2013 1:32 AM   in reply to birderpp

    The problem is the combination of the use of the "Simple Copyright Watermark" and the fact that you have a blank Copyright field in the metadata. The "Simple Copyright Watermark" defaults to using the data in the Copyright field in the metadata section, which you have said is blank, hence no copyright on your exports.

     

    So either:

     

    1. Populate the Copyright field in the Metadata panel (you should do that anyway), or

    2. Stop using "Simple Copyright Watermark" and create your own watermark using the Edit Watermarks function, which will then include whatever you specify in that watermark.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points