Skip navigation
jimmyswl
Currently Being Moderated

Can anyone upload their ipa files to the latest Apple apps store?

Dec 19, 2013 7:28 PM

Hi everyone, I tried to upload my ipa files to Apple apps store recently but failed. Below are the messages they email to me.

 

Dear developer,

We have discovered one or more issues with your recent delivery for "Altitude236". To process your delivery, the following issues must be corrected:

iPhone 5 Optimization Requirement - Your binary is not optimized for iPhone 5. New iPhone apps and app updates submitted targeting iOS 6 and above must support the 4-inch display on iPhone 5 and must include a launch image with the -568h size modifier immediately following the <basename> portion of the launch image's filename. Launch images must be PNG files and located at the top-level of your bundle, or provided within each .lproj folder if you localize your launch images. Learn more about iPhone 5 support and app launch images by reviewing the iOS Human Interface Guidelines and iOS App Programming Guide.

Though you are not required to fix the following issues, we wanted to make you aware of them:

Missing recommended icon file - The bundle does not contain an app icon for iPhone / iPod Touch of exactly '120x120' pixels, in .png format.

Missing recommended icon file - The bundle does not contain an app icon for iPad of exactly '76x76' pixels, in .png format.

Missing recommended icon file - The bundle does not contain an app icon for iPad of exactly '152x152' pixels, in .png format.

Once the required corrections have been made, go to the Version Details page and click "Ready to Upload Binary." Continue through the submission process until the app status is "Waiting for Upload." You can then deliver the corrected binary.

 

 

I don't know what mean by the "must include a launch image with the -568h size modifier ", I think it should be something related to Apple Xcode?

Then I tried to include the 3 missing icon size and export, and I get these errors.

 

Error occurred while packaging the application:

 

C:\data\Apps\Altitude236\bin-release-temp\AOT\Altitude236-app.xml(147) : error 103: application.icon.image76x76 is an unexpected element/attribute

 

C:\data\Apps\Altitude236\bin-release-temp\AOT\Altitude236-app.xml(149) : error 103: application.icon.image120x120 is an unexpected element/attribute

 

C:\data\Apps\Altitude236\bin-release-temp\AOT\Altitude236-app.xml(151) : error 103: application.icon.image152x152 is an unexpected element/attribute

 

 

Did anyone know what happen to this issue? Any help would be appreciate. Thanks you.

 

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points