Skip navigation
MSTiefreak
Currently Being Moderated

Upgraded from Elements 9 to 12 since upgrading from Windows 7 to 8.1 - Issues with my old psd's.

Dec 20, 2013 12:36 PM

Tags: #elements_9 #elements_12

Hi - in regards to moving up to the newer version of Elements, I find that all the psd files I was in the middle of working with (all of them multi-layered) don't seem to be associated with photoshop anymore.  When I double-click them, windows asks me what app I'd like to open them with.  If I open photoshop I can open the psd files from there, however.

 

I made the change from Elements 9 to 12 because after installing Windows 8.1 the older Elements got weird and "buggy."  I actually would've preferred to keep 9 (so if anyone's aware of "fixes" or "upgrades" for 9 that help it to work better with Windows 8.1, please let me know)!

 

Also, I see that the old layers panel, where I can see all my different layers and move them around to front or back, isn't there.  I did see that it's possible to select "Layers" from the menu, but it's greyed out. 

 

I'm wondering if I somehow "lost" something switching over, and I wonder if there's something I can do to get my psd's to open in Elements more-or-less like they used to.

 

I should say that I jumped from Elements 9 up to 11, so I do realize there have of course been many many changes in the interim (I'd previously made the jump from 5 up to 9) and it'll take time for me to relearn, but this particular issue seems like it might be more of a glitch than me not knowing the new version yet.

 

I should also mention that the psd files don't have an Elements icon anymore - just a white square.

 

Thanks!!!

 
Replies
  • Currently Being Moderated
    Dec 20, 2013 1:16 PM   in reply to MSTiefreak

    If Layers is greyed out it possibly means that you are in Quick Mode. Select 'Expert' and all the options should become available.

     

    Try permanently associating psd files with C:\Program Files (x86)\Adobe\Photoshop Elements 12\PhotoshopElementsEditor.exe and see if that fixes the issue. Instructions here - http://windows.microsoft.com/en-gb/windows-8/choose-programs-windows-u ses-default.

     

    Cheers,
    --
    Neale
    Insanity is hereditary, you get it from your children

     

    If this post or another user's post resolves the original issue, please mark the posts as correct and/or helpful accordingly. This helps other users with similar trouble get answers to their questions quicker. Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 21, 2013 4:09 AM   in reply to MSTiefreak

    Glad to hear it worked. We seem to be getting an awful lot of problems posted this last week with PSE and Windows 8.1 so it's always good to hear back what worked.

     

    Cheers,
    --
    Neale
    Insanity is hereditary, you get it from your children

     

    If this post or another user's post resolves the original issue, please mark the posts as correct and/or helpful accordingly. This helps other users with similar trouble get answers to their questions quicker. Thanks.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points