Skip navigation
Currently Being Moderated

flex in a week: run the mxml but nothing shows

Dec 29, 2013 8:44 AM

hi

I am doing the flex in a week course. Pain in the butt to see the design view is gone but hey no worries.

Anyway, I run the mxml and nothing shows up. I also ran the swf that was produced and yes - empty. However the code seems to be fine so I am confused.

 

</s:Application>

<?xml version="1.0" encoding="utf-8"?>

<s:Application xmlns:fx="http://ns.adobe.com/mxml/2009"

               xmlns:s="library://ns.adobe.com/flex/spark"

               xmlns:mx="library://ns.adobe.com/flex/mx"

               minWidth="955" minHeight="850">

   

    <!-- Exercise 1.01: Setting up your project files -->

   

    <!-- Styles ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -->

   

    <fx:Style source="Styles.css"/>

   

    <!-- Script ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -->

   

   

   

    <!-- Declarations ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -->

   

    <fx:Declarations>

        <!-- Place non-visual elements (e.g., services, value objects) here -->

    </fx:Declarations>

   

    <!-- UI components ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -->

   

    <s:Label x="10" y="34"

             width="690" height="40"

             text="Employee Portal: Vehicle Request Form"

             styleName="titleHeader"/>

   

    <s:Form x="10" y="70">

       

        <s:FormItem label="Employee:">

            <s:DropDownList/>

        </s:FormItem>

       

        <s:FormItem label="Office Phone:">

            <s:TextInput/>

        </s:FormItem>

       

        <s:FormItem label="Mobile Phone:">

            <s:TextInput/>

        </s:FormItem>

       

        <s:FormHeading label="Dates Requested"/>

       

        <s:FormItem label="Pickup Date:">

            <mx:DateChooser/>

        </s:FormItem>

       

        <s:FormItem label="Return Date:">

            <mx:DateChooser/>

        </s:FormItem>

       

        <s:FormItem>

            <s:Button label="Submit Request"/>

        </s:FormItem>

       

    </s:Form>

   

 
Replies
  • Currently Being Moderated
    Jan 2, 2014 8:04 AM   in reply to codeBeastAdobe

    Are you sure you are running the right mxml? Some times doing a clean build also helps. Sometimes the html template files (js files) are missing that cause a javascript error and nothing to load. Usually, project clean build does it. If you right click on the generated swf what does it say?

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points