Skip navigation
ROBOPM
Currently Being Moderated

Generated SSL to MS WORD: Both Word doc map levels (Headings) & PDF Bookmarks are incorrect

Jan 2, 2014 10:39 AM

Tags: #robohelp_8 #pdf_bookmarks

Hello All,

 

Please review the following problem I am experiencing with my WORD output Document Map / PDF Bookmarks,

 

Thank you for your time and assistance,

~PM

 

SOFTWARE VERSIONS: WIN 7, RoboHelp 8, WORD 2007

 

ISSUE: Generating TOC chapters from Robohelp 8 to MS WORD 2007, WORD document map levels (Headings) are incorrect or navigation trees are not consistent. RoboHelp 8->SSL configured and mapped, using a WORD template .dot.

 

SOLUTION GUIDANCE:

The PDF is generated from the word document that, in turn, is created from the RoboHelp 8 project. The PDF generation is configured to use heading styles to create bookmarks. Note: Word styles are mapped to styles defined in the RoboHelp templates however; the resulting document/PDF will generate incorrect or inconsistent bookmarks.

 

PROBLEM ONSET: Unable to determine when this first occurred (I am new to the position). What I did (looking at older generated "PDF's") see that there were no bookmarks; probably due to not having the option in WORD converting/publishing into Adobe 'heading option' checked off.

 

DESCRIPTION: In the Adobe Reader, click on the View->Navigation Panel->Bookmarks (NOTE: this can also be seen in WORD 2007 'Document Map' left pane), user's view: the navigation trees are not consistent.

 

Expected result: The bookmark structure follows the structure of the document where the first level are chapters, second level of the navigation tree are topics, etc.

 

Actual result: The bookmark structure is not consistent and shows things like "Scenario 1", "Figure 1" on the same level as chapter headings.

 

EXAMPLE #1:

Click on the + sign next to the Introduction bookmark;

Expected result: It should show

Introduction

->Introduction

->Support and Training

 

Actual result:

Introduction

->Introduction

  ->Support and Training

 

EXAMPLE #2:

Click on the + sign next to the Preparing for Database Migration bookmark;

Expected result: It should show;

Preparing for Database Migration

->Required Steps for Certain Versions of Financials

->Any version running on SQL Server 7.0

->Version 3.x running on SQL Server 2000

->Version pre-4.3.11 running on SQL Server 2000

->Version 4.3.11 or later running on SQL Server 2000

 

Actual result:

Preparing for Database Migration;

->Required Steps for Certain Versions of Financials

->Any version running on SQL Server 7.0

->Version 3.x running on SQL Server 2000

->Version pre-4.3.11 running on SQL Server 2000

1. Upgrade 4.3.11 or later to 4.6 while running under SQL Server 2000.

2. Upgrade SQL Server 2000 to SQL Server 2005/2008/2012.

->Version 4.3.11 or later running on SQL Server 2000:

Scenario 1

Scenario 2

 

and so forth...

 

EXAMPLE #3:

1) Open PDF

2) In the Adobe Reader click on the View->Navigation Panel->Bookmarks;

 

Expected result: The bookmark structure follows the structure of the document where the first level are chapters, second level of the navigation tree are topics, etc.

 

Actual result: The bookmark structure is not consistent and shows things like "FDP", "2. Click Next." on the same level as chapter headings.

 

EXAMPLE #4 (Visual):

Notice “Step / Action”, this text is coming from RoboHelp as ‘Normal’ Styles and is mapped to WORD as a ‘Normal’ Styles but WORD is reading it as “Outline Level” (Paragraph). See sample WORD screenshots below.

 

ATTEMPTS TO RECTIFY PROBLEM: Note: This is NOT a problem if I generate a single chapter from RoboHelp TOC 'Chapter Layout'. I also tried all the chapters separately and there were no problems. When I generate all 24 chapters from my TOC 'Chapter Layout'  there are issues (e.g., single word like "Step / Action" text, nubered and bullited text become headings).


Sample 1

sample1.jpg

Sample 2

Shown in this sample screenshot I include the HTML from RoboHelp

sample2.jpg

 
Replies
  • Currently Being Moderated
    Jan 8, 2014 2:29 AM   in reply to ROBOPM

    It's difficult to follow this, almost too much information.

     

    My suspicion is this is something to do with the checkbox Maintain HTML Heading Levels. Try setting that. Also see Printed Documentation on my site.

     

    Come back if still stuck.

     


    See www.grainge.org for RoboHelp and Authoring tips

     

     

    @petergrainge

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 9, 2014 5:52 AM   in reply to ROBOPM

    I think the only way I can help on this one is to see the project. Can you share it with me? If you can, eee the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

     

    Send me a separate email pointing me to a specific folder and topic in the source that does not map correctly, also one that does.

     


    See www.grainge.org for RoboHelp and Authoring tips

     

     

    @petergrainge

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points