Skip navigation
Ben_E_86
Currently Being Moderated

FrameMaker 11 not displaying some math symbols—how to correct or work around?

Feb 11, 2014 9:59 AM

Hello,

 

I created a few equations for a manual, and everything displayed correctly. After I was upgraded to a new computer (same OS - Win 7), all the minus signs in the equations I made aren't displaying—all I get are (?)s.

 

I've tried creating a new equation, but the minus symbol still isn't displaying. Strange to me that it's only the minus symbol not displaying; all other operators display correctly.

 

I'm wondering if this is a symbol font issue, or a unicode issue, but after searching the forums all morning (and all afternoon yesterday) I haven't found any information on correcting the issue or working around it.

 

*Update*

 

I had a coworker open the file in question, and the minus symbols all displayed correctly. He is running Frame 11 on XP.

 

-Ben

 
Replies
  • Currently Being Moderated
    Feb 11, 2014 10:24 AM   in reply to Ben_E_86

    What font is being used for the Math symbols? Can you compare the font versions on your machine with that of your co-workers? It sounds like it might be a unicode issue. The default equation configuration uses Symbol, but the unicode version is SymbolStd.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 12, 2014 6:39 AM   in reply to Arnis Gubins

    I'd guess that older FM versions use character code point 2Dh (U+002D, Frame notation \x2d) which is a "HYPHEN-MINUS" in both legacy (8-bit ISO 8859-1) Roman and legacy Symbol (8859-7) fonts.

     

    Is FM11 trying to use Unicode code point U+2212 ("MINUS", \u2212)? If so, that code point simply doesn't exist (is not populated) in the legacy Symbol font (or any legacy 8-bit Roman fonts), and would render as "?". The newer SymbolStd presumably does have U+2212.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 12, 2014 7:05 AM   in reply to Error7103

    The font used for the math symbols is specified in the maker.ini with the MathFamily=Symbol entry in the [Fonts] section.

     

    I've tried playing around with changing this in FM11 and FM12, but I always get the minus sign to appear in both versions. [There is a minor bug in FM12 no longer supporting the backslash sequences, so I was checking if other things were pooched.]

     

    The math characters, on the other hand, are defined in the fminit\mathchar.cfg file, e.g.

      < alpha      61 Symbol Regular>

      < beta      62 Symbol Regular>

      < plus      2b Times Regular>

      < equal      3d Times Regular>

      < minus      d0 Times Regular>

    etc.

     

    Notice that there is a mix of Font Families specified in the cfg file. It could be that if Times is missing and FM doesn't properly substitute proprly, one may get the unknown character.

     

    Try changing the font definitions in the mathchar.cfg file (and make a back-up so that it can be restored if this gets messed up).

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 12, 2014 1:16 PM   in reply to Ben_E_86

    Glad you sorted it out. It probably is an old vs new version of font that's been updated to unicode encoding from the old ansi encodings. Some font names weren't changed when they were updated, such as for Symbol to SymbolStd, so this makes it quite difficult to determine what encoding a font has from the font name alone.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points