Skip navigation
Currently Being Moderated

Contribute cannot verify your connection information

Mar 4, 2009 1:27 PM

I am having a strange issue. I have my website on one Windows 2003 server, Contribute installed on another. Both machines are networked and I have administrator access. My problem is that when I try to set up a connection to the website using Local/Network option, Contribute gives me a "Cannot verify your connection information" error. I have tried making the connection with a standard shared path, e.g. \\Server1\website as well as mapping the network share to a local drive letter.

What does work is when I specify the complete network path, including drive letter, e.g. \\Server1\D$\website

The problem is that in order to map this connection using the drive letter for other users, they all need Administrator access. That's a major security problem.

Has anyone else run into this problem and is there any solution to get Contribute to recognize virtual share paths?
 
Replies
  • Currently Being Moderated
    Mar 11, 2009 7:50 PM   in reply to cs@tradepulse
    I'm having a similar connection issue. Using Dreamweaver / Contribute CS4 on Windows, I also have users using Contribute 3.1 on Mac. I mainly administer in DW but sometimes use Contribute for things that can't be done in Dreamweaver.

    During development of our site we had it on a separate subdomain from our main business application, and connection was never a problem. When we launched the site we kept all the files in the same place we did for development (a separate folder in the web root from our secure business application which shares the same domain/url). We use virtual folders in IIS to point to the appropriate website directories for the pages on the website, so that our application is in one directory and our site is in another, and it's all routed through the same URL and home page. For the first week, everything worked fine.

    Then my Contribute users started getting connection problems, Contribute would say that they couldn't edit certain pages. When I triy to administer the site in Dreamweaver, I get an error saying that Dreamweaver can't connect to the server. However my normal FTP connection works fine.
    When I try to setting up a connection with Contribute, after I enter my username and password, etc it initially connects fine and I can browse the server. But when I choose the folder where my website files are located, Contribute again says it cannot connect. The part that mystifies me is that this was all working fine at one point not too long ago!

    I've tried recreating the connection, deleting the contribute.xml file on the server, and all sorts of variations on the remote folder path. I'm using SFTP. Basically, I can now do nothing with Contribute on the site.

    Can anyone offer any insight? Are the virtual directories the problem? Or might it be something else? I really appreciate any help, my users are getting tired of not being able to edit the site and I'm tired of doing it for them :)
     
    |
    Mark as:
  • Currently Being Moderated
    May 5, 2009 1:21 PM   in reply to raelehman

    I've just started to see this myself... I have Contribute CS4, and when I try and create a site connection, I can't verify my location..

    I've even tried just putting in c:\temp and it doesn't like it. I can navigate just fine to the drive location using the CHOOSE option, and it just won't verify it... Is there a fix for this?

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2009 11:25 AM   in reply to raelehman

    I started seeing this error when we switched hosts which required us to access our site via secure ftp. As you stated, this now renders Contribute as essentially useless. I can edit/administer the site locally on my system but it is tricky because of what Contribute does with path names. Besides, what's the point if I can't make the changes and upload them from the same application.

    Now I have to edit the pages locally using Contribute or some other tool and then an ftp app to load the files to the web server (I use Filezilla which had no problem with the secure ftp credentials). I know that I am probably creating problems for when Contribute does get fixed because I am not transferring all of the Contribute-specific folders and files when I upload the changes.

     

    Not fun. It has held me back from making changes that I should make -- especially now that I see from this thread that other packages have a similar problem.

     

    Any news on this from Adobe?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2009 5:13 PM   in reply to cs@tradepulse

    I have a similar issue,  setting up a website on a VPS. I am unable to get Contribute CS4 to connect via FTP.   I have ran through the check list ,found in the support section, of ftp commands that Contribute uses and manually tested them, all were working fine.  I downloaded an ran ftp server checker, all sections were marked as successful.  I even verified my FTP was on the compatiable ftp list and was able to connect to it with a ftp client. Contribute still refuses to connect even with root access.  Has anyone ran into this problem and found a solution yet?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 11, 2009 11:53 AM   in reply to Threep007

    I was having a similar problem. I resolved it by going to

     

    Edit > My Connections. I then clicked on my website and clicked "Remove" so I can start over and connect with a connection key.

     

    Christine Gharibian

    Marketing Manager

     

    SearchMar,  Inc.

    D: (415)  362.0330 | T: (866) 885.6263 | F: (415) 362.0331

    870 Market  Street | Suite 542 | San Francisco | CA 94102
    SearchMar.com | Blog | LinkedInTwitter

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2009 9:03 PM   in reply to cs@tradepulse

    I found a .htacess file in the main directory with this in it:

     

    RewriteEngine on

    RewriteBase /

    RewriteRule (.*).htm$ /$1.php

     

    I removed the file and I can now connect fine.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2010 2:24 AM   in reply to cs@tradepulse

    Hi,

     

    I had the same issue but managed to solve my problem. The isssue seemed to be the URL that you use for your website needs to be the root directory of your domain ie http://anydomain.com/   If you have something like http://anydomain.com/index.cfm like i did problems seem to occur.

     

    Hope this helps

     

    Chris

     
    |
    Mark as:
  • Currently Being Moderated
    May 11, 2010 12:34 PM   in reply to cs@tradepulse

    Thanks, Virginia; your solution worked for me. 

     

    Removing the .htaccess file (with rewrite and other rules inside) prevented the "Contribute cannot verify your connection information" error and allowed me to finish setting up my site.  However, deleting the .htaccess file was not a permanent solution for my case, as I need those rewrite rules. 

     

    If your site can tolerate some down time, simply remove (or rename) the .htaccess file while setting up the connection, then restore it once finished.  My site continued working after the .htaccess file was restored.  Hope that helps!

     
    |
    Mark as:
  • Currently Being Moderated
    May 11, 2010 12:36 PM   in reply to Virginia Rae Stubella

    Thanks, Virginia; this worked for me.  See my other post for more details.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 31, 2013 3:47 PM   in reply to cs@tradepulse

    Hey folks...I know this thread is a bit old, but I was seeing the same issue and resolved it using a different approach.  It seems that the “Contribute cannot verify your connection information” error is Contribute's "go to" error when anything bad happens.  Thanks for the in-depth error message, Adobe.  In my case, this was happening during the middle of a server migration.  The issue was that Contribute basically asks for 3 pieces of information to get you started:

     

                    1. The web URL for you site (which should look like http://www.contributeisterrible.com

                    2. The method you wish to use to connect (Network, FTP, SFTP)

                    3. The path to your website (on a network, this might look like \\mywebserver.contibuteisterrible.com\wwwroot , whereas on an FTP/SFTP sever, you'd specify the name or IP of the SFTP/FTP server and provide a valid username and password)

     

    Here's the kicker...Contribute seems to care FAR TOO MUCH about the IP addresses returned during this process.  So, in my case (IP addresses have been changed to protect the innocent and all that good stuff), my website was still living on 192.168.10.100, but the site files I wanted to start editing were living on 192.168.10.150.  Contribute won't allow this.

     

    To see if this is your problem when trying to set up a connection, do the following:

                   

                    1. Open a command prompt and ping your website's URL and see what IP is returned (in my example, that would be "ping www.contributeisterrible.com")

                    2. In the same command prompt, ping the server holding your files and see what IP is returned (in my example, that would be "ping mywebserver.contributeisterrible.com")

                    3. The IP's returned from steps 1 and 2 must be the same...if they aren't, Contribute won't connect to the site

                    4. If you're trying to set up an "FTP/SFTP" connection, you'll need to know the name of the server holding your web files...this may or may not be the same as the name of your FTP/SFTP server (in most cases, it isn't since many places separate FTP/SFTP away from web content and web application servers)

     

    If for some legitimate reason the IP's are different (for example, you have a webserver with multiple NIC's or IP's, or you're in the middle of a server migration, or you just want to test something, or DNS is configured such that the web URL returns a different IP than the server name), you can rectify the difference by tweaking your HOSTS file (in Win7, it's at C:\Windows\System32\Drivers\etc).  Just add entries similar to the following:

     

    1. 192.168.10.100  www.contributeisterrible.com
    2. 192.168.10.100  mywebserver.contributeisterrible.com

     

    This will force your computer to see both the server share and the site URL at the same IP address and resolve the issue.

     

    If this doesn't fix ya, well...sorry

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)