Skip navigation
Currently Being Moderated

Issue with XML PDF and AdobeDesigner!

Sep 10, 2008 4:36 AM

Hello!<br />I have a PDF Document!<br />With Acrobat Proffesional Reader i can File -> Export Form Data (Hope this is right in english)<br /><br />A new XML File will be generated<br /><br />The conten of the File<br /><br /><?xml version="1.0" encoding="UTF-8" ?> <br />- <ichicsr lang=""><br />- <ichicsrmessageheader =""><br /><messagetype ="" /> <br /><mailrcpt ="">test@test.de</mailrcpt> <br /><mailbody ="">Test</mailbody> <br /><br />To this Point all works fine...<br /><br />but when i Load up the PDF File in AdobeDesigner, and save it up. (I do no changes at this Point, only Save the file.) and close<br /><br />And then i export second time the xml data with Acrobat Proffesional Reader <br /><br />the conten looks like this:<br /><br /><?xml version="1.0" encoding="UTF-8" ?> <br />- <ichicsr lang=""><br />- <ichicsrmessageheader lang=""><br /><messagetype lang="" /> <br /><mailrcpt lang="">test@test.de</mailrcpt> <br /><mailbody lang="">Test</mailbody> <br /><br />everywhere is written lang?!?!?!?!<br />WHY??? How can I eliminate this effect?!<br /><br />HELP and sorry for my bad english!
 
Replies
  • Currently Being Moderated
    Sep 10, 2008 11:24 PM   in reply to (RobDust)
    Your XML processor should just ignore the tags it doesn't understand -
    no problem.

    It sounds as if you are trying to create a very simplified XML parser
    that looks for text patterns. I advise against this. There are many
    tools designed to parse XML and which will take care of the special
    issues. A simple text approach will collapse the first time someone
    types an ampersand "&" in their text...

    Aandi Inston
     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)