Skip navigation
Currently Being Moderated

Extendscript V3(CS4) Tab Stops

Jan 11, 2009 11:25 PM

Hi,
I have a problem with editing in the new Extendscript which is annoying the hell out of me, and I am suprised that I haven't seen any one else annoyed with it because I doubt the problem is isolated to my PC.
The problem is as follows:
In the previous Extendscript(V2) I could use tabs when writing code, the code would align vertically due to me using these tabs, now In the latest version (V3) the tabs will not align the code vertically and it makes it look all ugly.
My guess for why this is happening now is that it is an over-site in the development of the Extendscript v3 when the editor was updated.
Does anyone have this same exact problem?
Kind Regards,
Ben.
 
Replies
  • Currently Being Moderated
    Jan 12, 2009 5:00 AM   in reply to (Ben_Pettit)
    Works fine for me.

    Dave
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2009 7:20 PM   in reply to (Ben_Pettit)
    Ah, your coding style is completely different from mine.

    How many spaces per tab do you have set in preferences? Are you using a monospaced font?

    Dave
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 21, 2009 5:59 AM   in reply to (Ben_Pettit)
    Ben,

    I always use tabs, never spaces, so I didn't notice. But you seem to be right, I see the following:

    1. Tab stops do not align with spaces.
    2. The number of spaces I set in preferences for tab stops don't have any influence.

    It seems tab stops are placed independent of the width of spaces. Quite annoying if you're using your style of coding.

    Teus
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 21, 2009 6:12 AM   in reply to (Ben_Pettit)
    Teus,

    >2. The number of spaces I set in preferences for tab stops don't have any influence.

    Changing this setting has no effect on the active window, but you see the result when you create a new script file.

    Ben -- I can reproduce the behaviour that you see and it is indeed pretty hopeless.

    Peter
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 21, 2009 8:05 AM   in reply to (Ben_Pettit)
    My impression is that two (or however many you set in preferences) spaces are being used instead of tab characters, so tabs in ESTK CS4 align only at the beginning of lines (which happens to be the only place I use them).

    Dave
     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)