Skip navigation
Currently Being Moderated

Importing Photoshop files into Illustrator CS3

May 6, 2007 11:00 AM

I'm running into a problem in Illustrator CS3 when I try and import a native CS3 Photoshop file. If I try and place the file as a linked file I get an application error stating that there was insufficient virtual memory. And, if I select cancel I get a run time error and Illustrator crashes.

If I try and embed the file I get the same results. It doesn't seem to matter what the file size is and .tif's work just fine up to huge sizes 100Mb+.

As to the system I'm running Windows Vista Ultimate (x64) 8Gb of ram, two SCSI drives with virtual ram assigned to both so memory issues, well, shouldn't be issues.

Anyone got any ideas?
 
Replies 1 2 3 Previous Next
  • Currently Being Moderated
    May 6, 2007 12:52 PM   in reply to (Thomas_Kryton)
    What other programs were you running? And were yu using your sart up disk as your scratch disk?
     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2007 11:40 AM   in reply to (Thomas_Kryton)
    I have the same issue. Whenever I try to place a PSD into Illustrator, it will crash with an "Out of Virtual Memory" error although I have a 250 gig drive and 4 gig of ram.
     
    |
    Mark as:
  • Currently Being Moderated
    May 26, 2007 6:08 AM   in reply to (Thomas_Kryton)
    I have this same issue. Anyone find a resolution?
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 7, 2007 9:39 AM   in reply to (Thomas_Kryton)
    Are any of you using a 64-bit OS? Adobe has been less than helpful, even to the point of suggesting I install Vista drivers on a Windows XP system, but it appears to be a problem with the 64-bit environment. I can import just fine in 32-bit. Adobe says it is the print drivers, but I have 64-bit drivers installed. There doesn't seem to be a workaround for this, so Illustrator is all but useless. You can convert every graphic to .tif and they will import, but it sure is a pain in the butt.
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2007 1:47 PM   in reply to (Thomas_Kryton)
    The report I received from Adobe tech support is that this is a known issue and was unsure if a fix is even being worked on! "As windows 64 bit gains popularity, I'm pretty sure it will be addressed." What a blunder on Adobe's planning!
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2007 2:58 PM   in reply to (Thomas_Kryton)
    It worked in CS, CS1, and CS2. It does not in CS3. There is an implied contract there. I wonder if it works on 64bit Macs? They better get on the bandwagon or they might start losing market share. 64-bit is becoming more common among professionals and it is simply stupid to do this to us.
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 29, 2007 10:35 AM   in reply to (Thomas_Kryton)
    Agreed! I really wish Adobe would fix this!! I purchased CS3, but am forced to use CS2. How dumb is that.
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 29, 2007 11:47 AM   in reply to (Thomas_Kryton)
    Just to clarify, ClickBouyow, CS is CS1.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2007 7:54 AM   in reply to (Thomas_Kryton)
    I think I just came back from the Twilight Zone. I was able to import PSD's and Tiffs into Illy CS3 on my Win XP 64 bit system!!

    I was working in CS2, and thought I would try it one last time in CS3. Low and behold...it worked! Bad news is...I rebooted, and importing files into CS3 no longer works!

    What in the world? Did working in CS2 load some shared file that allowed me to place PSD's into Illy CS3?

    Please...someone come up with an answer to this problem. Illy CS3 is USELESS (and a waste of good money) to me if I can't import PDS's and or Tiff's!

    TIA

    Dean
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2007 9:56 AM   in reply to (Thomas_Kryton)
    It would be nice if Adobe could figure it out. Ill CS3 is totally useless to me.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2007 10:19 AM   in reply to (Thomas_Kryton)
    Same here! I have to use CS2. Give me a refund!
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2007 3:05 AM   in reply to (Thomas_Kryton)
    The system requirements of Illustrator CS3 state that it is certified for 32-bit editions of Vista Home Premium, Business, Ultimate, or Enterprise only.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2007 3:32 AM   in reply to (Thomas_Kryton)
    Galumph, there is an implied compatibility there. If it worked with 64-bit in CS2, it should also work with CS3. Sorry. But that is the simple truth. Adobe does not have to certify it to make it work. That is simply lazy on their part. I am a professional just as they are. I expect a product that I pay for to work. When it does not, then I do not expect Adobe to hide behind excuses. I expect them to remedy the problem. Saying "sorry, we have your money and we are not giving it back because we did not "certify" the software for your OS" is BS.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2007 8:17 AM   in reply to (Thomas_Kryton)
    John and Thomas...well said.

    So how do we get Adobe's attention?
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2007 8:36 AM   in reply to (Thomas_Kryton)
    I don't know. I tried to get Adobe support involved, but they were not interested. I keep hoping someone there will wake up and patch this dog.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 23, 2007 11:16 PM   in reply to (Thomas_Kryton)
    Maybe there's a RAM capacity setting that has to be set, such as the 3GB Photoshop limit?

    d
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 24, 2007 4:20 AM   in reply to (Thomas_Kryton)
    If there is, I am not able to find it. I think it is more to do with how 64bit processors (especially INTEL based) handle memory. Adobe should patch this. It is just bad business to exclude this segment of the industry because they don't want to deal with it. I am now looking for alternatives and they may lose a large customer.
     
    |
    Mark as:
  • Currently Being Moderated
    Aug 7, 2007 12:05 PM   in reply to (Thomas_Kryton)
    Well, add me to the list...I just opened the file I do most of my work in and got an error with all nine linked PSD files. I tried various things, from opening each file in Photoshop CS3 and resaving them, all the way down to creating a simple little Photoshop file and trying to place it by itself, and NOTHING happens...no error message of any kind, no nothing; Illustrator just goes on as if I didn't just tell it to place an PSD files. It worked fine with a jpg, though.

    I have a 64-bit Windows Vista Ultimate machine with 16 GB of RAM installed (because I tend to use such huge files, and 4 GB of RAM, or really 3.5 GB of RAM, just wasn't enough, I needed an OS that could handle more than 4 GB of RAM.

    I checked before I bought my computer to make sure the Adobe products I use would run on 64-bit Windows Vista, and Adobe claimed they would (but only with 32-bit functionality). Okay, whatever, fine by me, as long as they actually run with 32-bit functionality.

    If anyone figures out why I can't place an Adobe CS3 PSD into an Adobe CS3 Illustrator file, I'd love to know about it.

    Chris

    PS. I love that Adobe Spell Check on these forums didn't recognize the word "Photoshop".
     
    |
    Mark as:
  • Currently Being Moderated
    Aug 7, 2007 4:47 PM   in reply to (Thomas_Kryton)
    Adobe get your butts into gear. Same dam thing happens to me on vista 64. I have 8gigs installed. I'm a professional not some half *** hack tooling around with a program. GET THIS WORKING IMMEDIATELY or bye bye Adobe. Dont think your market share will stop me. I'll do it out of spite.

    Support 64bit Vista with NATIVE 64bit code or get the hell out of the industry. You cant hack it anymore if you're playing with 32bit half *** code. Get up to gear. The pros have surpassed your company... unfortunately we are dependent on your programs, but that can change very quick if you do not move quickly.

    Yeah i'm pissed.. I have a deadline i'm going to miss today BECAUSE OF YOU, ADOBE.
     
    |
    Mark as:
  • Currently Being Moderated
    Aug 8, 2007 3:13 AM   in reply to (Thomas_Kryton)
    I seriously wouldn't be putting NEW software anywhere near a job with a critical deadline especially on such a badly supported system. Don't care how many bells and whistles unless there is a new tool I couldn't live without stable is the number 1 priority for work.

    Ok so Adobe needs to fix the bugs but consider your running on a brand new OS, with brand new code on new and different processors with many badly tested drivers. Adobe isn't the only one who should take any blame here.

    BRETT
     
    |
    Mark as:
  • Currently Being Moderated
    Aug 8, 2007 7:36 AM   in reply to (Thomas_Kryton)
    I wouldn't either. But I do expect Adobe to support their software, and the implied contract is still there. OK. it doesn't work. But there appears no desire on Adobe's part to remedy the problem.
     
    |
    Mark as:
  • Currently Being Moderated
    Aug 9, 2007 4:18 AM   in reply to (Thomas_Kryton)
    when i importing a psd file with spot channels to illustrator cs3, spot channels are appears a single composit channel. They arent separating but printing correctly. i need to see channel by channel for some reason. Please help.

    mehmet ali
     
    |
    Mark as:
  • Currently Being Moderated
    Aug 13, 2007 4:18 PM   in reply to (Thomas_Kryton)
    Ok, so ADOBE needs to get up off their a$$e$ and address this problem, However some of you guys make it sound like its the end of the world... Here's a way to go around it in the meantime- at least this is how my PC is reacting (you might not be as lucky, but worth a try)

    After getting my "insufficient virtual memory" error, try closing Illustrator down and then open the file from the OS window (not from within illustrator or browse)by double-clicking the file you'll automatically open Illustrator,it might take a couple of tries but after my second attempt it opened my file (took a little long) and I got a different error message "there was an error with the embeded file what do you want to do - replace file, correct file, ignore file, cancel" (msg not verbatim but close - not at my comp right now)
    Then just ignore the files delete the links (they'll show up as blank boxes) If your just using those embedded psd's for previewing purposes you'll just have to save a flattened tiff everytime you make a change and keep saving over that same tiff so illustrator will automatically update it to you illustrator file.

    sorry for the long post, but hopefully it helps ease the pain!

    -salvador
     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2007 8:05 AM   in reply to (Thomas_Kryton)
    I am running XP pro with my CS3. I only have 2 gigs of RAM. I was able to place a 232 MB PSD file into my Illustrator file. It has a few problems with saving (one time it sat saving for 5 minutes and didn't actually save), but now it seems fine. It's slow to work with because of the size but all else seems fine.

    I haven't had too many problems with CS3 at all, and I don't think all the problems some these people are having are Adobe's fault. There are so many other factors as someone else already stated.

    -Jason
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 22, 2007 7:00 PM   in reply to (Thomas_Kryton)
    OK - I just found a fix for this - well, rather a workaround. Im running Vista 64 Ultimate, with 4GB of RAM. Since the majority of the people reporting this same issue has similar specs, I decide to try running Illustrator in 'compatibility mode' for WinXP. To do this, right-click on the illustrator.exe (or shortcut file), and click properties. At the top, click on the "Compatibility" tab, then check the box next to "Run this program in compatibility mode for:" I selected Windows XP (SP2).

    After this, I can view and place .psd files no problem. I'm not sure why this works, but it does... So until Adobe addresses the cause of this (Im sure it has to do with Vista 64), we have to do this...
    Hope this helps!

    -Ryan
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 23, 2007 5:32 AM   in reply to (Thomas_Kryton)
    Well, I'm just writing to say I tried this and it worked! So thanks very much for the tip, Ryan.

    Of course I had already converted all my PSD files to a different format at great expense and expenditure of time. ;-)

    But still, it does work for those of you who have put off projects involving PSD files. I should've thought of that...I've had to run one or two other programs in compatibility mode to make them work, I should've tried that.

    Thanks again!
    Chris
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 23, 2007 5:44 AM   in reply to (Thomas_Kryton)
    I am having the issue with WinXP 64-bit. Doesn't work for me.
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 23, 2007 5:57 AM   in reply to (Thomas_Kryton)
    Hmm. I don't know much about WinXP 64 - Im not sure if it's compatibility mode works in a similar fashion as Vista's. Perhaps this issue is caused more by a WOW64 issue than the Vista Aero Glass... This would be supported by the fact that simply turning off Aero didn't cure the issue to begin with...

    The only thing I would try (if you haven't already) is to select older and older versions of Windows in the compatibility mode section... At least, Vista allows you to choose anywhere from XP SP2 down to Win98. You may also want to check to see if there are any Windows updates that may affect the functionality of WOW64 in XP64...

    I hope you can get it figured out!
    -Ryan
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 23, 2007 7:19 AM   in reply to (Thomas_Kryton)
    That won't work. Illustrator CS3 will not work in earlier versions of Windows (I tried Windows 2000 and WindowsNT).
     
    |
    Mark as:
  • Currently Being Moderated
    Dec 19, 2007 7:57 AM   in reply to (Thomas_Kryton)
    Ryans suggestion to run CS3 in XP compatibility mode worked for me. I just love it when we do Adobe's work for them. Wish someone could do my design work for free. Thanks Adobe!
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 7, 2008 9:21 PM   in reply to (Thomas_Kryton)
    I'm running Windows XP Pro 64bit and, like ClickBouyow, the workaround suggested by Ryan, i.e. changing compatibility settings didn't work for me either. Hey ClickBouyow, did you have any luck since last October?
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 8, 2008 6:22 AM   in reply to (Thomas_Kryton)
    Hi lionell -

    Try checking the "Disable desktop composition" box, located directly below "Run this program in compatibility mode for:" selection menu. If that doesn't work by itself, try it in conjunction with the compatibility mode set to WinXP, Win 2000, etc.
    Hopefully this will give you a result!

    -Ryan
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2008 4:35 PM   in reply to (Thomas_Kryton)
    Hi Ryan,
    Is the "Disable desktop compostion" box an option in Vista? I don't see it in XP64. What I see below the "Compatibility mode" section is the "Settings" section and the nearest thing I could find in that section is "Disable visual themes" option. I tried that with and without the compatibility mode on for WindowsXP. Still the problem persists. BTW you can't set compatibility below WindowsXP, Illustrator will not lauch if you do (you get an error message which reads "Adobe Illustrator cannot run on this computer because the minimum system requirements is Windows XP."
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2008 3:29 AM   in reply to (Thomas_Kryton)
    Same here, winXPx64, 4gb, amd x2 6000+

    There are other bugs - Flash crashes, Updater does nothing and I have to update manually... I hope the money I paid for CS3 Upgrade made at least somebody a bit happy, because I am far from being happy. Quite the opposite... the flower icon of Illy CS2 is back on desktop, flash was replaced by cracked demo (that actually works - don't ask me why) and I am really pissed off.
    CS2 worked on x64 just fine, so I do not see any reason why do I have to fight so many beta release issues... microsoft policy of beta release candidates, adobe?
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 15, 2008 12:44 PM   in reply to (Thomas_Kryton)
    XPx64, 4GB, Dual Xeon 3.4GHz.

    For me, if I load in a file as linked, it just dismisses the place dialog as if I'd hit cancel. If I embed, it shows a note that I don't have enough memory.

    I've been using this system for a while now and previously having less problems with this. I created several files with placed documents, but now it has gone south... so I now have several CS3-formatted AI files with placed PSDs that won't load ("An error occurred trying to read the linked file...").

    Tried the compatibility settings noted above, no effect on the problem. Not sure what else to do here. While I've had enough other problems with XPx64 that I would not buy it again, it's not an option at this point to not use it.
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 28, 2008 1:45 PM   in reply to (Thomas_Kryton)
    I'm having the same problem with Illustrator CS3 13.0.2 on Windows XP x64 with 10gb of ram. This very frustrating and dissapointing. It appears that this problem has been around for more than six months without any fixes from Adobe.
    I used to work at Adobe as a programmer, so this is doubly aggravating. The Illustrator code base was widely regarded as a complete mess, but they've had ten years to clean it up so that's not a good excuse anymore. I would rather that placing images work with somewhat downgraded features than not work at all.
    A lot of people use 64bit versions of Windows to compensate for memory limitations in Photoshop, so Adobe should really address this problem quickly.
    My assumption is that they are working on a 64 bit version which will be then sold as CS4, at the expense of fixing bugs in CS3, so we'll probably have to shell out more cash to get something that sort of works...
    In the mean time, AAAAAARRRRHHHGGGG! #@&^%$&^%#!!!!!
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 28, 2008 2:15 PM   in reply to (Thomas_Kryton)
    While there seems to be a workaround for Vista-64, there does not seem to be one for XP-64.
    The import photoshop file issue in Vista-64 seems to be tied to disabling the 'desktop composition' feature of Windows Aero (which is why running Illustrator CS3 in compatibility mode also works - it effectively disables that feature as well).

    As for XP-64, this obviously isn't the same issue. It must be caused by something else altogether... The question is, what is it?
     
    |
    Mark as:
1 2 3 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)