Skip navigation
Currently Being Moderated

AI CS4 Keyboard shortcuts not working

Jan 26, 2009 10:49 PM

Hi to all,

Today while working on Illustrator CS4, I tried to Move a shape while drawing it using the spacebar-drag shortcut, but didn't work. I use that trick a lot, and it's annoying not having the option to use it.

I already deleted the AI preferences with no effect. I use a Wacom Intuos 3 Tablet and deleted their preferences and still not working. Also almost all of the other shortcuts are not working at all.

Any ideas?

Using Windows Vista Home Premium 32 Bit
Nvidia GeForce Go 7600 256 Mb
2 Gigs of RAM
Intel Centrino Duo T2050

Please help :(
 
Replies
  • Currently Being Moderated
    Jan 26, 2009 11:51 PM   in reply to sandesign
    Are you using multiple languages (Spanish/English) on your system? If so, you may have inadvertently triggered Windows' region settings switching and then the shortcuts may be affected in mysterious ways...

    Mylenium
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 30, 2009 9:42 AM   in reply to sandesign
    (great, the new login thing made me lose my post... thanks a lot :D)

    Having the same issues here. While writing normal text is fine, once it comes to the shortcuts several keys are messed up (i.e. Ctrl + ; is Ctrl + /, which equals nothing).

    Using Windows XP in Portuguese and CS4 in English. Disabled the region settings a long time ago.

    Workaround so far has been to simply edit the keyboard shortcuts, but this sure is annoying.
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 30, 2009 9:45 AM   in reply to sandesign
    Oh, btw, the shortcuts work just fine in Photoshop CS4.
     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2009 8:36 PM   in reply to coningham

    Have there been any workarounds on this issue, besides simply changing all erroneous key assignments?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2009 2:45 AM   in reply to coningham

    Not that I'm aware. What you are encountering specifically still boils down to the programs picking the wrong Unicode ranges and/ or the operating not correctly setting input device mapping, which is even deeper surgery than just changing the shortcuts in the program itself. ;-) If you can, you could post a dump from your system info Utility here plus possibly the install log for AI. This may provide pointers, if not the wrong shortcut files were installed to begin with due to the installer not recognizing your locale settings, but from my view, that's the extent of what we as Experts can do. We may be closer to "the powers", but not that close to know everything ;-)

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2009 1:50 PM   in reply to sandesign

    Hello Sandesign,

     

    The problem is another CS4 bug. PC and Mac user have the same problem:

    http://forums.adobe.com/message/1251780#1251780

    In this discussion offers a work around for Mac user. Hopefully works for PC users. I hope this helps!

     

    Here is another discussion with the same problems you are having:

    http://forums.adobe.com/message/1268264#1268264

    This one is PC users comments.

     

    Please let me know when Adobe provides a CS4 update.

     
    |
    Mark as:
  • Currently Being Moderated
    May 7, 2009 2:55 PM   in reply to Mylenium

    A little late on the reply but...

    Mylenium, is this what you are talking about:

     

    Components:
    ACE 2008/08/27-18:10:41 53.355610 53.355610
    Adobe Linguisitc Library 4.0.0
    AdobeLM 3.0.11.10077 (BuildVersion: 53.352460; BuildDate: Tue Jul 29 2008 16:47:08) 53.352460
    FLEXnet Publisher (32 bit)
    Adobe Owl 2008/08/12-18:12:12 2.0.69 53.353913
    Adobe Owl Canvas 2.0.69 53.353913
    PDFL 2008/07/29-20:24:25 53.199969 53.199969
    Adobe Product Improvement Program 1.0.0.220
    AdobePSL 53.497547_11.497538 53.497547_11.497538
    Adobe Updater Library 6.0.0.1452 (BuildVersion: 52.338651; BuildDate: Wed Apr 16 2008 19:28:20) 52.338651
    Adobe XMP Core 4.2.2 53.351735
    Adobe XMP Files 4.2.2 53.351735
    Adobe XMP Script 4.2.2 53.351735
    Adobe CAPS 2,0,99,0 2.135373
    Adobe EPIC 3.0.1.10077 (BuildVersion: 53.352460; BuildDate: Tue Jul 29 2008 16:47:08) 53.352460
    Adobe EPIC EULA 3.0.1.10077 (BuildVersion: 53.352460; BuildDate: Tue Jul 29 2008 16:47:08) 53.352460
    AFL 1.0
    AFlamingo 2008/07/09-11:28:44 53.350580 53.350580
    AGM 2008/08/27-18:10:41 53.355610 53.355610
    AdobeHelp Dynamic Link Library 1, 3, 11, 0
    AIPort 1.0 23.68434
    AMTLib 2.0.1.10077 (BuildVersion: 53.352460; BuildDate: Tue Jul 29 2008 16:47:08) 53.352460
    AMTServices 2.0.1.10077 (BuildVersion: 53.352460; BuildDate: Tue Jul 29 2008 16:47:08) 53.352460
    ARE 2008/08/27-18:10:41 53.355610 53.355610
    Adobe Illustrator 1.0
    AsnEndUser Dynamic Link Library 1, 6, 0, 8
    Unknown Name
    AXE8SharedExpat 2008/06/11-20:19:53 NFR 53.348206 53.348206
    AXEDOMCore 2008/06/11-20:19:53 53.348206 53.348206
    AXSLE 3.3 1.242790
    BIB 2008/08/27-18:10:41 53.355610 53.355610
    BIBUtils 2008/08/27-18:10:41 53.355610 53.355610
    CoolType 2008/08/27-18:10:41 53.355610 53.355610
    AdobeCrashReporter 3.0.20080806
    ExtendScript 2008/07/28-19:31:09 53.352300 53.352300
    Adobe XMP FileInfo 4.2.2 53.351735
    FilterPort 1.1 52.
    FLEXnet Publisher (32 bit)
    Microsoft® Windows® Operating System 5.1.3102.3352
    International Components for Unicode 2008/03/20-16:33:10  Build gtlib_1.1 CL#7223
    International Components for Unicode 3, 4, 0, 0
    International Components for Unicode 2008/03/20-16:33:10  Build gtlib_1.1 CL#7223
    International Components for Unicode 2008/03/20-16:33:10  Build gtlib_1.1 CL#7223
    International Components for Unicode 3, 4, 0, 0
    International Components for Unicode 2008/03/20-16:33:10  Build gtlib_1.1 CL#7223
    JP2KLib 2008/06/11-20:19:53 53.100857 53.100857
    Intel(r) C Compiler, Intel(r) C++ Compiler, Intel(r) Fortran Compiler 10.0
    LogSession 2, 0, 0, 611
    Transport Dynamic Link Library 2, 0, 0, 1211
    Transport Dynamic Link Library 2, 0, 0, 716
    LogUtils 1, 0, 0, 06052006
    MPS 2008/07/07-10:33:04 53.350311 53.350311
    Microsoft (R) Visual C++ 6.00.8168.0
    Microsoft® Visual Studio .NET 7.10.3077.0
    Microsoft® Visual Studio® 2005 8.00.50727.762
    Microsoft® Visual Studio .NET 7.10.3052.4
    Microsoft® Visual Studio® 2005 8.00.50727.762
    Microsoft® Visual C++ 2.10.000
    Microsoft® Visual C++ 4.00.5270
    PDFPort 2008/08/20-20:15:08 53.354855 53.354855
    Adobe PDFSettings 1.04
    Adobe Photoshop CS4 CS4
    Adobe(R) CSXS PlugPlug Standard Dll (32 bit) 1.0.0.71
    Registration 2.0.1.10077 (BuildVersion: 53.352460; BuildDate: Tue Jul 29 2008 16:47:08) 53.352460
    Adobe India Sangam Core Code 2008/07/17-10:11:31 53.102428 53.102428
    Adobe India SangamML Import from Sangam 2008/07/17-10:11:31 53.102428 53.102428
    ScCore 2008/07/28-19:31:09 53.352300 53.352300
    Microsoft® Windows® Operating System 6.00.2600.0000
    SVGExport 6, 0, 0, 305507 1.305507
    SVGRE 6, 0, 0, 305507 1.305507
    WRServices Friday May 30 2008 7:18:42 Build 0.7713 0.7713
    ATE

     

    OS: Windows
    Version: 5.1
    System Architecture: x86
    Built-In Memory: 2047 MB

     

    ?

     

    The worst part of having to change some of the shortcuts - fortunately I don't have issues with all of them! - is when another command already uses the combination that I'm trying, and then I have to go and locate it first, change it to something else, then go back to where I was before. Too lazy to do that or too in a hurry to go through the process while working =D

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 26, 2009 8:41 AM   in reply to sandesign

    same issue here.

    I really am hating this Adobe stuff. Trying to use Illustrator CS4 on a macbook C2D, english.

     

    Shortcut in question:

    Spacebar - does not change to hand (but the H key does)

    Option key - CANT be used to make copies while dragging. Cant use it with the reflect tool either.

    {BTW, these same short cuts work for me in Photoshop Elements.}

     

    I think this is mandatory to be able to place copies of the same object in a perfect circle in Illustrator.

     

     

    1. I trashed my 3 preference files for illustrator, restarted the app while holding down the SHIFT+ OPTION (LOL) + COMMAND keys.
    2. I also repaired disk permissions, but that did nothing.
    3. Any other 'solutions'?
     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2009 9:00 AM   in reply to oldfashnglzdoughnut

    Do you have any processee running in the background like Quicken scheduler, a VPN, Microsoft Entourage or any other process which holds an open port on the internet? These are some of the applications which can cause the OS to block modifier keys. Try opening the Activity Monitor and kill any suspect process and then retry in AI.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2009 10:01 AM   in reply to oldfashnglzdoughnut

    I'm having the exact same issue and have no idea how to fix this.  I am on a iMac.

     

    I really am hating this Adobe stuff. Trying to use Illustrator CS4 on a macbook C2D, english.

     

    Shortcut in question:

    Spacebar - does not change to hand (but the H key does)

    Option key - CANT be used to make copies while dragging. Cant use it with the reflect tool either.

    {BTW, these same short cuts work for me in Photoshop Elements.}

     

    I cannot function without these shortcuts.  I really need a resolution.
     
    |
    Mark as:
  • Currently Being Moderated
    Mar 24, 2010 9:37 AM   in reply to BandwagonMerch

    I have CS4 on an imac and every one of the shortcuts here are not working. WTF Adobe and Wacom should have this fixed together. Both companies should be fixing this mess along with Mac. Industry standard-Right. They all are loosing respect here! We need these shortcuts to work!!!!!!!!!!!!!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 25, 2010 3:25 PM   in reply to sandesign

    I and another designer at work just started having the same exact problem. I lose the set of shortcut keys most often used both in Illustrator and InDesign. Photoshop has been fine. We've been using CS4 for a long time and this problem just started appearing about a month ago. We tried a lot of different things. Keyboard changups/Entourage/Preferences/Scripts. Nothing has worked. The problem comes and goes sporadically. Also the only solution to gain back the shortcuts we have found is a system restart. This however is not realistic and only fixes the problem until it decides to come back.

     

    This problem is very hindering and wastes a lot of work time. I've never had this sort of problem with Adobe products beofre. It's very dissapointing and has lowered y expectations of the company. Hope to see a patch or solution out asap from Adone for this. I see a lot of people are having the same issue.

     

    Mac platform

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2010 10:47 AM   in reply to sandesign

    This has been happening to me for a while. What I did to fix it (temporary) is to erase the preferences by clicking option-alt-shift while opening the program. Then restart your mac and then the shortcuts are back.

     

    The problem is that I have to do this everytime I want to use illustrator and Adobe support has not any answer yet of how to fix this situation.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2010 11:32 AM   in reply to sandesign

    By the way, I just discovered that turning off DropBox (if you use it) cause the problem with illustrator shortcuts. Turn it off and Ai may work.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2010 12:08 PM   in reply to hectoplasma

    What eactly does DropBox do for you? If it is a Share app as I think, then it falls in the category of something which would be blocked by the OS to prevent System calls from outside.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2010 1:43 PM   in reply to Larry G. Schneider

    I use dropbox to share docs between office and home computer. is weird how when dropbox is on, illustrator loses their shorcuts and I have to delete the preferences and restart every time. I read that applicactions like VPN or Quicken do a similar effect in Ai, so checking OS activity process, turning off dropbox, Ai works fine then.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 15, 2010 2:34 PM   in reply to sandesign

    I have been fighting this same problem at work for about a month now and it's really cutting into my production time.

     

    I have been noticing that I seem to lose my shortcuts shortly after I log on to check my e-mail on the Hotmail website but assumed it was just a coincidence.

     

    Today I lost them immediately after I logged on, so I thought I'd try closing the Hotmail site and voila!...the use of my shortcuts returned!!

     

    Go figure...

     

    Oh, and I'm using a Mac G5 tower. I always thought that Microsoft was evil...now I have proof.  :-)

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 16, 2010 7:50 AM   in reply to psycle03

    humm! That proves that hotmail sucks information from our computers while we are connected...

     

    As long as I know, Illustrator shortcuts fails when another application is transfering data in the background as VPNs or Drpboxes.

    One question.. when you closed hotmail, shortcuts returned after restarting Ai or inmedaitly after?

     

    OK

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 16, 2010 8:46 AM   in reply to hectoplasma

    It was immediately after I closed the window in Firefox.

     

    Didn't restart anything, and Firefox was still running.

     

    Actually just tested it again and it did the exact same thing!

     
    |
    Mark as:
  • Currently Being Moderated
    May 4, 2010 8:26 AM   in reply to sandesign

    That is very true! As soon as I close hotmail, inmediatly Ai shortcuts come back!

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2011 9:15 AM   in reply to sandesign

    Hi colleagues out there!

     

    I finished setting up my new system

     

    Thinkpad T61

    Windows 7 64bit (german)

    Creative Suite CS 5.5 (english)

    Wacom Inuos 4 (latest driver)
    Firefox 5 RC
    Office 2010

     

    And if have the same REALLY ANNOYING bug here ...

     

    Sometimes (and this is anUNDERstatement) ...
    the Ctrl (Strg in german) Button stops working correctly in Illustrator !!!

     

    Working (not) correctly means:

    Illustrator seems to "know" that I'm pressing ctrl because it switches the actual tool back and forth to the selection tool if i press/release ctrl ...
    BUT NONE of the Ctrl-Shortcuts are working anymore ....  

     

    In every other Application (including Photoshop / Indesign) it works right/fine

     

    It seems to have no further dpendency which other Applications are open ... sometimes it JUST STOPS working ... doesnt matter if i
    restart the system
    Reset the Wacom Driver
    closing Firefox ...

    whatever ...

     

    then after a while it works again ... this bug is really cutting deep into my productivity !!!

     

    Are there any solutions out there ???

     

    Thanxx a lot in advance


    AlexxJ

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)