Skip navigation
Currently Being Moderated

Tried to compile sample 'qpac_email', got error message 'No QLC instance found.'

Jul 28, 2006 12:21 AM


I configured Eclipse to develop custom QPACs as described in 'developing_custom_qpacs.pdf' in the SDK 7.03. Then I tried to compile one of the SDK samples 'qpac_email'. I included the java mail library, everything compiles, I only get 4 warnings from JUnit.

Unfortunately, testing the QPAC in Eclipse fails. I get the following exception: No QLC instance found.

Does anyone know, what I did wrong?

  • Currently Being Moderated
    Jul 28, 2006 4:57 AM   in reply to (Steve_Woodruff)
    You need to copy the file "qlc-config.xml" from the qlc subdirectory of the workflow designer, into the root directory of your Eclipse installation.
    That should fix it - let me know if it doesn't.
    This is documented on page 21 of the "Developing custom qpacs" guide.

    Mark as:
  • Currently Being Moderated
    Jul 30, 2006 4:19 PM   in reply to (Steve_Woodruff)
    It may be some sort of version conflict, but I think more likely versions of libraries, rather than versions of JUnit.
    What version of Workflow are you trying to connect to?
    Could you please post the entire stack trace you're getting?
    Please make sure that the Workflow jar files you've added to the path of your project are the same as the ones that exist in the lib directory of your Workflow Designer.
    There is an ant target called copy_libraries" that will help you to copy the required files into a "LIB" directory.
    Also, are you able to run the QPACTester - there should be a run target created for you to do this?

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)