Skip navigation
Currently Being Moderated

causes of "plugin entry point could not be found"

Jul 1, 2007 2:30 PM

Hi,

I had a report from a user of my most popular plugin (i.e., mature and extremely well tested), that it failed to work for him on Photoshop CS3 Extended + Vista Business 32-bit.

The error message when he used the plugin was "Could not save as ... because the plugin entry point could not be found."

Is there anything new about CS3 Ext that might cause this? (The plugin is known to be compatible with Vista.)

I have not had other reports like this, so I am currently concluding it's an oddity of his installation.

--Toby
 
Replies
  • Currently Being Moderated
    Apr 11, 2008 6:15 PM   in reply to qu1j0t3
    I tried running it as an administrator (by right-clicking the program and selecting such) and am still having the same problem. I don't have a "remote" desktop, I don't think. I am on my local computer in the livingroom. Is remote and local the same here as web definitions??? So, any suggestions? I am on Vista 32-bit, PS CS3.
    I just want to update the .ico for my website :(

    Thanks!
    Allison
     
    |
    Mark as:
  • Currently Being Moderated
    May 4, 2008 10:27 AM   in reply to qu1j0t3
    Toby,

    Thanks for the rebooting tip. I was able to save as an .ico with no error message.

    Cheers,
    Jacob
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 3, 2008 9:24 PM   in reply to qu1j0t3
    Toby,

    I was able to correct this problem. After installing the ICO (Windows) plug-in in Vista (32 or 64-bit), the user will have to log into a Vista profile with administrator access. Navigate to the Plug-Ins > File Formats folder where the "ICOFormat.8bi" plugin is visible.

    Right-click on the plug-in to bring up the dialog box, click properties and at the bottom of the dialog box you will notice the message "This file came from another computer and might be blocked to help protect this computer." Click "Unblock", "Apply" and restart the computer.

    The plug-in should work after the above steps have been completed.

    Thanks to all,
    Jas
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 5, 2008 7:11 PM   in reply to qu1j0t3
    Until tonight I was using .ico file format with my Vista and Photoshop CS3. Why suddenly today I am getting error message, any idea?

    And sure, I checked and plugin, there in correct file so what is the problem? How can I fix?

    Here is the error message:

    "Could not sae as x.ico because the plugin entry point could not be found."

    Thanks from now
    Linda
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2008 4:57 PM   in reply to qu1j0t3
    Hi Toby,


    I tried 3 times again tonight and tired of really; and still getting same error :(

    Give me some idea what can I do?


    Best,

    Linda
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 7, 2008 1:38 PM   in reply to qu1j0t3
    I tried reboot then reinstall, because above recipe not matching with me, I checked for trying that above recipe too but not any message for about blocking etc, so above recipe not for me...

    Interesting Part is my ICO FORMAT Plug-in, until last night was working perfectly with same Vista same computer. I added some new Brushes and Styles last few days, I don't think this can effect but again wonder, is that possible to something effect that, because of I added 200 - 300 new brushes/styles and now ICO FORMAT Plug-in not working??

    If anybody has any idea, please share with me...

    Best,
    Linda
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 7, 2008 1:42 PM   in reply to qu1j0t3
    Or Vista or Photoshop CS3 did any updates these days, so was that effected the ICO FORMAT Plug-in?
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 7, 2008 8:35 PM   in reply to qu1j0t3
    Hey, for those that dont have the "unblock" dialog, I have another solution that is pretty much the same but worked for me.

    - click properties on the icoformat.8bi file
    - click on the security tab
    - click on the Users, then the advanced tab
    - although it might say allow next to users, you still have other options you have to check.
    - click on users again, click edit
    - another box that pretty much looks the same will pop up,
    - click users again, click edit
    - click Allow on the first checkbox that says 'Full Control'
    - Click ok through all boxes
    - be sure to restart computer or changes will not take effect
    - open photoshop and try saving. it worked for me.

    Please let us know if this solution helped anyone, so we can help assist others.

    -Alban
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 9, 2008 7:09 PM   in reply to qu1j0t3
    Alban,

    Thanks for your help but unfortunatelly not worked for me....

    But again thanks for sharing your experience with us...

    Best,
    Linda
     
    |
    Mark as:
  • Currently Being Moderated
    Dec 11, 2008 12:42 PM   in reply to qu1j0t3
    Jas and Alban, I had to use both your solutions to get it to work, plus a little extra.

    http://www.adobeforums.com/webx?224@@4acff5cb@.3bc4549f/5
    http://www.adobeforums.com/webx?224@@4acffd9c@.3bc4549f/14

    I had to check the "Unblock" under Properties and follow Alban's steps under the Security tab. And yes, you will keep going through User pop ups that all look the same and keep checking "full control". However, I also had to add a new user, which was my computer login account and give it "full control" and that's what made it finally work.

    Thanks for the help! I was beginning to think this wouldn't work on Vista!
     
    |
    Mark as:
  • Currently Being Moderated
    Mar 4, 2010 9:15 AM   in reply to qu1j0t3

    This solution appears to work at first, but all it does for me is

    crash CS4 every time I try to save in .ico format.

     

    Message was edited by: JohnDoe10

     

    Ok this solution worked for me once I rebooted Thanks qu1j0t3's

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 4, 2010 2:28 PM   in reply to JohnDoe10

    G'Day All,

     

    I am currently working with Photoshop CS4  on Windows XP SP3.  After reading through each of the noted solutions, I have tried each one until I found a solution that was viable.   Although I have two units with the same OS and application, the solution  that worked for me on the unit that was experiencing the issue was installing the new *.ico application.  After the first use, it worked; but the second use crashed the application.  After a reboot, it seems to work fine.

     

    Thank you all for your efforts in helping resolve this issue.  I hope this information helps someone else.

     

    Regards,

    Rob

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 21, 2010 8:48 AM   in reply to qu1j0t3

    Jas_Smith workaround above in this thread worked as a charm for me, greeeeeat! Thx a lot!

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 11, 2011 3:10 AM   in reply to qu1j0t3

    Today is 4/11/2011.

     

    I used the .ico plugin 4 days ago without any problem.

    Then, suddenly tonight it would not work.

     

    The post above by "Jas_" correctly identifies the problem as a "file permission issue".

    I am running Windows 7 64 bit with Photoshop Elements 7.0 and this version of the .ico format plugin.

     

    For some reason the "permissions" for the group "Users" on the ICOFormat.8bi file (located at: \Adobe\Photoshop Elements 7.0\Plug-Ins\File Formats\ICOFormat.8bi) were "read and execute", but not "Full control".  once I changed the settings back and restarted the computer, I was able to "save as .ico" again with no problem.

     

    (mostly) STEP BY STEP INSTRUCTIONS for Windows 7:

     

    1. Locate your "ICOFormat.8bi" file

    • Navigate to Drive Letter (usually C:), Program Files, Adobe, Adobe Elements (what ever version you are using), Plug-Ins, File Formats, and voila... ICOFormat.8bi should be in this folder. (if it is not, then the plugin is not installed, or not installed correctly (see this link to install))    

    2. Right Click the ICOFormat.8bi File and select Properties.

     

    3. Select the Security Tab

     

    4. Click the "Edit" button beneath the "Group or user names:" box.

     

    5. Click on each group and determine whether the "full control" check box is checked in the "allow" column.

    • In my case, the "users" group was allowed to "read and execute", but did not have "full control"

     

    6. If each group does not have "full control", then Click the "allow" box next to "full control" (as long as you're not trying to prohibit a user from using this plugin, that is... >:-)

     

    7. Apply All Changes.

     

    8. Restart your computer.

     

    9. Open you would-be favicon in Photoshop Elements

     

    10 File, Save as -- .ico...   Poof!   Done!  Fixed!  Yaay!

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 14, 2011 6:13 AM   in reply to cody.hayes

    Hey Guys,

     

    I recently went through all this fun stuff, and noticed I was only able to open as an ICO...

     

    Did anyone who is having issues saving it make sure that the file is under 150pixels resolution?

     

    Worked for me...

     

    Thanks.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)