Skip navigation
Currently Being Moderated

Could not initialize Photoshop because the file is locked

May 27, 2008 9:10 AM

I have the problem where you get the Could not initialize Photoshop because the file is locked, where the solution was to fix the properties in the jpg. I did that and tried the Ctrl-Alt-Shft thing too. I pressed them in time and got the message to delete the settings. When I click yes, I still get the "file locked" message. If it is the scratch disk setting problem, I can't get PS open to change it. This problem started when I was opening a locked jpg from a relative. (Now none of my previous pics will open either). Any other ideas other than these that are already listed in the forums? Thanks for any help.

Technical: Windows XP 5.1, HP7680, Photoshop CS2, 2g ram, more than enough work drives. (no Vista)

Sequence of events: 1) recd a jpg from a relative in an email and saved it to hard drive. 2) with Photoshop unopened, I rt clkd on the jpg and chose "open with CS2". 3) PS started loading and then stopped with the "file locked" msg. Clkd on OK and PS closed. 4) tried to open PS from the shortcut (and from explorer) and got same result. 5) researched the problem and then used the Ctrl-Alt-Shft approach, got the window that asks to "delete settings" and chose ok, PS closed again. 6) went to the jpg and displayed properties and saw "This file came from another computer and might be locked....", so I clicked "unblock". 7) retried step 2, then 4 with same results. 7) tried to open an old jpg with step 2 and same result (got file locked msg). 8) no longer can bring up the "delete settings" window with the the Ctrl-Alt-Shft approach as it looks like it deleted the settings the 1st time.
Any ideas???? Thanks again.
 
Replies
  • Currently Being Moderated
    May 29, 2008 5:06 PM   in reply to (Bob_Heffley)
    Bob,

    I do not know why a locked JPG would mess up PS. I could see if you always tried to launch PS, by dbl-clicking on the JPG in Windows Explorer, but not from your Desktop shortcut, or from the PS.exe file.

    For the locked file, there is a freeware utility, Unlocker. I do not have a URL handy, but Google should find it for you. It has worked on some network assets, that seemed to lock up on me.

    Good luck, though this might not address your PS launch issue.

    Hunt
     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2008 6:22 PM   in reply to (Bob_Heffley)
    I think the "file is locked" issue usually relates to the preferences file, and more often than not is related to a permission problem. might also have to do with a registry hive that ps needs to update...

    do you see the issue when logged in as an administrator?

    this link tells what permission you need (for a non-admin user) to run photoshop:
    http://www.adobeforums.com/webx/.3bb46518/0
     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2008 11:57 PM   in reply to (Bob_Heffley)
    You could try resetting your preferences the manual way as described in the FAQ.

    http://www.adobeforums.com/webx/.ef4a07f/1

    Very strange that an individual image file should corrupt Photoshop settings though.
     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)