Skip navigation
Currently Being Moderated

Force PDFs to open Reader [not Acrobat] in Web Browsers

Oct 13, 2008 1:45 PM

Greetings,

I support Windows computers that have both Adobe Acrobat 8 Professional and Adobe Reader 8 installed. The use of Adobe Acrobat 8 Professional is limited to the number license we have for the product. Thus, my department also installs Adobe Reader 8 on college owned computer so that faculty/staff dont need Acrobat 8 Professional just to read PDFs.

We use the application, Keyserve, to keep use of Acrobat 8 Professional in compliance with our software license agreement. Keyserve will not allow Acrobat 8 Professional to run off campus. At least, not without a VPN connection.

Now for the problem. People are having trouble opening PDFs within Internet Explorer and Firefox on their Windows notebooks while off campus. When they try to open a PDF in Internet Explorer or Firefox, the PDFs wants to open in Acrobat 8 Professional, not Acrobat Reader 8. If the person has not enabled the VPN connection, Acrobat will not open and the web browser crashes.

Setting Adobe Reader as the default PDF reader does not appear to do any good. Acrobat appears to over-ride this preference when opening a PDF with in web browser.

Strangely, if one opens Adobe Reader before opening a PDF in web browser, the PDF will open without issue using Reader.

Is there any way to force web browsers to use Reader, and not Acrobat 8 Professional?

Denis
 
Replies
  • Currently Being Moderated
    Oct 13, 2008 1:50 PM   in reply to (Denis_Recendez)
    You've found one of the reasons that installing both of those items is not suggested nor supported.

    One recommendation (that probably won't work for your group) is to start up Reader first before trying to access a PDF.
     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2008 6:08 AM   in reply to (Denis_Recendez)
    To force PDFs to be opened in reader, edit the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Software\Adobe\Acrobat\Exe

    Set the default value to the adobe reader executable, e.g. "C:\Program Files\Adobe\Reader 8.0\Reader\AcroRd32.exe", including the double quotes!

    That will do the trick!
     
    |
    Mark as:
  • Currently Being Moderated
    Nov 7, 2008 4:04 PM   in reply to (Denis_Recendez)
    The solution for me was to use the Adobe Customization Wizard to set the default viewer for PDF files to Reader. See Adobe kb401258. This changes the installation settings on the msi file, so it is more useful for new installs.
     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)