Skip navigation
tonyperry1951
Currently Being Moderated

Photoshop CS4 file associations (Vista) - fix

Apr 23, 2009 11:35 AM


--Only tried on Windows Vista - For those who upgraded from Photoshop CS3 to CS4 and lost the ability to associate Photoshop with specific file extensions (like .jpg) because it didn't show up in the "Openwith" list.  You might want to try this fix:

 

Because the upgrade install did not update the following registry entry;
[HKEY_CLASSES_ROOT\Applications\Photoshop.exe\shell\open\command]

 

Mine was still set to

@="\"C:\\Program Files\\Adobe\\Adobe Photoshop CS3\\Photoshop.exe\" \"%1\""

Windows doesn't see the new CS4 version as an application and if you have uninstalled CS3 it doesn't see Photoshop as an application period.

 

Type the following in a text file and save it with a '.reg' extension.  Make sure that the path is correct in the last line and uses the exact syntax shown (cut and paste should work but make sure you check that the Photoshop.exe file path is correct for your machine.)  Save it to your desktop and double clicking it should automagically update your registry.

 

This is much safer than mucking about in regedit but still be careful not to make any typos, they can have unexpected results.

 

========= start file at next line
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Applications\Photoshop.exe]

[HKEY_CLASSES_ROOT\Applications\Photoshop.exe\shell]

[HKEY_CLASSES_ROOT\Applications\Photoshop.exe\shell\open]

[HKEY_CLASSES_ROOT\Applications\Photoshop.exe\shell\open\command]
@="\"C:\\Program Files\\Adobe\\Adobe Photoshop CS4\\Photoshop.exe\" \"%1\""
========== end of file at line before this

 

Why Adobe didn't do this in the install is beyond my simple mind to ascertain.

 
Replies
  • Currently Being Moderated
    Apr 23, 2009 1:03 PM   in reply to tonyperry1951

    You must be writing about 32 bit?

    Your showing a lot more slashes too. Maybe that is correct using that software you mentioned?

     

     

    My 64 bit version works fine, with no edits, and this is what I have showing in the Hive in command box section since install:

     

    Value name:

    (Default)

     

    Value date:

    "C:\Program Files\Adobe\Adobe Photoshop CS4 (64 Bit)\Photoshop.exe" "%1"

     
    |
    Mark as:
  • Currently Being Moderated
    May 26, 2010 12:38 PM   in reply to tonyperry1951

    Quite right, also applies to my installation of CS5 under Vista 64-bit.  When I uninstalled CS3, it didn't update that (very important) field in the registry.  Pretty shabby.  Thanks for the lead, I spent way too much time searching for an answer on Microsoft.com and the web in general.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 5, 2010 10:44 AM   in reply to dec9

    Thanks tonyperry1951

     

    I was having trouble in Windows 7 with CS5 and Windows Photo Viewer. Photoshop was not shown in the "open with" list of programs and would not load from the browse button.

    I followed your registry instructions and found that I had an old line with CS4 in it. I changed the 4  to a 5 and that fixed the problem. This is what my registery looks like now.

     

    "C:\Program Files\Adobe\Adobe Photoshop CS5 (64 Bit)\Photoshop.exe" "%1"

     

    Thanks for your help with this fix.

     

    Dwayne

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 1, 2010 9:34 PM   in reply to tonyperry1951

    My OS is XP 34-bit and I just used the suggested registry edit to change CS4 to CS5 and it worked.  Photoshop CS5 is now listed in my recommended programs list to open jpg's.

    Thank you!  This was very helpful.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 15, 2011 6:04 AM   in reply to tonyperry1951

    Thank you for this effective solution. I've been dealing with this problem with my Photoshop 64-bit CS5 for months and this worked!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 9:10 AM   in reply to tonyperry1951

    thanks this worked for me in CS5.5 windows 7 64bit upgrade from 4

     

    "C:\Program Files\Adobe\Adobe Photoshop CS5.1 (64 Bit)\Photoshop.exe" "%1"

     

    I can now put photoshop in recommended programs list

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 7:32 AM   in reply to tonyperry1951

    tonyperry1951 wrote:

     


    For those who upgraded from Photoshop CS3 to CS4 and lost the ability to associate Photoshop with specific file extensions (like .jpg) because it didn't show up in the "Openwith" list.  You might want to try this fix:

     

    The problem is not the upgrade.  The problem is you installed a newer version and THEN deleted the older version. 

     

    It is quite common for the flie associations to then revert to the old (uninstalled) version. 

     

    Best advice is to leave all versions on your hard drive.  If you need the space then uninstall old version BEFORE installing new version.

     

    If you uninstalled the old version and have file association problems you can uninstall the new version, run Adobe Script Cleaner to get rid of a pieces left behind, and then re-install the new version.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 7:54 AM   in reply to Curt Y

    thanks but I think my sollution is ten times easier and these issues have come up after uninstalling old versions so no one is going to know of this silly quirk until its too late!

    The best sollution is for adobe to sort it out in a patch!

     
    |
    Mark as:
  • Noel Carboni
    23,513 posts
    Dec 23, 2006
    Currently Being Moderated
    Jan 11, 2012 8:47 AM   in reply to tonyperry1951

    Has anyone who's experienced this problem tried reassociating the current version of Photoshop through Bridge's Edit - Preferences - File Associations dialog?

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 8:56 AM   in reply to Noel Carboni

    From past posts I remember them saying if was a difficult process.  Even changing File Type associations in Bridge did not solve the problem.

     

    Perhaps one of the users that experienced this can verify.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 9:04 AM   in reply to Noel Carboni

    that only associates the files from within bridge, not in the os

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 7, 2013 10:52 AM   in reply to remainz123

    I have the problem of similar type with PNG files not being seen or recognized by CS6 in Win 7. I went to Bridge file association and PNG is not even listed there! It worked until a few days ago... uninstall and reinstall CS6 is a pain for all the plugs and actions I have in it... any suggestions from anyone is welcomed!! Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 7, 2013 11:02 AM   in reply to Stantonup

    A reinstall rarely solves problems.  If suggestions offered in your other post do not work try resetting preferences.  I would start with Bridge.  Hold down the Ctrl key and start Bridge you should get a reset window with 3 options.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 7, 2013 11:47 AM   in reply to Curt Y

    I managed to have a discussion (chat) with Adobe today and we reduced the problem to plugins. Holding down the "shift" key (not control) and double clinking the CS6 icon brings up the window to alow CS6 without plugins support and then the PNG worked... so then it was a matter of letting the plugins back one by one. So he suggested to rename the plug-ins folder to plug-insold. and create a new plug-ins folder and copy them one-by one and open and close CS6 and the PNG file for each and see what happens. So far I opened all my plug-ins back except for OnOne7--which I just instaled a couple of days ago.. that may be the one causing the trouble.

     
    |
    Mark as:
  • Noel Carboni
    23,513 posts
    Dec 23, 2006
    Currently Being Moderated
    Feb 7, 2013 11:57 AM   in reply to Stantonup

    The OnOne Software people are generally pretty responsive.  I'm sure they'd love to know about a specific conflict, and if it turned out to be a product problem of theirs I'll bet they would likely have it fixed pretty quickly.  Make sure you tell them about this.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 7, 2013 12:10 PM   in reply to Noel Carboni

    Yes, you are right. I will send them a support note of what happened. Albeit lately I had some issues even with their responsiveness: They suggest that a TIFF file is a "flatened" file in Photoshop.. I can't help but wonder if they are REALLY keeping up with the times.. I cannot recal the last time a TIFF did not keep layers... someone's head at OnOne is definitely in the sand.. not sure why!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)