Skip navigation
Currently Being Moderated

Acrobat is unable to connect to your email program

Jun 1, 2009 11:03 AM

I've done a fair amount of research with little to no success on this issue. I am using latest version of Mozilla Thunderbird and works just fine on my WinXP machine. I am currently running Vista Ultimate. Version of Acrobat is 9.1.1 [after recent update]. I have already done the basic troubleshooting (i.e. Set Thunderbird as default mail client within Vista and Thunderbird).

 

Acrobat is the only program I am having issue's with in this regard. Every other program I have recognizes Thunderbird as the default program. I've done a complete un-install w/complete registry cleanup, re-boot, re-install and update with still no light at the end of the tunnel.

 

Any other idea's would be greatly appreciated....Adobe have a "Default Mail Client install program"?? I do not see any settings within Acrobat under the "Preferences" tab.

 

Thank You

Attachments:
 
Replies
  • Currently Being Moderated
    Jun 1, 2009 1:23 PM   in reply to banff_springs

    Acrobat has only a few email clients it supports. I can only guess that the new Thunderbird is not among the clients it supports. If you want it to support Thunderbird:  https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2009 1:56 PM   in reply to banff_springs

    I thought that some of the e-mail issues had been improved with AA9. You are likely running into the issue that is why we do not recommend e-mail submission of forms. E-mail interaction depends on the settings of the client and in the past has required MAPI to be active on the system to activate e-mail. I have heard that some of the web clients have worked, but I am not sure if that is because they use MAPI or what. In any case, look for MAPI. You might do a search in the manual (HELP) to see if MAPI comes up. It does in older versions of Acrobat. Bill

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2009 3:32 PM   in reply to banff_springs

    You have to set your email program to use MAPI. This is listed in the Acrobat JS API Reference.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2009 11:17 PM   in reply to banff_springs

    As far as I know, Acrobat only requires simple MAPI. That is all I use with my mail package. The question is if any form of MAPI is active?

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 1, 2010 4:18 AM   in reply to banff_springs

    I found a way to make this work. It boils down to setting Thunderbird as default in a very specific way - even if you think it already is the default, it will only work in this way. I'm using Windows 7 Profssional and Acrobat Pro 9.0.

     

    Here' how: Start > Default Programs > Set program access and computer  defaults > Custom (expand this) > Choose a default e-mail program

     

    Then, click on 'Thunderbird'. - 'Use my current email program' won't do it, even if Thunderbird is already your default.

     

    I can now email my pdf documents from Acrobat.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 8, 2010 1:09 PM   in reply to gertw22

    THANK YOU SO MUCH for this solution, qertw22!! That setting of the default email program worked like a charm! I have been irritated by this problem since buying my Windows 7 setup 3 months ago. You're a genius!!

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 8, 2010 9:23 PM   in reply to vixbow

    Keep in mind that if you create forms with a "mailto:" submission, you have no control over fixing the e-mail problems on a client machine as you have just done for yourself. Your problem is a good example of why not to use e-mail submission.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 18, 2010 6:55 AM   in reply to Bill@VT

    Thanks!!!!!! This solved it for me too

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 25, 2010 1:44 PM   in reply to banff_springs

    YES, this solved my problem, too. I started having problems when I changed to Windows 7. I was so frustrated to see that I had LOST functionality. Now I'm a happy camper. Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 25, 2010 1:47 PM   in reply to gertw22

    I don't know how to mark your answer as CORRECT, but it is CORRECT!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2010 1:33 AM   in reply to banff_springs

    I am running into the same problem except I am running Thunderbird version 2.0.0.24 on a Windows XP machine. The pdf form was created using Acrobat 9 Pro, but it doesn't matter if I try to fill it using Acrobat reader 9 or Acrobat Pro--both just seem to see Microsoft Outlook.  Other things find Thunderbird just fine--mailto links in websitesfrom both Firefox and IE, and hyperlinks in Word documents.  I have double-checked the default mail program in the control panel, and checked that Outlook Express knows it is NOT the default mail program, but I could not find a similar function in Outlook.  I've tried downloading and running the DefaultMail freeware program that was suggested on the MozillaZine KB, but that didn't seem to help either.  Anybody got any suggestions??  Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 28, 2010 2:05 PM   in reply to gertw22

    Right on gertw22! You solved it!


     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2010 10:59 AM   in reply to gertw22

    This is the solution! Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2010 11:44 AM   in reply to glc_italy_20052

     

    Thank you. It worked!

     

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 18, 2010 9:24 PM   in reply to banff_springs

    Worked for me too.  Thanks so much.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 26, 2010 12:55 PM   in reply to kbarm

    You must go to this link,

     

    http://support.microsoft.com/kb/963707

    remove .NET Framework Assistant plug in Firefox

     

    Delete this and it will work...again, took me weeks to figure it out!

    It is a plugin your friends at Microsoft secretly add to your Windows registry without permission to make your Mozilla Software go wacked,

    That way they get frustrated and intice you to go back IE and OE

     

    Not me!!!!!!!!!!

     

    Hint: Do not delete the whole Foundation folder just the NPWPF.dll in it.

    MIcrosoft wants you to delete the whole Folder, do not do it just the .dll file in it

     

    This will also help you copy and paste in Firefox again and will make your default e-mail client e-mail with T-Bird again & not OE

     

    Microsoft updates - are't they great? - NOT - turn them off - "automatic"ally for good!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 26, 2010 12:57 PM   in reply to banff_springs

    You must go to this link,

     

    http://support.microsoft.com/kb/963707

    remove .NET Framework Assistant plug in Firefox

     

    Delete this and it will work...again, took me weeks to figure it out!

    It  is a plugin your friends at Microsoft secretly add to your Windows  registry without permission to make your Mozilla Software go wacked,

    That way they get frustrated and intice you to go back to IE and OE

     

    Not me!!!!!!!!!!

     

    Hint: Do not delete the whole Foundation folder just the NPWPF.dll in it.

    MIcrosoft wants you to delete the whole Folder, do not do it just the .dll file in it

     

    This  will also help you copy and paste in Firefox again and will make your  default e-mail client e-mail with T-Bird again & not OE

     

    Microsoft updates - aren't they great? - NOT - turn them off - "automatic"ally for good!

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 2, 2010 12:46 PM   in reply to banff_springs

    Am having similar problem. Recently updated from MAC Office 2008 to MAC Office 2011. Acrobat (9.4.1) initially asked me "Where is Entourage?" and when I selected Outlook 2011 nothing happened. Now when I select Attach to Email, I simply get an error message "An error occurred while trying to create a mail document.  Acrobat is unable to complete your request."

     

    I have checked the MAC Mail system preferences and they are set with Outlook as the default email service.

     

    Any ideas?

     

    Dave

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2011 6:58 PM   in reply to banff_springs

    http://objectmix.com/adobe-acrobat/250279-problem-attaching-file-email .html

     

     

    Not sure if this will help but you can try if you are comfortable using the
    registry editor

    . Some how Vista does not seem to set the default email
    client properly for other programs to use. I found this out when trying to
    send email from within Adobe acrobat like yourself.

    From start menu Run/regedit and open it

    Then go to

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

    In the right pane you sill see a value (default). Right click on that and
    select modify. If Windows Mail is not in there then type it in and
    close the editor.

    In my case it had Outlook and was opening Outlook even though WM was my
    default client


    Bill

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2011 1:28 PM   in reply to acbook

    Thank you!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2011 7:07 PM   in reply to MartyAmy

    I am a computer nut and it took me three weeks of banging my head against the cinder blocks before I figured it out, thanks Microsoft

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 12, 2011 10:18 PM   in reply to gertw22

    Well done gertw22, that is the answer I needed. Fixed my problem on win7 with Thunderbird 3.1.9 and Acrobat pro 9.4.3. Several of the other answers listed here were not helpful or even bad advice.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 7, 2011 10:56 AM   in reply to banff_springs

    Had this same problem in Acrobat 9.4.5, Mac OS 10.6.7. I had previously used Entourage for all mail, and recently switched to the much better Apple Mail 4.5.

     

    I had defined Apple Mail to be the default Mail reader in Apple Mail's preferences, but not in Entourage. I went back to Entourage, which was waiting for me with an alert about making Entourage the default mail reader. I said no, restarted Acrobat, and my Email icon worked again!

     
    |
    Mark as:
  • lmccat
    6 posts
    Oct 12, 2011
    Currently Being Moderated
    Oct 28, 2011 9:35 AM   in reply to gertw22

    gertw22 wrote:

     

    I found a way to make this work. It boils down to setting Thunderbird as default in a very specific way - even if you think it already is the default, it will only work in this way. I'm using Windows 7 Profssional and Acrobat Pro 9.0.

     

    Here' how: Start > Default Programs > Set program access and computer  defaults > Custom (expand this) > Choose a default e-mail program

     

    Then, click on 'Thunderbird'. - 'Use my current email program' won't do it, even if Thunderbird is already your default.

     

    I can now email my pdf documents from Acrobat.

     

     

    This solution worked perfectly for me!!  Thank you so much for your advice. 

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points