Skip navigation
Alex le Grand
Currently Being Moderated

Error on startup (see log file)

Jun 8, 2009 3:53 PM

Hi,

Flash Builder gives me this error in the .log file and will not start !

 

---------- .log file --------

eclipse.buildId=unknown
java.version=1.5.0_11
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86 -clean

 

!ENTRY org.eclipse.osgi 4 0 2009-06-09 00:00:15.230
!MESSAGE An error occurred while automatically activating bundle com.adobe.flexbuilder.ui (75).
!STACK 0
org.osgi.framework.BundleException: Exception in com.adobe.flexbuilder.ui.UIPlugin.start() of bundle com.adobe.flexbuilder.ui.
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActiv ator(BundleContextImpl.java:1028)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(Bund leContextImpl.java:984)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(Bundl eHost.java:346)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(Abstrac tBundle.java:265)
    at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java: 400)

     ...

and other errors....

----------------

 

I've updated my Java runtime and rebooted but the same error occur.

One idea ?

Thanks

Alex

 
Replies
  • Currently Being Moderated
    Jun 8, 2009 4:20 PM   in reply to Alex le Grand


    Hi,

     

    Please see if the following steps remedy the problem.

     

           1. Quit all running applications.
           2. Uninstall Flash Builder Beta.
           3. Making sure that there are still no other applications running, install Flash Builder Beta.
           4. In most cases, steps 1-3 should be enough, but if it still won't launch, a reboot can help as a follow-up.

     

    Tim Statler

    Flash Builder QA

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 9, 2009 3:07 PM   in reply to Alex le Grand

    Can you post a little more of the error log?  If you post the entire !MESSAGE block, that will help us figure out what is going on.  Specifically, we'll need to see the part that says

     

    Caused by: ...

     

    and another part below that, I can't remember the wording, "Original exception:" or something like that.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 10, 2009 12:43 PM   in reply to Alex le Grand

    Does this file exist on your machine?

     

    C:\Program Files\Adobe\Flash Builder Beta\plugins\com.adobe.flexide.amt_4.0.0.235740\os\win32\x86\amt_win_ jnilib.dll

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 11, 2009 11:29 AM   in reply to Alex le Grand

    The error message in the log seems to indicate that for some reason, Flash Builder was unable to load the DLL I asked about in the previous message.  I have no idea why -- the main reasons I can think of are:

     

    - it doesn't exist (but you checked, and it does exist, so that's not the problem)

    - some sort of file-permissions issue, e.g. Flash Builder doesn't have permission to read the file (but I can't think of any possible reason why we wouldn't have permission to read the file -- unless perhaps the file was added by one user account on the machine, and you are now running in a different user account?  Anyway, try copying the file to another directory -- if the copy succeeds, then that rules out most problems with file permissions.)

    - the file is corrupt

     

    None of these seem very likely, so I am at a loss to explain why it is failing, sorry.

     

    - Mike

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 21, 2009 8:07 AM   in reply to mike_morearty

    I was having this issue on WIndows 7 64-bit. I found that running eclipse as administrator fixed the problem.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points