Skip navigation
Currently Being Moderated

AE rendering error (memory leak?)

Jun 16, 2009 11:54 AM

I bought a new computer about a year ago, which I believed to be more than enough to power AE and the other apps I use with it.  It's an 8-core 3.2 GHz Mac with 4 gigs of ram.  However, AE is constantly erroring out during a render test of mine.  Nothing more than basic screen screen (subjects are blacked out) with a jpg background.  It's about 35 minutes long.  It error'd probably 3 or 4 times before I lowered the composition size from 640x480 to 320x240.  One render made it through successfully in this size.  I made an extremely slight change (just moving one of the subjects) and did another test render of 2 minutes.  It was flyin right through and again, the render stopped saying it "Failed."  It never produces error log files, so I have no idea what's going on.

After a failed attempt, I'll try it again and the program stops responding when I hit Render.  From there, I have to force-quit and try again.

I've turned on my Activity Monitor to see how much memory it's soaking up, and it's never anymore than ~2 gigs.  Is this a memory issue?  I find it completely hard to believe with this system.

I would REALLY appreciate any knowledge that anyone can give me regarding the situation.

Edit:  the last render I did was again a 2 minute-length video.  2 minutes, 18 seconds into the render process, it failed.  Activity Monitor showed it stopped at 2.84 gigs of memory (a constant climbing number until it failed there).  It also displays "AE (null)" as the title of the process.  And, after a failed render, AE sits at 2.84 gigs of memory.  That memory never gets freed back up, which I'm guessing is why the application becomes non-responsive.

Edit 2: After looking at how much Free memory I have, it shows around ~2.5 gigs (that's with only AE and firefox open).  If this is a memory problem, how much do I need to execute simple renders like this in AE?  All it is, is a 320x240 key'd-out, silhouette subject with a different background (ideally an hour long - but even 2 minute-length fails).  Should AE really need to use ~3 gigs of memory for this task?  I am more than willing to put a few more gigs of ram into this computer if necessary, but I don't want to add more if AE will use all of that ram up also, to the point of crashing.  I'm wondering if it's a problem beyond system requirements (which this computer should meet 3 times over).  It's really frustrating.

 
Replies
  • Currently Being Moderated
    Jun 16, 2009 12:11 PM   in reply to bsnyder175

    4 GB of RAM is only enough to feed 2 cores, when using After Effects multiprocessing (Render Multiple Frames Simultaneously).

    And definitely inadequate for an octo-core machine.

    If you enable multiprocessing for all 8 cores with such configuration, the backround rendering instances will starve to death, or keep shutting and re-launching.

    While you only have 4 GB, I suggest you go to Memory and Multiprocessing preferences and set "Leave CPUs freee" to 6 cores (ie, only use 2).

     

    If you really want to use all 8 cores for rendering, it's recommended you get 2 GB per core (ie, 16 GB total). After all, you're running a virtual render farm of sorts inside your computer. You can get away with about 1.5 GB per core (12 GB total) if you're not doing HD video and/or use using high bit depths (16 or 32 bpc) in your projects.

     

    But it's not an all or nothing kind of thing- You could get an extra 4 GB (8 GB total, by all means you want at least that amount) and use 4 cores for rendering in AE (ie, leve 4 CPUs free). That would give you very, very good performance.

     

     

    I've turned on my Activity Monitor to see how much memory it's soaking up, and it's never anymore than ~2 gigs

     

     

    That's for the main After Effects instance. If you're using multiprocessing, each rendering instance would appear as "AEselfLink".

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 16, 2009 12:49 PM   in reply to bsnyder175

    The preference for setting the number of cores is new in CS4.

    In CS3, there could be a way to set this in the text preferences, but it's not going to do any good if multiprocessing is off.

    Everything I wrote only applies if Render Multiple Frames Simultaneously is on (which is the main point of using a multi-core machine for AE!)

     

    If you're using a small composition size with small source files, there's nothing wrong with AE not using memory it may not need. Some Compositions are memory intensive by nature, and others aren't.

     

    How are you exporting? Are you using the Render Queue or File > Export? What format/codec are you rendering to?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 16, 2009 1:15 PM   in reply to bsnyder175

    No, you shouldn't have to compress your source footage, unless we're talking extraordinarily large files (unlikely).

    Nope, there are no cores to free because you are not using that feature at all. This setting only is used when you have Multiple Render Frames Simultaneously enabled.

    With that feature turned off, 4 GB of RAM shouldn't cause problems (of course, taking advantage of your hardware would require enabling it and getting more RAM).

     

    Is it possible that the target drive doesn't have enough room for the exported file?

     

    Did you update After Effects CS3 to the latest update available for it (8.02)? If you didn't, just go to Help > Updates and the Adobe Updater should offer that update.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 16, 2009 1:31 PM   in reply to bsnyder175

    This is for CS3 only.

     

    The text prefs file is in UserName/Library/Preferences/Adobe/After Effects/8.0/Adobe After Effects 8.0 Prefs

     

    Make sure you quit the application. Open the text preference file and look in the ["MP"] section for: “MaxNumberOfProcesses” = “0″.

    “0″ is the default setting, which disables this preference setting. For better performance on an 8-core machine with 8GB RAM, for example, change the “0″ setting to “4″ and save the preference file and restart After Effects. This restricts multiprocessing with Render Multiple Frames Simultaneously to 4 cores, each getting approximately 2GB of RAM.

     

    You could right now set it to "2", and AE will use just two cores to render multiple frames simultaneously.

     

    BUT, this is unlikely to be related to your problem, since this feature was disabled completely.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 16, 2009 2:08 PM   in reply to bsnyder175

    There are some projects which can fail to render due to excessive memory usage, but usually these make use of source files with very, very large dimensions in pixels.

    To get you out of trouble in this case, you can simply render the first half of the Comp (Setting time span to Custom in the Render Settings and enter the duration manually) and then the other half. If you have Quicktime Pro, you can then open both files in QT Player, select all (Command+A) and copy the second file, paste it at the end of the first and save. That's it.

    Also, try downloading the CS4 trial and see if it manages to get to the end of the render?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 16, 2009 2:14 PM   in reply to bsnyder175

    Have you tried disabling layer caching and purging during your render?

     

    If you hold down the "shift" key when you access the AE preferences, and then release the key when the preferences dialog box pops up, you'll be able to access a hidden item in the pulldown menu entitled "secret". When you go there, you can choose to purge every "1" frame during rendering, and you can disable the layer cache.

    If this works, don't forget to go back to the preferences after the render completes and restore the settings to their default states.

     

    Aside from that, is there anything occuring in your project's timeline around the area your crash/hang is happening?

    Any effects being applied? Any footage element beginning?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 16, 2009 2:48 PM   in reply to bsnyder175
    > Does comp length have anything to do with memory usage?  Would a 5 minute comp take just as much memory as a 6 minute comp?  Or does length make the memory usage vary?

     

    When you're rendering for final output, you only need to consider the amount of RAM needed to render each frame. If you're using time-related effects or motion blur or other temporal things, then some surrounding frames must also be considered. But the whole rendered composition isn't being retained in RAM or anything. (When you're rendering a RAM preview, you're also using the RAM allocated to the foreground process to store the frames for playback.)

     

    So, basically, the memory usage to render a composition for final output doesn't change with the length of the composition.

     

    I'm glad that purging memory periodically is helping you to get your composition rendering.

     

    It seems that you're past this issue right now, but I wanted to say this for others reading this thread:

    To echo something that Adolfo said: Don't enable Render Mutliple Frames Simultaneously if you're failing to render without it. Only enable Render Mutliple Frames Simultaneously if you're rendering just fine without it and want to see if you can get a speedup by throwing another processor core at the render. The only problem that Render Mutliple Frames Simultaneously ever solves is the problem of slowness---and it only solves that problem some of the time... and it can only do that when you have lots of RAM. This preference defaults to OFF for a very good reason.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2009 1:44 AM   in reply to bsnyder175

    bsnyder175 wrote:

     

    At this point, can we safely assume that it's not AE, and it's my system?

     

    It's neither, I daresay. It's probably down to Keylight. It's a memory hog that can slow down even beefy systems. Also there are some bugs in it, especially when using the CS3 version in CS4, which may have contributed to the failure of your test. The additional RAM will certainly improve things. However, I'd definitely also consider trying a different keyer like Primatte at some point. Overall behavior may improve considerably just by that.

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2009 8:15 PM   in reply to bsnyder175

    bsnyder:

    It seems Keylight is devouring your RAM over time.

    This looks like a bug.

    I have done hundreds of shots with the version of Keylight that comes with CS4, and at much larger frame sizes.

    So, I'd like to take a look at your project.

    How many GBs would it be for the folder containing the .aep project file + source files? About 7 GBs, I think you said? If you zip that folder, does it come down in size? I am asking to see if you want to upload that folder so I can take a look and see if there's something

     

    As always, I have to make it clear that I can't promise an immediate solution, but rather investigate the issue to isolate the causes, notify the developer and have it fixed in the future. Of course, if I do find a woraround I'll let you know.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2009 8:43 PM   in reply to bsnyder175

    My e-mail address is arozenfe[[AT]]adobe.com

     

    Let me investigate the server thing. I'll send a private message once I know, ok?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2009 10:17 PM   in reply to bsnyder175

    Normally, you don't want to change the default settings (of course, normally renders don't stall!).

    Let me know if you can upload the project and files to a file hosting service (yousendit, etc).

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points