Skip navigation
Currently Being Moderated

HTTP Error 401.3 - Unauthorized You do not have permission to view this directory or page because of the access control list (ACL) configuration or encryption settings for this resource on the Web server.

Jun 22, 2009 9:58 AM

Hi,

 

I got this 401.3 error when running the http://127.0.0.1/CFIDE/administrator/index.cfm configuration page after installation of coldfusion 8 standard on win 2008 32bit server which has IIS7. Coldfusion 8 files are located on D drive instead of the default C drive. I already duplicate right access from C to D but still get the error. The IIS 7 error page shows that the logon account is Anomymous. I traced default web site authentication and it poited to NT Authority\IUSR account so I added this account full access to D:\inetpub\wwwroot but that didn't help either. Does anybody come across this problem? Any help is greatly appreciated.

 
Replies
  • Currently Being Moderated
    Jul 14, 2009 5:00 PM   in reply to khang

    Justing pinging this thread.  We are having the exact same issues.  Anyone have a solution to this?  Once I install CF8 IIS won't even serve HTM files.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 15, 2009 7:01 AM   in reply to khang

    Review the windows application event log.  There should be information logged there on this issue.  Most likely there is another user (maybe a .Net user) that doesn't have access to the directory or the files.

     

    Sincerely,

     

    Braden

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2009 6:18 AM   in reply to CFMLGuru

    I'm having the same issue. I don't see anything in the event viewer that looks to be related. I even changed the IIS7 anonymous user to an administrator account temporarily.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2009 8:10 AM   in reply to rtcpenguin3

    Good morning,

     

    Did you check to see if the USERs account have read? Do not give your IUSR account full access. I normally create a bogus account and replace that with IUSR account with this account so that it can't be corrupted. You may have to give your account write permissions. You may have changed permissions in the wrong folder. You can also, delete the website and then recreate it. This will not delete the folder but the virtual folder. Last, check your port number in Host Header under Bindings.

     

    DJ Khalif

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2009 8:14 AM   in reply to djkhalif

    Re-Read your post: Change your loopback address to the server name (not the FQDN) or to the server IP address. This should work especially if you're accessing from a remote workstation. The loopback address (127.0.0.1) is only for the local browser.

     

     

    DJ Khalif

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2009 8:27 AM   in reply to djkhalif

    Under the wwwroot folder I created, the accounts have the following permissions

     

    IUSR -- read & execute, list folder contents, read

    Internet Guest Account (IUSR_machinename) -- read & execute, list folder contents, read

    Users -- special permissions

     

    Under the bindings the port is 80.

     

    Navigating to the root on the server (ie. entering localhost in the browser) gives me the same error (however its the detailed version).

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2009 8:44 AM   in reply to rtcpenguin3

    Do you have an A record in DNS? Try this: http://your_server_address/cfide/administrator/index. Put the permissions on the Website Folder. Your c:\inetpub\wwwroot\ permissions should be set and you not have to change those. Last, check your application pool and enable 32-bit application on your application, set to "true". This is in IIS7.

     

     

    DJ Khalif

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2009 8:54 AM   in reply to djkhalif

    If I navigate to that address ( http://localhost/cfide/administrator/ ) I get the same 401.3 error. When ColdFusion finishes installing it tries to launch that page and I get the 401.3

     

    The permissions on the website folder (ie. wwwroot/mywebsite ) are the same as what I listed above. My wwwroot folder is on a different drive than the Coldfusion install. Would that make a difference?

     

    Not sure what you mean with the last part. Where is that setting? This is a 32-bit version of Windows and I used IIS7 defaults (aside from a different location for the wwwroot folder).

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2009 9:41 AM   in reply to djkhalif

    Thanks for the links. I already saw some docs on MSDN.

     

    The weird thing is that if it is an ACL issue (as the error states), shouldn't setting an administrator account as the IUSR/anonymouse account get rid of the error? I realize its a terrible idea to give full control to the IUSR, but why doesn't this at least fix my issue?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2009 10:10 AM   in reply to rtcpenguin3

    If I remove the * wildcard under the Handler Mappings, html pages display fine. So I guess the issue has to do with accessing those files (in this case ColdFusionROOT\runtime\lib\wsconfig\1\jrun_iis6_wildcard.dll )

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2009 10:26 AM   in reply to rtcpenguin3

    RESOLUTION:

     

    I reinstalled ColdFusion on the same drive as the web root (D:)  aand a as a developer trial. I'm not sure what fixed it, but its more likely the drive issue.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 29, 2013 11:55 AM   in reply to khang

    In the below URL, solution is described with step by step guide. You can try with this:

     

    http://coldfusion-tip.blogspot.com/2013/10/you-do-not-have-permission- to-view-this.html

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points