Skip navigation
David Ethell
Currently Being Moderated

Flash Builder 4 endless compile loop?

Aug 4, 2009 4:33 AM

Sometimes my Flex projects get stuck in an endless compile loop. What I mean is, they start building, go to a certain percentage and then restart at 0%. I have to cancel the build process and do a Project, Clean just to get the project built so I can debug.

 

Anyone else experiencing this? I'm unsure if this is related to having Aptana Studio 1.5.1 also installed on the same eclipse, but that's the only other major plugin I have installed.

 

David

 
Replies
  • Currently Being Moderated
    Aug 4, 2009 6:05 AM   in reply to David Ethell

    Ive also seen this. No Aptana installed here

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 4, 2009 6:33 AM   in reply to David Ethell

    I also ran into this problem when I first tried Flash Builder 4. I had converted a large project from Flex 3. Next day when I tried to reproduce the problem I was unable to. Don't know what caused it or what happened to stop it.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 9, 2009 1:59 PM   in reply to David Ethell

    Hi David,

     

    yup, I know this error. I reproduced it several times.

    If you use the automatic binding, by dragging and dropping an EntityService to a Datagrid, some code is added.

    For example a definition for the callresponder, a call for this callresponder, a creationComplete for the DataGrid.

     

    If you do this several times and then start you delete some parts of the generated code for bindinng, the described error happens quit quickly!

     

    Then you do not(!) get a clear compile error, but it compiles for ever .

     

    You can solve this in two ways.

     

    Take this project out of your workspace ( you do not habe to delete it from disk).

     

    Find the still existing code snip, that produces the error and delete it and use clean compile. To find the error is tricky!!!  because DataGrid3 belongs to Callresponder 2 and so on and you don not(!) get clear messages from the compiler.

     

    I use the automatic code generation, but do not use the automatic binding. Then this kind of error does not happen any more!

     

    Hope this helps!

     

    Martin Zach

     

    P.S: This has nothing to do with Aptana.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2009 7:33 AM   in reply to David Ethell
     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points