Skip navigation
Walt_4343
Currently Being Moderated

Titles blurred after export

Mar 10, 2010 4:16 AM

Hi all,

 

I'm using Premiere Pro CS4 and some months ago created a short video with some titles at the beginning and end.  I exported the video using the H.264 codec (YouTube Widescreen SD preset) and all was well.  Video, including titles, looked crisp and clear.  However, now I'm revisiting that file and when I export it using the same codec and presets, the titles look poor.

 

The only things that would have changed in the meantime are that Premiere would have been updated using Adobe Updater and it's likely I would have updated by video card drivers, too.

 

The following image shows what the credits looked like 6 months ago (left) and now (right).  Both are shown in Quicktime.  Please see below for my system specs, though these have not changed in the interim.

 

credits issue - youtube.jpg

I am not very familiar with the titler, but as a wild stab in the dark, is it possible that it could be some layering issue, to do with transparent and non-transparent layers?

 

SPECS:

Windows XP Professional SP3
AMD Phenom II X2 550 - 3.32 GHz
3.25 GB RAM
ATI Radeon 4890 video card (driver ver 8.702.0.0)

 

Adobe Premiere Pro CS4
Ver 4.2.1 (003 (MC: 166418))

 

Many thanks.

Walt

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Mar 12, 2010 2:04 PM   in reply to Walt_4343

    What happens when you use a normal export, instead of QuiRckTime?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 12, 2010 2:19 PM   in reply to Walt_4343

    H.264 YouTube, not QuiRcktime.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 12, 2010 2:48 PM   in reply to Walt_4343

    Are you working with the original Project file (clips etc) or are you working over

    the exported H.264 file as a clip?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 12, 2010 11:48 PM   in reply to Walt_4343

    Walt,

     

    The best thing is usually to go back to when things were working/never change stuff; random things that may have happened in between then and now might be affecting it.  So system updates, software, or adobe updates, for example, might have done something funny.

     

    If system restore isn't an option, which I don't think I'd recommend anyway (last time I did it, it just screwed up my whole OS installation):

     

    Try remaking the titles, if you haven't already.  Don't get carried away, just make a test new one and export just that segment to see if it works.  Make a new title in a new project in a new sequence and see if that looks good when exported (narrowing your problem down to project-specific or program-problem).

     

    You could try copy/paste everything in the sequence into a new project.

     

    Try uninstalling some of the things that may be affecting codecs, such as codec packs or downgrading to an earlier version of quicktime you were using 6 months ago.

     

    Try exporting to a different format just to see if it turns out better--you could isolate the problem to being something pre-export, if they all turn out badly.  For example, the FLV format is a similar encoder quality wise but different enough to tell you if the problem is just the h.264 encoder or not.  (If so I'd try a reinstall of AME).

     

    And lastly, for some reason, try playing with the Field Options under right click menu on clip.  I've found these special options to be the magical make-look-good of Adobe Premiere; sometimes the option that turns out best doesn't even make sense with respect to your source/project settings/output format.

     

    If you have to, try bringing the good looking h264 clip in and use that over the place of the title, for a possible temporary fix for this project.  If it can't encode titles right, perhaps it can re-encode the encoded video right instead.

     

    - wb

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 13, 2010 8:35 AM   in reply to Walt_4343
    In the titler the background is transparent (chequer board), but in the video the background is black.  I think I have 'show background' switched off in the titler, so maybe that's all that is.

     

    In Titler, you will see black, and if you placed the Title onto the Timeline with nothing below it, you will see black. However, the background, unless you add a Shape or Matte, etc., is transparent. That is why you see the next Video Track below where the Title is placed, when you check Show Video. Having that checked, or unchecked, is just for the display in Titler and will not affect the Exported footage.

     

    I keep thinking that something has changed with your H.264 CODEC. There are three very popular H.264's, Apple's, Lead's and MainConcept's. Some users have had problems with Apple's, and for them, either the Lead, or MainConcept have proved better. Which H.264 CODEC do you have? Did you update QT Player between when things worked well, and now? Just thinking here, so if you made zero changes, just ignore me.

     

    Good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 13, 2010 12:04 PM   in reply to Walt_4343
    how do I check what type of H.264 codec I have?

     

    The great, free utility, G-Spot will survey your system. Normally, it's used to gather data on AV files, but it also has a menu entry, Tables, in the Toolbar. Look at it for your Video CODEC's.

     

    As for a change by PrPro, I would guess that PrPro uses the MainConcept CODEC's, if it ships with an H.264 CODEC. I do not have CS4 to check. I believe that the majority of the Adobe CODEC's are MainConcept. Maybe someone else can verify this.

     

    I'll keep thinking of possibilities, but am out of ideas right now.

     

    Good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 13, 2010 12:19 PM   in reply to Walt_4343

    Hey WAlt

     

    Can you tell me where the "black" BG is coming from in your title?

     

     

    There are two ways (and more) of making  White Text over Black BG

     

    One way is to simply type White Text over the Transparent BG in the Titler. (Text over alpha channel)

     

    Another,  is to type White Text over a Black BG in the Titler (White text on a black rectangle)

     

    IN the 1st method...if the title is placed over either clear space in the video layers (or Black Matte or Black Video clip) you get White Text on Black.

     

    All these ways get the same effect.but there are advantages and reasons why you might choose one of these methods over each other.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 13, 2010 2:27 PM   in reply to Walt_4343

    Walt,

     

    I forgot to mention that G-Spot will list false-positive errors for the Adobe CODEC's, because they use a different naming convention, to protect them from being overwritten by other programs. The same thing will happen with Sherlock the CODEC Detective. Mea Culpa, mea culpa.

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 13, 2010 2:42 PM   in reply to Walt_4343
    (though I did worry about typing 'gspot' into altavista)

     

    Yes, I forgot to add the URL to the name, as I normally do. Guess it's not my best day. Teach me to try and watch Doral and hang in the forum!

     

    I know that some of our lady subscribers have gotten pretty perplexed at the suggestion to get G-Spot. We are not trying to "get fresh," or be vulgar, but not everyone is as open. However, I did not name the utility, so take no responsibility...

     

    Wish I had more to add, but am stumped. Maybe Craig will hit on something for you.

     

    Good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 13, 2010 2:46 PM   in reply to Walt_4343

    Wouldn t hurt to try a synthetic black on a video layer below but...my last guess...

     

    From your screen grabs it is obvious you did change something ( because the text has different information that got there somehow).

     

    Check all the attributes of the text in the Titler (eg shadows, opacity, etc...)

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 13, 2010 3:30 PM   in reply to Walt_4343

    You know, I've heard reports that Apple's H.264 has an issue with "synthetic media." The way around that is to use Black Video in PrPro, and then Export that to DV-AVI. Import that AVI and replace the "synthetic" Black Video. It also seems to have issues with Transparent Video too.

     

    As a test, you might want to do a new Sequence and do a segment of Black Video, that will be long enough to go beneath your Titles. Export that in a format to match your main Sequence, and then Import and use that to go below your Titles. Might be worth a test.

     

    Good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 13, 2010 3:40 PM   in reply to Walt_4343

    How high is the Bit Rate on your Export and what are you exporting as now.?

     

    Higher  will make a real difference.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 13, 2010 5:10 PM   in reply to Walt_4343

    Playing with the bitrate (and other export options) is a good idea for the next step.  Like one of my earlier suggestions, I'd also try playing with different formats all together, just to see if the h.264 is indeed the culprit.  I know the 'Quicktime' format option and then picking 'h264' under it's codecs has produced terrible results for me.  Make sure you're on the 'h264' format, instead. 

     

    If on the correct format, under the video tab, it should say "Codec: MainConcept H.264 Video" such as in this pic (ignore other settings):

    http://www.academicsuperstore.com/images/cs4_flash_14.jpg

     

    Another format I can say should turn out well is FLV, I'd give that a shot if you keep having problems.  Even if you can't use it in that format (if you're uploading to a video site, many other formats do work, not just h264), it can help you narrow down the problem.  You could try some sort of lossless format like (format) Quicktime (codec) None or AVI lossless(?) just to see if it works.  If it is narrowed down to the h264 encoder, a reinstall might be the solution so that mainconcept gets reinstalled and working properly.

     

    - wb

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 14, 2010 5:36 PM   in reply to Walt_4343
    P.S.  Have not tried the layer of black below the title track yet.

     

    Hey Walt

     

    It should not make a "real world" difference but if it works, it works.

     

    I am able to use all methods mentioned to create title on Black and dont have the issue you are having.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 14, 2010 8:12 PM   in reply to Walt_4343

    Walt,

     

    You can set your own dimensions if needed, so that it comes out the correct resolution.

     

    - wb

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 14, 2010 9:16 PM   in reply to Walt_4343

    I've had the same problem in the past.  However, I found that if you import your PP sequence in After Effects then render it in the render queue, the titles will retain their quality.  I would recommend setting the codec to something other than 'Animation' (Quicktime H.264 works well) and choose 'Best' for quality.  Not sure why this happens or if it is consistent throughout versions of PP, but I think it's worth a try.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 15, 2010 10:23 AM   in reply to Walt_4343

    Walt,

     

    First off, YouTube will accept .FLV files.  And if you want to, you can even upload it at 1440x1080 or 1280x720, you don't need to take it down to WS SD if your end product is YouTube.  So anyway, if .FLV is all that's working well, then use it.

     

    Now, to explain the codecs, yeah, the Quicktime format options turn out like poop.  I've tried them too.

     

    - The Quicktime option don't use MainConcept encoder, as far as I know they use Apple I suppose

     

    - The H.264 format option does use MainConcept

     

    When you pick FLV/F4V, you can pick between the two:

     

    - F4V uses MainConcept, and should turn out exactly the same as the H.264 format exports

     

    - FLV option uses On2vp or something like that, which is what is working for you

     

    Hope that clears things up.  FLV hasn't been player friendly in the past, but it's getting better; the new versions of VLC also play it fine.

     

    So, it seems like your MainConcept encoder is not working properly.  I know of no way to repair or reinstall it per say, and my best guess would be to uninstall and reinstall the whole suite.  If it still didn't work then, I'd suspect some codec pack or something is messing with it, and would start by uninstalling all other video related players, codecs, and editing software, etc on your system.

     

    But like I mentioned, if you don't want to deal with all this for this project, using .flv should work fine for 'delivery'.

     

    - wb

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 16, 2010 9:00 AM   in reply to Walt_4343

    Walt,

     

    A big misconception is that .flv (flash video) has anything to do with Adobe Flash the application, which makes .swf files.  Although they have integrated the two somewhat and it's possible to work one inside the other (premiere and flash), FLV is a video codec, not a product of Flash, and Flash Player shouldn't be able to play it.  Someone else here probably knows the exact history and relationship the flv format and the flash program have, so I won't pretend to know and try to explain it; what's important is that .swf/flash player and .flv are very different.

     

    That's strange f4v and H.264 formats are not turning out similar, it's been my experience that they turn out exactly the same.  I'd have to just go back to my previous thoughts and say the best bet is a reinstall (the OS, if need be).

     

    I didn't notice that you reinstalled already trying to solve the problem.  Did they have you do a clean uninstall with the clean script?

     

    Additionally to video codecs (that may have been installed with players), do you have any other editing software installed?

     

    If anything I would suspect the updates would solve the problem, but if you end up reinstalling at some point try exporting before doing any updates, just to see.  It's interesting to know that many professional facilities simply will not update their software or computers at all unless it's absolutely necessary. If it already works, why change it/chance it.

     

    - wb

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 16, 2010 2:55 PM   in reply to Walt_4343

    Walt,

     

    No, they shouldn't affect each other, in theory at least.  I think the Master Collection CS should work well together, no worries there.  I've heard of quarky problems with other apps, like Edius somehow causing bugs in After Effects, and things like that, so I was just curious.  Sound Forge shouldn't affect it, as far as I know it doesn't encode video, but I don't know for sure.

     

    I'm not an expert on how codecs work with things--but if you install codecs they seem to become available for any program to use, so I've experienced, for example, problems installing certain Codec Packs that in turn make Premiere not work properly because Premiere is trying to use codecs it doesn't like.  The solution was uninstalling the codec pack.  I've never used Gspot, so not sure :/ .

     

    Also, After Effects does use a different method of rendering out exports, it doesn't use Adobe Media Encoder, so trying the route mentioned earlier about opening the project in After Effects may be another way to get a good result.

     

    Not a problem.  I hope through their process they can figure out the issue.

     

    - wb

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points