Skip navigation
Currently Being Moderated

RE: "Unable to create font" After Effects CS 5 won't launch

May 1, 2010 7:16 AM

My spanking new After Effects CS5 won't launch due to "Unable to create font" error.

I'm running OS X 10.6.3 on a 17" with specs listed below.

After Effects CS3 is running fine. What's the solution?

 

Model Name: MacBook Pro

  Model Identifier: MacBookPro5,2

  Processor Name: Intel Core 2 Duo

  Processor Speed: 3.06 GHz

  Number Of Processors: 1

  Total Number Of Cores: 2

  L2 Cache: 6 MB

  Memory: 8 GB

  Bus Speed: 1.07 GHz

  Boot ROM Version: MBP52.008E.B05

  SMC Version (system): 1.42f4

  Serial Number (system): W89400R18YB

  Hardware UUID: E2300327-D5D3-5DC2-85CF-9FFA9CEAD9ED

  Sudden Motion Sensor:

  State: Enabled

 

 

 

 
Replies
  • Currently Being Moderated
    May 1, 2010 8:07 AM   in reply to billsantry

    Start with the solutions listed here:

    http://aeerrors.myleniumstuff.de/?p=482

     
    |
    Mark as:
  • Currently Being Moderated
    May 1, 2010 4:47 PM   in reply to billsantry

    Same for me, I'm trying a lot of things but nothing work – I keep checking and let you know If I've got a solution

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2010 8:14 AM   in reply to Maherso

    There are 3 possible issues on the system. A corrupt font, a corrupt Adobe font list and/or a corrupt system font database.

     

    Try the following:

     

    1) On the Mac, delete all copies of the AdobeFnt.lst on the system. They will have a name like AdobeFnt10.lst, AdobeFnt11.lst, etc.. On the Mac this will be found in the /Library/Application  Support/Adobe/PDFL/9.0/Fonts folder.

    2) Then restart the system holding down the S key while the system is starting up for Safe Mode. That will reset the system database.

     

    On Windows,

    1) search and delete the AdobeFnt.lst files found in C:\Program Files\Common  Files\Adobe\PDFL\...,

    2) restart the system.

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2010 8:44 AM   in reply to Will Lockwood

    Hi Will,

     

    I did all that but nothing fixed the problems. Finally, I'm suspecting a corrupted drive. When I fix the drive with fsck command it gets corrupted after each system launch. I plan to clone my system on another drive, boot from the new one, check if everything is ok. I let you know.

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2010 8:49 AM   in reply to Maherso

    Bummer. Sorry to hear that. Let us know how this works out.


     
    |
    Mark as:
  • Currently Being Moderated
    Mar 3, 2012 12:59 AM   in reply to billsantry

    Hi,

     

    Finally I found the solution, I don't know if it's gonna work for you, but you should give it a try. After hours of troubleshooting, I found that a missing Verdana Fonts (version 1.0 from Microsoft) is causing the problem. Just put Verdana in YourHardDrive/Library/Fonts and AfterEffects CS5 should start normally. It would be cool to have a better dialog box like "Unable to create font - please locate and Install Verdana".

     

    For your convenience, you can download Verdana here : [removed by moderator, since Verdana is not a freely distributable font]

     

    Enjoy

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2010 12:00 PM   in reply to Maherso

    Hi Will

     

    I posted a solution that works for me.

     

    Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    May 11, 2010 4:17 AM   in reply to Maherso

    After Effects Warning Unable To Create Font

     

    @Maherso

     

    Thanks that works perfect.

     

    Verdana, Typeface and data © 1996 Microsoft Corporation. All Rights Reserved Version 2.45 - Thursday, 8 April 2004 08:00

     
    |
    Mark as:
  • Currently Being Moderated
    May 11, 2010 4:35 PM   in reply to Maherso

    your link to the font is gone. (sigh).

    could you reupload, please?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 3, 2012 2:12 AM   in reply to karolus ka

    Hi Karolus,

     

    The link is now working, enjoy...

     

    [removed by moderator]

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 19, 2010 6:51 AM   in reply to Maherso

    Worked the first time! Thanks for the link too!

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 29, 2010 1:01 PM   in reply to billsantry

    You can buy Verdana font from Microsoft site for 30$ (aamof from Ascender Corporation). It's not legal to download it from above links (unless this guy have license for sharing this font, and I doubt about that). It is laughing because after you spend 999$ for a software, you have to pay 30$ more for the fonts. Did Adobe have no money for licensing this font?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 29, 2010 3:18 PM   in reply to Mac0SX

    Oooops, I was sure Verdana was free. Sorry folks, you'll have to buy that font or find it in another way (try installing Office 2008 trial...). We live in a strange world full of contradictions.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 10, 2010 12:55 AM   in reply to Will Lockwood

    I tried this soln ..and it's worked finally

    Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 10, 2010 8:47 AM   in reply to jackie.vishwakarma

    The After Effects CS5 (10.0.1) update should fix this problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 28, 2010 7:28 AM   in reply to Todd_Kopriva

    For me the Adobe update *DID NOT* fix this but copying over and activating the Veranda family of fonts from my MBP that had Office on it, did - kind of a sorry situation if this is what's actually needed to fix it but at least there is a way.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 31, 2011 8:01 AM   in reply to billsantry

    Hi,

     

    I had the same problem. Also after updating AE. But this worked for me:

     

    Activate the verdana font in your system Fontbook (dutch: Lettertypecatalogus).

    (Suitcase Fusion 3 turned it off)

    Grtz,

     

    Code d'Azur

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2011 12:46 PM   in reply to billsantry

    The Verdana trick worked for me too. AE’s type engine fails if there isn’t a font at /Library/Fonts/Verdana.ttf —common, simple programming problem. Mahalo for posting all this, guys!

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Mar 21, 2011 6:40 PM   in reply to Todd_Kopriva

    And a March 2011 download of the Master Collection & update to 10.0.1 (everything that updates) reveals that the same issue still exists. Installing Verdana "fixes" it. <font family="Verdana">Idiots.</font>

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2011 8:00 AM   in reply to Maherso

    Thank you!!! This totally worked for me!!

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Apr 11, 2011 11:32 PM   in reply to Maherso

    Thanks

     

    Just want to add that this worked for me. But it didn't at first. I moved Verdana to the right place but it did not work. The problem was that you need all the files. I had them all but not "Verdana Italic.ttf" for som reason. I had to get that from a disc and then it worked. So make sure you get them all to /Library/Fonts/.

     

    Verdana Bold Italic.ttf
    Verdana Bold.ttf
    Verdana Italic.ttf
    Verdana.ttf

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 25, 2011 7:05 AM   in reply to billsantry

    Worked for me (I ended up adding all the Verdana affiliates as well....bold..italic..etc)

    Such a relief, as I had already gone through a reinstall, and several other troubleshooting workarounds...

    thanks!!!

     

    jon

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 7, 2011 8:30 AM   in reply to billsantry

    I'm running OSX 10.6.7 and started getting this error after validating my fonts & resolving duplicates in Font Book. Verdana was still installed on my machine (worked in Photoshop & Illustrator), but for some reason After Effects wasn't able to locate it, hence "Unable to create font."

     

    What worked was re-installing Verdana, which caused another duplicate. Oh well, at least it works again.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 7, 2011 10:27 AM   in reply to iamshaun

    It's important that you install the specific version of Verdana that comes with AE… probably something to do with its ID #… sounds like you got it figured out!!

     

    All contents are confidential. Delete if you are not the intended recipient.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 7, 2011 10:28 AM   in reply to thinkingmanhawaii

    Yep, got it going. Thanks man!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 5, 2011 4:37 AM   in reply to iamshaun

    Thanks guys

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 3, 2011 3:21 AM   in reply to billsantry

    Hi,

    had the same problem but solved in a little different way since I have no Administrator privileges. I use Fontexplorer to manage my fonts instead of Fontbook. I've found in it multiple versions of Verdana font . I removed everything but system Verdana, now everything works.

    Thanks

    Lorenzo

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2011 11:06 AM   in reply to Todd_Kopriva

    I updated to the current after effects and I am still getting this problem. I have homework to finish today. Please help! :-)

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2011 11:15 AM   in reply to suz56

    I went into type book and activated verdana in computer and inactivated verdana in user. It worked.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 7, 2011 6:47 AM   in reply to Maherso

    And now for something completely different:

    I was having this problem and I went to the Fonts folder and saw that Verdana was there!  Just for giggles, I went ahead and dragged the font out of the folder and, yes, After Effects worked just fine for me afterwards!

     

    I'm running a 2.66 GHz Intel Core 2 Duo iMac on 10.6.8, but this problem also reared its ugly head when I was running 10.5.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 17, 2012 3:49 PM   in reply to billsantry
     
    |
    Mark as:
  • Currently Being Moderated
    May 8, 2012 9:25 AM   in reply to billsantry

    I have encountered the same problem on OSX 10.7.3 and I searched for Verdana in the FontBook to find that it was only disabled. Try this first; all you may need to do is enable the font family.

     

    I hope this is helpfull and nobody needs to spend 30$ to fix this error.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 31, 2013 7:34 PM   in reply to CristianM7

    This bug is fixed in the After Effects CC (12.1) update:

    http://adobe.ly/AE_CC_12dot1_details

     

    Let us know how this works for when you've tried with the new update.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2013 6:22 AM   in reply to Todd_Kopriva

    Well Todd, seems the newest version has the same problem, or perhaps an unrelated issue. Just upgraded to Mavericks yesterday (10.9) and I'm running AE 12.1. Closed AE last night after working on a project successfully for 4 + hours, tried to get back to work this morning and I see the following error messages. Is this related?

     

    error_1.pngerror-2.pngerror-3.png

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2013 6:38 AM   in reply to ericsbowman

    That's a different (but related) failure.

     

    If you are using a font manager (like Font Explorer), then re-enable the font.

     

    See this thread:

    http://forums.adobe.com/message/5807941#5807941

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2013 6:48 AM   in reply to Todd_Kopriva

    Thanks Todd.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points