Skip navigation
Currently Being Moderated

Photoshop CS5 Process still working

May 4, 2010 12:46 PM

Hi, i've downloaded the trial of Photoshop CS5 extended, and installed it normally, but when i close the photoshop, with CTRL + Q or ALT + F4, apparently the application closes, but if i use process utility like Process Explorer, i've see that te process of photoshop.exe still running, and also it's consumming the 25% of the CPU usage, supposedly  when I close the program with any of the traditional methods, it is  assumed that the process should be end the photosho.exe, but  not so, why?

 
Replies
  • Currently Being Moderated
    May 5, 2010 2:06 AM   in reply to samuelmarfer

    Strange , it quits the process immediately for me , which OS you are using. Have you confirmed that application is not waiting for any response from you like saving etc.

     
    |
    Mark as:
  • Currently Being Moderated
    May 5, 2010 9:13 AM   in reply to samuelmarfer

    Either it's terminated or it isn't. Closing a window and terminating an app are two different things. The process still lingering would indicate that it is crashing on exit, which could depend on a specific driver on your system getting in the way or PS not correctly handling things like the licensing service...

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 7, 2010 3:20 AM   in reply to samuelmarfer

    I experience this problem also. When closing the PSCS5 window, I notice the process is still running. Starting PS again starts a new process, and so on.

    What I have notices that is very strange, and assures me it is not a driver bug, but a bug on Adobe's side, is that if I select File -> Exit, the process closes perfectly fine.

     

    Please fix this!

     

    I am using Windows 7 64-bit.

     
    |
    Mark as:
  • Noel Carboni
    23,514 posts
    Dec 23, 2006
    Currently Being Moderated
    Jun 7, 2010 10:59 AM   in reply to samuelmarfer

    I have seen Photoshop.exe hang around after the window is closed as well.  I am also on Windows 7 x64.

     

    See this thread:  http://forums.adobe.com/thread/651034?tstart=0

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2010 10:56 AM   in reply to samuelmarfer

    same issue : win7 x64, and photoshop still running in process

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2010 2:19 AM   in reply to Asurani

    Hi,

     

    I can observe the same problem occuring randomly with CS5 (12.0.1) under XP SP3. I just made a quick test a few minutes ago:

     

    1. Launched PS

    2. Immediately closed the main window (but this can also happen after a "real" editing session).

    3. The Task Manager showed that photoshop.exe was still loaded and using 106 752 K.

    4. amt3.log was locked.

    5. photoshop.exe must then be killed. If I launch PS again, a new instance is created and the previous one remains in memory. The new instance may or may not also stay in memory after closing the main window.

     

    Of course, if the user is not aware of this, doesn't kill the ghost process and starts PS multiple times during a Windows session, memory can quickly be exhausted.

     

    Below are the contents of amt3.log and swtag.log (I had deleted them before making the test).

     


     

    2010-08-15 11:05:26 [2788]  AMT: START SESSION, library version 3.0.0.64,3.0
    2010-08-15 11:05:26 [2788]  AMT: Initializing C:\Program Files\Adobe\Adobe Photoshop CS5\
    2010-08-15 11:05:26 [2788]  AMT: Adobe License Manager version 3.2 (build 64.0) RELEASE
    2010-08-15 11:05:26 [2788]  AMT: Failed to disable Virtualization SetTokenInformation Failed
    2010-08-15 11:05:26 [2788]  ServiceLoader: looking for library C:\Program Files\Adobe\Adobe Photoshop CS5\adobe_caps.dll
    2010-08-15 11:05:26 [2788]  ServiceLoader: Found library C:\Program Files\Adobe\Adobe Photoshop CS5\adobe_caps.dll
    2010-08-15 11:05:26 [2788]  PCDService: PCD Service in threaded mode
    2010-08-15 11:05:26 [2788]  performance: AMTPreObtainProductLicense took 6.192687 ms
    2010-08-15 11:05:26 [2788]  PCD thread: PCD thread started
    2010-08-15 11:05:26 [2788]  ServiceLoader: looking for library C:\Program Files\Adobe\Adobe Photoshop CS5\Adobe_OOBE_Launcher.dll
    2010-08-15 11:05:26 [2788]  ServiceLoader: Found library C:\Program Files\Adobe\Adobe Photoshop CS5\Adobe_OOBE_Launcher.dll
    2010-08-15 11:05:26 [2788]  AMT: App Product Locale [0] = en_GB
    2010-08-15 11:05:26 [2788]  config: Loading configuration for C:\Program Files\Adobe\Adobe Photoshop CS5\AMT\application.xml
    2010-08-15 11:05:26 [2788]  config: Found payload code {7DFEBBA4-81E1-425B-BBAA-06E9E5BBD97E}
    2010-08-15 11:05:26 [2788]  PCDService: found driver code {15FEDA5F-141C-4127-8D7E-B962D1742728}
    2010-08-15 11:05:26 [2788]  config: config: Host app was installed, using installed license configuration.
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [FLMap] in hive [Photoshop-CS5-Win-GM{|}ALL] in cache.
    2010-08-15 11:05:26 [2788]  config: Setting current license to the driver at startup because no mapping was found.
    2010-08-15 11:05:26 [2788]  config: Setting current license to Photoshop-CS5-Win-GM [ALL]
    2010-08-15 11:05:26 [2788]  config: payload code: {7DFEBBA4-81E1-425B-BBAA-06E9E5BBD97E}
    2010-08-15 11:05:26 [2788]  config: driver payload code: {15FEDA5F-141C-4127-8D7E-B962D1742728}
    2010-08-15 11:05:26 [2788]  config: driver licensing code: Photoshop-CS5-Win-GM
    2010-08-15 11:05:26 [2788]  config: current licensing code: Photoshop-CS5-Win-GM
    2010-08-15 11:05:26 [2788]  config: current locale code: ALL
    2010-08-15 11:05:26 [2788]  config: Done loading configuration
    2010-08-15 11:05:26 [2788]  AMT: Locale from PCD [0] = en_GB
    2010-08-15 11:05:26 [2788]  AMT: Reordered Installed App Product Locale [0] = en_GB
    2010-08-15 11:05:26 [2788]  config: Setting insalled locales
    2010-08-15 11:05:26 [2788]  config: Changing locale to "en_GB" because old locale "" is not in the new list of installed languages
    2010-08-15 11:05:26 [2788]  ServiceLoader: looking for library C:\Program Files\Adobe\Adobe Photoshop CS5\asneu.dll
    2010-08-15 11:05:26 [2788]  ServiceLoader: Found library C:\Program Files\Adobe\Adobe Photoshop CS5\asneu.dll
    2010-08-15 11:05:26 [2788]  AMT: config: Finding license info for payload: {15FEDA5F-141C-4127-8D7E-B962D1742728}
    2010-08-15 11:05:26 [2788]  AMT: config: PayloadCode: {7DFEBBA4-81E1-425B-BBAA-06E9E5BBD97E}
    2010-08-15 11:05:26 [2788]  AMT: config: Driver PayloadCode: {15FEDA5F-141C-4127-8D7E-B962D1742728}
    2010-08-15 11:05:26 [2788]  AMT: config: Installed LicensingCode: Photoshop-CS5-Win-GM
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [AdobeUpdaterCodeV2] in hive [{7DFEBBA4-81E1-425B-BBAA-06E9E5BBD97E}] in master.
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [AdobeUpdaterCodeV2] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [BridgeTalkCode] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [ISO_TAGGING_DISABLED] in hive [Photoshop-CS5-Win-GM] in master.
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [EULA] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [Registration] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [Registration] in hive [{7DFEBBA4-81E1-425B-BBAA-06E9E5BBD97E}] in master.
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [Updates] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [Updates] in hive [{7DFEBBA4-81E1-425B-BBAA-06E9E5BBD97E}] in master.
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [SuiteFeatureCount] in hive [Photoshop-CS5-Win-GM] in master.
    2010-08-15 11:05:26 [2788]  AMT: Application can be serialized (sif file found).
    2010-08-15 11:05:26 [2788]  config: Setting current license to Photoshop-CS5-Win-GM [en_GB]
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [ExpirationDate] in hive [Photoshop-CS5-Win-GM] in master.
    2010-08-15 11:05:26 [2788]  AMT: Subsequent launch (serial [91198248250290233036]).
    2010-08-15 11:05:26 [2788]  AMT: Application state initialized.  Obtaining Product License.
    2010-08-15 11:05:26 [2788]  AMT: Obtaining client features from cache.
    2010-08-15 11:05:26 [2788]  AMT: Obtaining client product info from cache.
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [ExpirationDate] in hive [Photoshop-CS5-Win-GM] in master.
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [ExpirationDate] in hive [Photoshop-CS5-Win-GM] in master.
    2010-08-15 11:05:26 [2788]  AMT: Running in PROV_APP
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [EULADelay] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [EULADelay] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:26 [2788]  PCDService: No value for key [MediaTag] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:26 [2788]  config: No media tag found for payload {15FEDA5F-141C-4127-8D7E-B962D1742728}
    2010-08-15 11:05:26 [2788]  config: Using default media policy RET
    2010-08-15 11:05:26 [2788]  uiswitch: EULA has already been accepted.
    2010-08-15 11:05:26 [2788]  AMT: This is a subsequent launch. Deferring services.
    2010-08-15 11:05:26 [2788]  performance: AMTObtainProductLicense took 25.348194 ms
    2010-08-15 11:05:33 [2788]  AMT: Pre-Validating Product License.
    2010-08-15 11:05:33 [2788]  AMT: Services not yet loaded in this session.
    2010-08-15 11:05:33 [2788]  AMT: Loading services in background to get ready for Validate call.
    2010-08-15 11:05:33 [2788]  AMT: Spawning background thread to load services.
    2010-08-15 11:05:33 [2788]  performance: AMTPreValidateProductLicense took 0.296686 ms
    2010-08-15 11:05:33 [2788]  AMT: Starting work on prevalidate thread.
    2010-08-15 11:05:33 [2788]  AMT: AMT: PreValidating Product License.
    2010-08-15 11:05:33 [2788]  AMT: Launch Workflow not yet done in this session.
    2010-08-15 11:05:33 [2788]  AMT: Starting Background Subsequent Launch Workflow
    2010-08-15 11:05:33 [2788]  AMT: Starting ALM workflow.
    2010-08-15 11:05:33 [2788]  AMT: Initializing ALM for serialized activation.
    2010-08-15 11:05:33 [2788]  ALMService: Initializing as licensed app
    2010-08-15 11:05:33 [2788]  ALM: _info_: Start ALM 3.2 Release (build 3.2.64.0)
    2010-08-15 11:05:33 [2788]  SLCoreService: Starting up SLCore 1.0 Release (build 1.0.13.199023).
    2010-08-15 11:05:33 [2788]  SLCoreService: Service construction took 0.0 ms and succeed.
    2010-08-15 11:05:33 [2788]  ALM: _info_: LEID passed Photoshop-CS5-Win-GM is used to configure SLCore = 0
    2010-08-15 11:05:33 [2788]  ALM: _info_: Host app is Licensable App
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [Photoshop-CS5-Win-GM{|}6] in hive [SSC-CS5-LE-Dominance] in master.
    2010-08-15 11:05:33 [2788]  ALM: _info_: Found LEID Photoshop-CS5-Win-GM with AMT Path C:\Program Files\Adobe\Adobe Photoshop CS5\AMT
    2010-08-15 11:05:33 [2788]  ALM: _info_: Found LEID DesignSuiteStandard-CS5-Win-GM with AMT Path C:\Program Files\Common Files\Adobe\ssc\DesignSuiteStandard-CS5-Win-GM
    2010-08-15 11:05:33 [2788]  ALM: _info_: Found LEID WebSuitePremium-CS5-Win-GM with AMT Path C:\Program Files\Common Files\Adobe\ssc\WebSuitePremium-CS5-Win-GM
    2010-08-15 11:05:33 [2788]  ALM: _info_: Found LEID DesignSuitePremium-CS5-Win-GM with AMT Path C:\Program Files\Common Files\Adobe\ssc\DesignSuitePremium-CS5-Win-GM
    2010-08-15 11:05:33 [2788]  ALM: _info_: Found LEID VideoSuitePremium-CS5-Win-GM with AMT Path C:\Program Files\Common Files\Adobe\ssc\VideoSuitePremium-CS5-Win-GM
    2010-08-15 11:05:33 [2788]  ALM: _info_: Found LEID MasterCollection-CS5-Win-GM with AMT Path C:\Program Files\Common Files\Adobe\ssc\MasterCollection-CS5-Win-GM
    2010-08-15 11:05:33 [2788]  ALM: _info_: Found LEID ELearningSuite-ES2-Win-GM with AMT Path C:\Program Files\Common Files\Adobe\ssc\ELearningSuite-ES2-Win-GM
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [MediaTag] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:33 [2788]  config: No media tag found for payload {15FEDA5F-141C-4127-8D7E-B962D1742728}
    2010-08-15 11:05:33 [2788]  config: Using default media policy RET
    2010-08-15 11:05:33 [2788]  ALM: _info_: MediaTagPolicy is RET
    2010-08-15 11:05:33 [2788]  ALM: _info_: Canonical LEID is Photoshop-CS5-Win-GM
    2010-08-15 11:05:33 [2788]  ALM: _info_: Driver LEID is Photoshop-CS5-Win-GM
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [926287090233530048226122] in hive [RejectedSNDomain_CS5] in cache.
    2010-08-15 11:05:33 [2788]  SLCoreService: Reading product config [C:\Program Files\Adobe\Adobe Photoshop CS5\AMT\SLConfig.xml]
    2010-08-15 11:05:33 [2788]  ALM: _info_: alm::IsLangPackForLocaleInstalled - Checking if lang pack is installed for ALL

     

    2010-08-15 11:05:33 [2788]  ALM: _info_: alm::IsLangPackForLocaleInstalled - Lang pack is not installed
    2010-08-15 11:05:33 [2788]  ALM: _info_: Set Running Locale to en_GB
    2010-08-15 11:05:33 [2788]  ALM: _time_: (func: ALM_Initialize, duration: 0.016 sec)
    2010-08-15 11:05:33 [2788]  AMT: Performing ALM silent license verification.
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [EncryptedSerial] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in cache.
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [Serial] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in cache.
    2010-08-15 11:05:33 [2788]  config: No pre-serial number found in {15FEDA5F-141C-4127-8D7E-B962D1742728}
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [PSN] in hive [Photoshop-CS5-Win-GM{|}en_GB] in cache.
    2010-08-15 11:05:33 [2788]  config: No en_GB provisional serial number found in Photoshop-CS5-Win-GM
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [PSN] in hive [Photoshop-CS5-Win-GM{|}ALL] in cache.
    2010-08-15 11:05:33 [2788]  config: No ALL provisional serial number found in Photoshop-CS5-Win-GM
    2010-08-15 11:05:33 [2788]  ALM: _info_: Validate license at Post-Chrome time, running locale is en_GB
    2010-08-15 11:05:33 [2788]  ALM: _info_: Searching license for locale en_GB ...
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [911982482502902330369562] in hive [RejectedSNDomain_CS5] in cache.
    2010-08-15 11:05:33 [2788]  ALM: _info_: alm::IsLangPackForLocaleInstalled - Checking if lang pack is installed for en_GB

     

    2010-08-15 11:05:33 [2788]  ALM: _info_: alm::IsLangPackForLocaleInstalled - Lang pack is installed

     

    2010-08-15 11:05:33 [2788]  ALM: _info_: alm::IsLangPackForLocaleInstalled - Checking if lang pack is installed for en_GB

     

    2010-08-15 11:05:33 [2788]  ALM: _info_: alm::IsLangPackForLocaleInstalled - Lang pack is installed

     

    2010-08-15 11:05:33 [2788]  ALM: _info_: Found existing serialization under LEID Photoshop-CS5-Win-GM, the serial number locale is en_GB
    2010-08-15 11:05:33 [2788]  ALM: _info_: This is the running locale, stop the search
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [911982482502902330369562] in hive [RejectedSNDomain_CS5] in cache.
    2010-08-15 11:05:33 [2788]  ALM: _info_: alm::IsLangPackForLocaleInstalled - Checking if lang pack is installed for en_GB

     

    2010-08-15 11:05:33 [2788]  ALM: _info_: alm::IsLangPackForLocaleInstalled - Lang pack is installed

     

    2010-08-15 11:05:33 [2788]  ALM: _info_: alm::IsLangPackForLocaleInstalled - Checking if lang pack is installed for en_GB

     

    2010-08-15 11:05:33 [2788]  ALM: _info_: alm::IsLangPackForLocaleInstalled - Lang pack is installed

     

    2010-08-15 11:05:33 [2788]  PCDService: No value for key [911982482502902330369562] in hive [RejectedSNDomain_CS5] in cache.
    2010-08-15 11:05:33 [2788]  ALM: _info_: alm::IsLangPackForLocaleInstalled - Checking if lang pack is installed for en_GB

     

    2010-08-15 11:05:33 [2788]  ALM: _info_: alm::IsLangPackForLocaleInstalled - Lang pack is installed

     

    2010-08-15 11:05:33 [2788]  PCDService: No value for key [911982482502902330369562] in hive [RejectedSNDomain_CS5] in cache.
    2010-08-15 11:05:33 [2788]  ALM: _info_: alm::IsLangPackForLocaleInstalled - Checking if lang pack is installed for en_GB

     

    2010-08-15 11:05:33 [2788]  ALM: _info_: alm::IsLangPackForLocaleInstalled - Lang pack is installed

     

    2010-08-15 11:05:33 [2788]  config: Setting current license to Photoshop-CS5-Win-GM [en_GB]
    2010-08-15 11:05:33 [2788]  SLCoreService: Syncing to license store...
    2010-08-15 11:05:33 [2788]  SLCoreService: Found server mkey.
    2010-08-15 11:05:33 [2788]  SLCoreService: Loading license references...
    2010-08-15 11:05:33 [2788]  SLCoreService: Found 1 license file(s)
    2010-08-15 11:05:33 [2788]  SLCoreService: Parsing license file [141548637.lic] succeed.
    2010-08-15 11:05:33 [2788]  SLCoreService: License store synchronization took 22.7 ms and succeed.
    2010-08-15 11:05:33 [2788]  SLCoreService: Query license: type = 3, duration = permanent, remaining = permanent.
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [PDApp_WF] in hive [Photoshop-CS5-Win-GM] in cache.
    2010-08-15 11:05:33 [2788]  SLCoreService: Feature ALM_PhotoshopCS5GM_12.0 is enabled.
    2010-08-15 11:05:33 [2788]  SLCoreService: Feature Bridge_Base_4.0 is enabled.
    2010-08-15 11:05:33 [2788]  SLCoreService: Feature Bridge_CameraRaw_4.0 is enabled.
    2010-08-15 11:05:33 [2788]  SLCoreService: Feature Bridge_MiniBridge_1.0 is enabled.
    2010-08-15 11:05:33 [2788]  SLCoreService: Feature MobileCenter_Base_3.0 is enabled.
    2010-08-15 11:05:33 [2788]  SLCoreService: Feature Photoshop_12.0 is enabled.
    2010-08-15 11:05:33 [2788]  SLCoreService: Feature Photoshop_Base_12.0 is enabled.
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [ALM_Info_S1] in hive [Photoshop-CS5-Win-GM{|}en_GB] in cache.
    2010-08-15 11:05:33 [2788]  ALM: _info_: Performing Block Check

     

    2010-08-15 11:05:33 [2788]  SLCoreService: Query license: type = 3, duration = permanent, remaining = permanent.
    2010-08-15 11:05:33 [2788]  ALM: _info_: Block Check ByPassed

     

    2010-08-15 11:05:33 [2788]  SLCoreService: Query license: type = 3, duration = permanent, remaining = permanent.
    2010-08-15 11:05:33 [2788]  ALM: _time_: (func: ALM_License_SilentValidate, duration: 0.047 sec)
    2010-08-15 11:05:33 [2788]  ALM: _info_: ALM_License_SilentValidate return license status: Valid And Activated
    2010-08-15 11:05:33 [2788]  AMT: License check shows serialized product is already activated.
    2010-08-15 11:05:33 [2788]  ALM: _info_: Entered ALM_NeedANAG
    2010-08-15 11:05:33 [2788]  ALM: _info_: Exiting ALM_NeedANAG
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [AdobeUpdaterCodeV2] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [AdobeUpdaterCodeV2] in hive [{7DFEBBA4-81E1-425B-BBAA-06E9E5BBD97E}] in master.
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [Updates] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [Updates] in hive [{7DFEBBA4-81E1-425B-BBAA-06E9E5BBD97E}] in master.
    2010-08-15 11:05:33 [2788]  AUMService: config: No AdobeUpdaterCode found in configuration; AUM will be disabled.
    2010-08-15 11:05:33 [2788]  ServiceLoader: looking for library C:\Program Files\Adobe\Adobe Photoshop CS5\updaternotifications.dll
    2010-08-15 11:05:33 [2788]  ServiceLoader: Found library C:\Program Files\Adobe\Adobe Photoshop CS5\updaternotifications.dll
    2010-08-15 11:05:33 [2788]  AUMService: IsUpdaterEnabled call
    2010-08-15 11:05:33 [2788]  AUMService: IsUpdaterEnabled call succeeded
    2010-08-15 11:05:33 [2788]  ALM: _info_: Deactivation menu is enabled
    2010-08-15 11:05:33 [2788]  AMT: Completed Launch Workflow successfully.
    2010-08-15 11:05:33 [2788]  AMT: Calling AUM API to create scheduler entry to be used by updater.
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [AdobeUpdaterCodeV2] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [AdobeUpdaterCodeV2] in hive [{7DFEBBA4-81E1-425B-BBAA-06E9E5BBD97E}] in master.
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [Updates] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [Updates] in hive [{7DFEBBA4-81E1-425B-BBAA-06E9E5BBD97E}] in master.
    2010-08-15 11:05:33 [2788]  AUMService: config: No AdobeUpdaterCode found in configuration; AUM will be disabled.
    2010-08-15 11:05:33 [2788]  AUMService: IsUpdaterEnabled call
    2010-08-15 11:05:33 [2788]  AUMService: IsUpdaterEnabled call succeeded
    2010-08-15 11:05:33 [2788]  AUMService: Get LEID xml call
    2010-08-15 11:05:33 [2788]  AUMService: Get LEID XML call succeeded
    2010-08-15 11:05:33 [2788]  AMT: AUM GetLEID called with status =0.
    2010-08-15 11:05:33 [2788]  AMT: Checking client features against cache.
    2010-08-15 11:05:33 [2788]  AMT: Feature AMT_ALLOW_DRAGDROP_INSTALL 3.0 is unlicensed (was unlicensed).
    2010-08-15 11:05:33 [2788]  AMT: Feature AMT_REQUEST_NO_TAMPERPROOFING 3.3 is unlicensed (was unlicensed).
    2010-08-15 11:05:33 [2788]  AMT: Feature Photoshop_Premium 12.0 is unlicensed (was unlicensed).
    2010-08-15 11:05:33 [2788]  AMT: Feature Photoshop_Base 12.0 is licensed (was licensed).
    2010-08-15 11:05:33 [2788]  AMT: Feature Bridge_Base 4.0 is licensed (was licensed).
    2010-08-15 11:05:33 [2788]  AMT: Feature Bridge_CameraRaw 4.0 is licensed (was licensed).
    2010-08-15 11:05:33 [2788]  AMT: Feature MobileCenter_Base 3.0 is licensed (was licensed).
    2010-08-15 11:05:33 [2788]  AMT: Validating client product info against cache.
    2010-08-15 11:05:33 [2788]  PCDService: No value for key [ExpirationDate] in hive [Photoshop-CS5-Win-GM] in master.
    2010-08-15 11:05:33 [2788]  AMT: Starting Data Collection for SWTag_Init()
    2010-08-15 11:05:33 [2788]  AMT: DoISOTagging() productCanonicalLEID = Photoshop-CS5-Win-GM;outMappedLEID =  Photoshop-CS5-Win-GM, unused = Photoshop-CS5-Win-GM
    2010-08-15 11:05:33 [2788]  AMT: DoISOTagging() productPayloadCode = {7DFEBBA4-81E1-425B-BBAA-06E9E5BBD97E};driverPayloadCode =  {15FEDA5F-141C-4127-8D7E-B962D1742728}
    2010-08-15 11:05:33 [2788]  AMT: SWTag_Init() Tags Arguments Adobe Photoshop CS5; Photoshop-CS5-Win-GM; en_GB
    2010-08-15 11:05:33 [2788]  AMT: DoISOTagging() License Status = activated
    2010-08-15 11:05:33 [2788]  AMT: DoISOTagging() Tags 911982482502902330369562; 12.0; RETAIL
    2010-08-15 11:05:33 [2788]  AMT: DoISOTagging() Product Version 12; 0
    2010-08-15 11:05:33 [2788]  AMT: AMT: Product License PreValidated.
    2010-08-15 11:05:33 [2788]  AMT: Prevalidate indicates license is good and no UI required.
    2010-08-15 11:05:33 [2788]  performance: PreValidate thread took 96.114731 ms
    2010-08-15 11:05:33 [2788]  AMT: PlugPlug : AdobeId has been created or SN with no SaaS bit
    2010-08-15 11:05:33 [2788]  AMT: PlugPlug : Can Go Online returned as true
    2010-08-15 11:05:33 [2788]  performance: AMTPlugPlugRequest took 25.290924 ms
    2010-08-15 11:05:33 [2788]  performance: AMTPlugPlugRequest took 0.655391 ms
    2010-08-15 11:05:33 [2788]  performance: AMTPlugPlugRequest took 0.843124 ms
    2010-08-15 11:05:33 [2788]  performance: AMTPlugPlugRequest took 0.684165 ms
    2010-08-15 11:05:33 [2788]  performance: AMTPlugPlugRequest took 0.645613 ms
    2010-08-15 11:05:35 [2788]  PCDService: No value for key [AdobeUpdaterCodeV2] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:35 [2788]  PCDService: No value for key [AdobeUpdaterCodeV2] in hive [{7DFEBBA4-81E1-425B-BBAA-06E9E5BBD97E}] in master.
    2010-08-15 11:05:35 [2788]  PCDService: No value for key [Updates] in hive [{15FEDA5F-141C-4127-8D7E-B962D1742728}] in master.
    2010-08-15 11:05:35 [2788]  PCDService: No value for key [Updates] in hive [{7DFEBBA4-81E1-425B-BBAA-06E9E5BBD97E}] in master.
    2010-08-15 11:05:35 [2788]  AUMService: config: No AdobeUpdaterCode found in configuration; AUM will be disabled.
    2010-08-15 11:05:35 [2788]  AUMService: UpdaterNotificationsLaunchAAMNotifierOnQuitIfReqd call
    2010-08-15 11:05:35 [2788]  AUMService: UpdaterNotificationsLaunchAAMNotifierOnQuitIfReqd call succeeded
    2010-08-15 11:05:35 [2788]  AMT: AUM UpdaterNotificationsLaunchAAMNotifierOnQuitIfReqd called with status =0.
    2010-08-15 11:05:35 [2788]  ALMService: Terminating
    2010-08-15 11:05:35 [2788]  SLCoreService: Shutting down SLCore 1.0 Release (build 1.0.13.199023).
    2010-08-15 11:05:35 [2788]  SLCoreService: Service destruction took 4.3 ms and succeed.
    2010-08-15 11:05:35 [2788]  ALM: _info_: End ALM
    2010-08-15 11:05:35 [2788]  performance: AMTReleaseProductLicense took 12.103214 ms
    2010-08-15 11:05:35 [2788]  AMT: END SESSION.


    2010-08-15 11:05:33 [2788] SWTAG: _info_: __SWTAG_LOG_FILE__
    2010-08-15 11:05:33 [2788] SWTAG: _info_: Get privilege info for "G:\Temp\swtag.log" returned 0
    2010-08-15 11:05:33 [2788] SWTAG: _info_: Set privilege info for "G:\Temp\swtag.log" returned 0
    2010-08-15 11:05:33 [2788] SWTAG: _info_: ==========================================
    2010-08-15 11:05:33 [2788] SWTAG: _info_: Start SWTAGGING productName=Adobe Photoshop CS5; licensingCode=Photoshop-CS5-Win-GM; locale=en_GB; caller=1
    2010-08-15 11:05:33 [2788] SWTAG: _info_: Get privilege info for "C:\Documents and Settings\All Users\Application Data\regid.1986-12.com.adobe" returned 0
    2010-08-15 11:05:33 [2788] SWTAG: _info_: Set privilege info for "C:\Documents and Settings\All Users\Application Data\regid.1986-12.com.adobe" returned 0
    2010-08-15 11:05:33 [2788] SWTAG: _info_: Reading existing C:\Documents and Settings\All Users\Application Data\regid.1986-12.com.adobe\regid.1986-12.com.adobe_Photoshop-CS5-Wi n-GM-en_GB.swidtag file
    2010-08-15 11:05:33 [2788] SWTAG: _info_: End SWTAGGING
    2010-08-15 11:05:33 [2788] SWTAG: _info_: ==========================================

     


     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2010 5:17 AM   in reply to Samoreen

    I dont understand all this stuff,

     

    but this bug is really getting on my nerves...

     

    Premiere Pro CS5 does it like everytime....

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2010 6:34 AM   in reply to Asurani

    Asurani wrote:

     

    I dont understand all this stuff,

     

    Never mind. This information is aimed at any developer from Adobe who could possibly give a look at this thread. I have sent a bug report anyway.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2010 12:57 AM   in reply to samuelmarfer

    Hi,

     

    Attn: Users having this problem

     

    Could you please list all the plugins that you are using? Maybe there's a plugin preventing PS from shutting down properly? At least, if we don't have at least one plugin in common, this would mean that it's a PS problem. If we have a plugin in common and if the problem disappears when we disable it, we'll have found the culprit.

     

    I'm using the following plugins:

     

    Nik Software Silver Efex

    Photokit Sharpener
    FocalBlade

    DxO plugins

    Noise Ninja

    Photomatix

    Noiseware

    Epson Print plugin

    PowerRetouche Golden Section

    Topaz Adjust

     

     

    Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2010 1:21 AM   in reply to Samoreen

    No plugin at all for Photoshop CS5

     

    as for PRemiere Pro CS5, it's was staying in the process even before I installed some plugin.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2010 3:22 AM   in reply to Asurani

    Asurani wrote:

     

    No plugin at all for Photoshop CS5

     

    as for PRemiere Pro CS5, it's was staying in the process even before I installed some plugin.

     

    Thanks. So it's now clear that it's a PS problem.

     
    |
    Mark as:
  • Noel Carboni
    23,514 posts
    Dec 23, 2006
    Currently Being Moderated
    Aug 20, 2010 9:10 AM   in reply to Samoreen

    I see a "stuck" Photoshop.exe (32 or 64 bit) process only very occasionally.

     

    I do not have any of your plugins.  I do have these:

     

    64 bit:

     

    • OnOne Software Genuine Fractals
    • My own plugins under development

     

    32 bit

     

    • OnOne Software Genuine Fractals
    • Astra Image Deconvolution
    • Focus Magic Deconvolution
    • NASA/ESA FITS Liberator
    • My own plugins under development

     

    I am sure that on rare occasion I have seen the Photoshop process hang around after simply opening Photoshop, checking a preference (or taking a screen shot of a dialog), canceling, then closing it.  I often do this kind of thing to support posts on this forum.

     

    It's infrequent enough that when I have thought to look for the process it isn't stuck.  At some point after the system's been running for days I might be doing some debugging, go to attach to a process with Visual Studio, and find several Photoshop.exes in the list of process choices.

     

    It seems to be happening less lately than in prior months.  Notably I have updated to Photoshop 12.0.1 and the most recent video drivers from ATI, and of course the Microsoft Windows 7 Updates as they roll them out.

     

    I've never seen a version of Photoshop prior to CS5 do this before, and I have used Photoshop since the 1990s daily.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2010 1:46 PM   in reply to Noel Carboni

    I just checked here and it closes in processess immediately. One caveat: Defrag (CC cleaner version) is running at the moment.

     

    Win7 64, CS5 Standard

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2010 1:50 PM   in reply to Hudechrome

    Hudechrome wrote:

     

    I just checked here and it closes in processess immediately. One caveat: Defrag (CC cleaner version) is running at the moment.

     

    Win7 64, CS5 Standard

     

    Hi,

     

    Beware: the problem appears randomly. So you should check in the Task Manager each time you exit (until the problem is fixed).

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2010 2:41 PM   in reply to Samoreen

    I just checked CS3 and CS5 on XP Sp3. That shows no problem either.

     

    I will monitor this on Win7 but not too likely on XP. IIRC, if PS or Bridge hangs during Exit then you attempt to restart it, you get a message that it is already running. Can't be 100% sure for Adobe but I know it's true for Firefox even though multiple windows can be invoked.

     

    Has Adobe verified it as a bug?

     

    Message was edited by: Hudechrome

     
    |
    Mark as:
  • Noel Carboni
    23,514 posts
    Dec 23, 2006
    Currently Being Moderated
    Aug 20, 2010 3:06 PM   in reply to Hudechrome

    I am not Adobe, but I can verify it's a bug.

     

    Somewhere around here is a post where I screen grabbed Task Manager with several of them running.  Their existence does not stop you from starting a fresh one...

     

    Edit, here, I found it:  http://forums.adobe.com/thread/686376

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2010 3:12 PM   in reply to Hudechrome

    Has Adobe verified it as a bug?

     

    We still haven't been able to reproduce the problem.

     
    |
    Mark as:
  • Noel Carboni
    23,514 posts
    Dec 23, 2006
    Currently Being Moderated
    Aug 20, 2010 3:19 PM   in reply to Chris Cox

    Chris, if I should see it happen again - and as I mentioned it seems to be getting more rare - did you determine whether there's more I can dig out about what's gone wrong?  I can stop Photoshop in the debugger (as I have done before) or anything else you need, providing I have the tools.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2010 3:26 PM   in reply to Noel Carboni

    Stopping in the debugger might give some idea what module you're in, but Photoshop doesn't ship with symbols - so you won't be able to get much.

     

    And no, I don't think there's much more info you could get -- unless you figure out how to reproduce it :-).

     
    |
    Mark as:
  • Noel Carboni
    23,514 posts
    Dec 23, 2006
    Currently Being Moderated
    Aug 20, 2010 3:54 PM   in reply to Chris Cox

    I'll watch for it.  Somewhere in my heart of hearts I somehow suspect the drivers' implementation of OpenGL is at fault.

     

    Lately I'm just allowing my 32 bit Photoshop to run with OpenGL disabled, until such time as AMD releases new drivers that make Photoshop happy at startup.  That could explain why I'm seeing fewer of the 32 bit Photoshop.exe files hanging around than before, when I was forcing Photoshop 32 bit to use OpenGL via the registry tweak.

     

    For 64 bit Photoshop, which I use most often, OpenGL is enabled in Normal mode, but I don't think I ever saw as many of those get "stuck" on exit as with the 32 bit executable.

     

    Did you ever get to the bottom of the "DDE Server" fault on Photoshop exit?

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2010 5:40 PM   in reply to Noel Carboni

    Premier Pro is implicated as well, but in my trial run, I never experienced the problem either. Same with Audition. I also held all three open and variously minimized and still it ran fine. No running out of memory. Of course, maybe I wasn't pushing it hard enough...nah! Pr pushed memory real good!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 21, 2010 5:03 AM   in reply to Hudechrome

    Hudechrome wrote:


    IIRC, if PS or Bridge hangs during Exit then you attempt to restart it, you get a message that it is already running.

     

    Not in that case. When preventing multiple instances of a given application to run simultaneously, the message (if any) always comes from the application itself, not from Windows. There are many methods to do that. None is 100% foolproof. There's obviously such a mechanism in PS since I can't launch multiple instances of the application (unless the problem occurs). But there's no  warning message in that case. The second instance just exits.

     

    In our case, PS might have already released the objects used to control the creation of a new instance (which can give to the developers an information about where the program hangs).

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 21, 2010 9:44 AM   in reply to Samoreen

    My recollections aren't too good any more.

     

    Thanks for the clarification.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points