Skip navigation
Currently Being Moderated

Installing on Eclipse 3.4.2 and Windows 7 (64bits)

May 12, 2010 1:15 AM

I installed the tool on Eclipse 3.4.2 / Windows 7 (64bits) and I got the follow error when trying to start the project creation wizard:

The selected wizard could not be started.

  Plug-in com.adobe.livecycle.cde was unable to load class com.adobe.livecycle.cde.wizard.CdeWizard.

  Bad version number in .class file

 

This was suggesting that I was using the wrong JDK version. But I tried different things without making progress:

 

Running : “java –version” from the cmd line and making sure JDK 1.6 was indeed the version running.

Putting the JAVA_HOME to JDK 1.6 in the path first.

Windows->Preferences->Installed JREs-> Making sure it is set to a jdk1.6

Windows->Preferences->Java->Compiler

Making sure the compiler compliance level was set to 1.6

Making sure I downloaded the latest build (at least lcwcdtool_p1_050710.zip)

 

Finally, considering that I was using a 64bit JDK, I decided to install the 32bit version, and the problem was solved. I have been searching for any similar issue, and found this note in the Sun JDK release notes:

 

When installing Java on a 64 bit Windows system, the 64 bit javaws becomes the default handler even if the 32 bit version were already installed. This will cause all 32 bit only applications (like JavaFX) to fail when 64 bit Java was installed last (after 32 bit Java). This issue applies to any JNLP based applications.

The workaround for this issue is to install the 64-bit version of Java first, and then install the 32-bit version of Java. If they were installed in the other order, then reinstalling the 32-bit version of Java will fix.

 

That may explain why installing the 32bit version solved the issue.

 

As far as I know the issue is only with Eclipse 3.4.2 and probably not specific to the plug-in.

 
Replies
  • Currently Being Moderated
    May 12, 2010 10:51 AM   in reply to Herve Dupriez

    Thank You for posting, Herve. This is very valuable experience in case others hit the same problem with 32 vs. 64bit JDK compatibility.

     

    The instructions on the Labs page (and our sample pre-packaged ecliplse zip) use Ecliplse 3.4.2. But in hindsight I think Ecliplse 3.5 is much easier to set up and configure for the Component Development Tool anyway. For example you can just use its Updater to add "Modeling" support and you are ready to install the Plug-in (no need to install GEF and EMF as separarate updates).

     

    Please do post any feedback or feature ehancement that you think would be worthwhile.

     

    Gary.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points