Skip navigation
Currently Being Moderated

"Waiting for Adobe Flash Player to connect to debugger..."

May 13, 2010 6:35 AM

Having an issue where after installing 10.1 debug build and then stepping back to 10.0 debug on Windows 7 and Flash Builder 4 the debugger will no longer connect:

http://content.screencast.com/users/IvanSlepchenko/folders/Jing/media/ 206aa0ea-4c5c-43e6-97f2-2f8f58df25ea/2010-05-13_1522.png

 

After 1-2 minutes it times out with Launch Failed: Failed to connect; session timed out.  Esnure that: 1. You compiled your Flash application with debugging on.  2. You are running the debugger version of Flash Player.

 

Any thoughts on what may be happening here?  Nothing else has changed and after searching for quite a while for answers nothing has resolved the issue.

 
Replies
  • Currently Being Moderated
    May 13, 2010 6:50 AM   in reply to ylluminate

    Can you verify if right clicking on the running SWF lists "Debugger" in the menu?

     

    Also, are you on Google Chrome?

     
    |
    Mark as:
  • Currently Being Moderated
    May 13, 2010 7:03 AM   in reply to ylluminate

    To make it clear: You cannot see "Debugger" when you right click on your app running in the browser?

     

    Then please run the flash player 10.1 uninstaller from http://labs.adobe.com/downloads/flashplayer10.html and then install your preferred debug player.

     
    |
    Mark as:
  • Currently Being Moderated
    May 13, 2010 7:17 AM   in reply to ylluminate

    Flash Builder listens on a port and when the debug swf is loaded, flash player connects to that port.

     

    By chance did you block Flash Builder in the firewall on Win 7?

     

    I know this might be time consuming for you to try out, but if you reinstall 10.1, does debug work?

     
    |
    Mark as:
  • Currently Being Moderated
    May 13, 2010 1:24 PM   in reply to ylluminate

    Additionally the following is seen:

    http://www.screencast.com/users/IvanSlepchenko/folders/Jing/media/b89c 1ddb-d3c6-4749-9d09-2beab6f20121

     

    So, please correct if I am wrong, but the debug server is listening, but then times out because for SOME REASON the client is not connecting to it.  For some reason it is isolated and thus the timeout?

     

    What could be happening here?

     
    |
    Mark as:
  • Currently Being Moderated
    May 13, 2010 10:55 PM   in reply to ylluminate

    Try this:

     

    1. Hit debug in Flash Builder.

    2. Run cmd.exe. In the console, type in telnet localhost 7935 (On Win 7, telnet has to be installed via Programs/Features panel)

     

    Let me know if telnet connects and what you see in the screen.

     

    Another thing to try out:

     

    By default on Win 7 / Vista, Flash Builder uses the IPV4 stack. You may want to try changing this by going to installdir/flashbuilder.ini and taking away the -Djava.net.preferIPv4Stack=true line.

     

    Thanks,

    Anirudh Sasikumar

    Flash Builder Engineering

     
    |
    Mark as:
  • Currently Being Moderated
    May 27, 2010 8:11 PM   in reply to Anirudh Sasikumar

    I am also struggling with this issue.

     

    When I try the telnet option I get:-

    ▼∟disable_script_stuck_dialogon∟disable_script_stuckon↕∟break_on_fault on▬∟enumer
    ate_overrideon§∟notify_on_failureon↕∟invoke_setterson§∟swf_load_messag eson¶∟gett
    er_timeout1500¶∟setter_timeout5000♦☺☺

     

    Connection to host lost.

     

     

    When I right click on the swf file, the 'debugger' option is greyed out.

     

    It occurs on IE and Firefox.

     

    I have installed the flash debugger V 10,0,45,2 isntalled of the activeX for firefox. I have tried with 10.1.53.38

     

    IE has 10.1.53.38 installed. When I run the uninstaller and try an install the 10.4.45.2 it tells me its not the latest version and won't install.

     

     

    Both Flex Builder 3 and FLash Builder 4 (trial) do this to me.

     

    I am running WIndows 7 (64Bit).

     

     

    pinging localhost returns my computer and domain name, not 127.0.0.1

     

    ▼∟disable_script_stuck_dialogon∟disable_script_stuckon↕∟break_on_fault on▬∟enumer
    ate_overrideon§∟notify_on_failureon↕∟invoke_setterson§∟swf_load_messag eson¶∟gett
    er_timeout1500¶∟setter_timeout5000♦☺☺

     

    Connection to host lost.

     

    ping localhost

     

    Pinging myComputerName.Domain.Local [::1] with 32 bytes of data:
    Reply from ::1: time<1ms
    Reply from ::1: time<1ms
    Reply from ::1: time<1ms
    Reply from ::1: time<1ms

     

    Any assistance would be great.

     

    Andrew

     
    |
    Mark as:
  • Currently Being Moderated
    May 27, 2010 11:15 PM   in reply to AndrewJHarrisson

    Actually,

     

    I am compiling and running this on the server.

    In the flex build path, I have the output folder as:       W:\development\

     

    and the output folder URL references is:      http://*****/development/

     

    Which has worked fine previously, and I don't get the sandbox violations etc.  If I change the output folder to bin-debug and leave the output URL blank the debugger connects.

     

    I am not sure what has changed.... I think the old style has worked on windows7, it certainly did on my old XP box.

     

    Andrew

     
    |
    Mark as:
  • Currently Being Moderated
    May 28, 2010 2:40 AM   in reply to AndrewJHarrisson

    Hi Andrew,

     

    Your telnet output looks fine. it means that the debugger is listening.

     

    If the Debugger option is grayed out, it usually means that the SWF is not a debug version.

     

    Can you confirm that bin-debug and the URL points to the same debug SWF? (Just save the SWF in firefox by typing in the URL and compare the size with the one in bin-debug)

     

    Also, more details on the sandbox violation error would be helpful.

     

    Thanks,

    Anirudh

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 29, 2010 5:41 AM   in reply to Anirudh Sasikumar

    Hello,

     

    I see you have suggested the telnet local host 7935. When i do this i get the error:

     

    Connecting to localhost...Could not open connection to the host on port 7935: connect failed.

     

    Is this the reason i always get the "Where is the debugger located" pop up? How can i fix this?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 29, 2010 7:42 AM   in reply to flexillu10

    Flash Builder listens on port 7935 only when you hit debug.

     

    If you're getting the pop simply by loading the SWF in IE, that is a different issue.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2010 4:53 AM   in reply to Anirudh Sasikumar

    I fixed this problem running Adobe Flash Builder 4 under administrator mode.

     

    E

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2011 4:22 AM   in reply to ylluminate

    Hi,

     

    i also same type of problem.

    when i run the application from Flash builder 4 in debug mode

    i have Window XP install on my PC.

    i use Flex sdk 4.1

    the application is run but in the Flash Builder the message "Waiting for Adobe Flash Player to connect to debugger..." at 57%.

     

     

    nothing happen until an error message is come that say your timeout.

     

    Where is the problem.

     

     

    Please i need Help in this regard.

     

     

     

    Thanks

     

     

    Tahir Alvi

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 9, 2011 10:42 PM   in reply to ylluminate

    I've been plagued with this issue for over a week now. I've tried all the solutions printed here and none of them have been successful. After reading this thread, however, it did provide me with some new insight on things I could try. I downloaded the sysinternal tools and have been running tcpview to see what is going on with the ports on my machine. What I'm finding is that after my first successful debugger session, the port (7935) will stay in the CLOSE_WAIT state with a process id of eclipse.exe.

     

    Of course, attempting a telnet at this point fails because nothing is listening on the port. If I try to launch a new debugger session, the debugger can't acquire the port and must be failing silently. When I first discovered this, I could close the connection and then subsequent sessions would execute fine (using tcpview). Now, however, closing the connection will prevent flash builder from ever acquiring the port again. It just never shows up again in tcpview. I can close flash builder and restart the machine and then it will work one more time.

     

    Unfortunately, the project I'm working on takes about 25 minutes to fire up from start to finish. So, having this issue with the debugger has all but prevented me from making any progress on my current workload.

     

    ANY information someone might have here would be invaluable. I am completely running out of ideas.

     

    I'm running jdk 6 update 26 (1.6.0_26-b03) with Flash Builder 4 installed as a plugin to a barebones eclipse version 3.5.2.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 10, 2011 5:07 AM   in reply to cafeParadox

    Thank you for that analysis. That nails down the issue you are facing.

     

    If it is in CLOSE_WAIT, that means that Flash Builder for some reason might not be acknowledging the hard close from the browser plugin. A possible workaround: hit terminate (the red stop button in the debug pane) in Flash Builder before closing the browser tab/page.

     

    Meanwhile, I'll file a bug on this - what you are facing is definitely a bug.

     

    P.S: We had a similar bug http://bugs.adobe.com/jira/browse/FB-9902?focusedCommentId=169463&page =com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#ac tion_169463 except for the fact that the port was in LISTENING there.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 10, 2011 5:34 AM   in reply to cafeParadox

    cafeParadox,

     

    To track your specific issue, I've filed https://bugs.adobe.com/jira/browse/FB-31224

     

    Others on the thread,

     

    Some of you may be facing this issue. If so, you can confirm it by verifying if debug launch (on a web project) works the first time and not afterwards. If this is not the reason you have the same symptom, as discussed in this thread, it can be due to:

     

    * Firewall. Make sure TCP port 7935 is open.

    * Incorrectly using release SWF instead of debug SWF.

    * Having release player installed instead of debug plugin.

    * Chrome using its builtin release player (which needs to be manually overriden to give the debug player priority)

    * IPV4 stack disabled (windows only, Flash Builder 4/4.1 users only, this is fixed for 4.5)

     

    -Anirudh

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 10, 2011 9:08 PM   in reply to ylluminate

    Thanks Anirudh!

     

    I'm glad to know I wasn't crazy. I had tried stopping the debugger before closing the browser with no success. However, clicking the "disconnect" button would gracefully close the port. That was a huge lifesaver today and I"m a little embarrased for not having tried that earlier.

     

    Perhaps the discussion and solutions here will benefit others.

     

    Again, thanks for your help Anirudh.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 28, 2011 9:04 AM   in reply to ylluminate

    If you tried the above solutions without success, check the configuration of your hosts file. I had mine configured such that localhost was bound to an ip address on my app server rather than the default location (127.0.0.1 usually). What I had to do was right-click in the running application (the html page in my case) and select 'Debugger' from the menu. In the dialog that comes up change the settings to 'Other Machine', input the correct ip address, and hit connect.

     

    Thanks to therush (http://therush.wordpress.com/2008/03/11/resolved-flex-builder-3-debugg er-stopped-working/) for this fix.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 16, 2011 12:20 AM   in reply to bucpatr1

    bucpatr1, thank you!!! I couldn't even remember changing my localhost (and hit my head when I read your post). Hours of frustration are now at an end

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 4, 2013 8:21 AM   in reply to ylluminate

    Like zangheri said, running FB as Administrator worked for me. There was also another workaround: while FB is stuck at 57%, go to your browser and load the webapplication. As soon as it's loaded, FB's debugger kicks in and you can continue on. PITA.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points