Skip navigation
Currently Being Moderated

Horrible font kerning when anti-aliasing is none in PS CS5

May 17, 2010 10:35 AM

Hello I found this bug:

 

When I type in Photoshop CS5, with Tahoma 12 pt anti-aliasing: none (or any other font)

I get really bad looking text.

When I do this in Photoshop CS4 everything is perfect.

Please see the picture below:

 

1.png

 

 

 

I wrote with this to Adobe Support they told me to try turn off the OpenGL in photoshop performance preferences but it didn't work.

 

I tried to:

- turn off OpenGL

- change advanced settings of OpenGL

- reinstalling Photoshop

- changing to different fonts

 

I'm using Mac OSX 10.6.3 (64-bit)

with NVIDIA GeForce 9600 M GT

 

Does anyone has the same problem ?

Maybe someone solved it ?

 

Chris

 
Replies
  • Currently Being Moderated
    May 17, 2010 11:01 AM   in reply to k.zieba

    How do they look at 100%? (Actual Pixels)

    Could be a "font hinting" display difference, not kerning.

     
    |
    Mark as:
  • Currently Being Moderated
    May 17, 2010 11:10 AM   in reply to k.zieba

    Yeah, that looks like with antialiasing off it isn't enforcing a minimum distance between glyphs (resulting in a zero distance sometimes).

    That's a bug we'll have to look into.

     
    |
    Mark as:
  • Currently Being Moderated
    May 17, 2010 6:30 PM   in reply to k.zieba

    I don't think so, because font rasterization has nothing to do with the video card.

    It looks like it could be a bug in our layout engine.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 9, 2010 4:07 AM   in reply to k.zieba

    I have the exact same problem, also on Mac OS X 10.6.3.

    Looking forward to any update. I'm usig CS4 until that

    Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 9, 2010 4:27 AM   in reply to k.zieba

    I found it!!!!!

    In the Character tab, just ckeck System Layout (Fractional Widths is the default). Should work from now on... Screen shot 2010-06-09 at 2.22.55 PM.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 9, 2010 6:13 AM   in reply to k.zieba

    Yes, I thought I've got it, but it looks wrong. Depending on some different font sizes, you can get a better display, but Adobe shoud fix this as soon as possible, because it's very frustrating

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 10, 2010 11:39 AM   in reply to k.zieba

    OK, I am able to reproduce this now. 

    I am sorry for your inconvenience.

     

    Thank you,

    Kyoko

    Photoshop QE

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 24, 2010 4:36 PM   in reply to k.zieba

    Could you test again with Fractional Widths off, please?

    Character panel > more option, uncheck both Fractional Widths and System Layout.

    Does this fix your problem?

     

    Thanks,

    Kyoko

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2010 12:40 AM   in reply to kitoda

    Hi Kyoko,

     

    I have same problem, your solution does not fix our problem. I update my photoshop to 12.0.1. and this bug still continue.

     

    Sorry for my english

     

    Michal Svoboda

     

    MITON CZ, Czech Republic

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2010 8:55 AM   in reply to k.zieba

    Please read previous responses on how to work around the issue.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2010 1:57 PM   in reply to k.zieba

    Hi Chris, k.zieba,

    Thank you very much for your update.

    We need to look into this...

     

    Thanks,

    Kyoko

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 25, 2010 12:20 PM   in reply to k.zieba

    None of the suggested workarounds fix this issue - OpenGL mode, Fractional widths on or off, System Layout, different font, etc. Seeing this with Tahoma, Helvetica, and Verdana at 11pt, no antialiasing. I've tried Metrics, Optical, and "0" for kerning. Either the characters are run together very closely at seemingly random kerning pairs or they are spaced noticeably far apart. I'm using Snow Leopard (10.6.4)

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 5, 2010 3:16 AM   in reply to k.zieba

    Hi.

     

    Since two days I have the Trial Version of PS CS5 on my iMac because I'm waiting for my "real" Master Collection :-). I have exactly the same problem but I'm using Mac OSX 10.6.4 (64-bit) with ATI Radeon HD 5750 which exclude the graphic card (I guess). I've tried the same things like you but it didn't work either. Because of this bug I'm a bit shocked. I'm a Webdesigner and besides of all new features I need the Font looking good!!! But surprisingly I've found no other Posts than yours about this problem so I hope it is not a problem. The PS CS5 Update 12.0.1 didn't eliminate this bug at all. I hope with my upcoming Full Version this bug will be gone (I don't want to face the reality :-)).

     

    Sorry for my English.

     

    Franziska, Germany

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2010 5:18 AM   in reply to k.zieba

    Any news about an update for this issue? It is still very present and there has been no update for months...

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2010 10:48 AM   in reply to Ben Smeets

    Yes, this is known issue with some of the fonts on smaller font sizes. We have been working for a solution.

     

    -Vinod

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 19, 2010 4:00 AM   in reply to k.zieba

    You should keep buying more Macs until the bug goes away. Or you can recognize that Adobe employees have already recognized in this discussion that this is a problem with Photoshop, not Mac. 

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 1, 2010 1:28 AM   in reply to k.zieba

    Hi dear, this is your solituon.

     

    Screen-shot-2010-12-01-at-11.26.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 1, 2010 1:33 AM   in reply to nacikatirci

    Cheers! Not a total fix, but a great workaround nonetheless

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 1, 2010 6:20 AM   in reply to Ben Smeets

    Clearly total fix.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 11, 2011 11:50 AM   in reply to Ben Smeets

    Thanks for the fix Ben!

     

    For months I've been rasterizing text layers and adjusting manually.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 30, 2011 5:27 AM   in reply to k.zieba

    I'm experiencing the same problem.

     

    Any news concerning a total fix?

     

    Thx

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 30, 2011 5:56 AM   in reply to sicksnot_ats
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2011 3:52 AM   in reply to k.zieba

    Thanks Charles for your message.

     

    It's really disappointing that no solution has been found.

    I'm almost ready to get back to CS4.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2011 11:12 AM   in reply to sicksnot_ats

    Please read the topics (and this one).

     

    The workaround for the change in OS behavior is to set the width to 99% or 101%.

    This is one of the disadvantages of using OS APIs for text - when the OS changes behavior, you get their new behavior whether you want it or not, and have to live with the bugs in the OS behavior.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2011 1:17 PM   in reply to Chris Cox

    I might be getting this wrong, but I don't see how things can be related to the OS this easily. The same OS with CS3 and CS4 was working great. Now all of the sudden, in CS5 it's OS related? It still feels like a clear bug that remains unfixed for a long time?

     

    Cheers, Ben

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2011 1:32 PM   in reply to Ben Smeets

    "use system spacing" uses the OS font spacing - it gets the information from the OS.

    When the OS changes the results of that API call, you get different text layout.

     

    Apple changed the behavior of the API if it is called from Carbon versus Cocoa code, in addition to changing the results a bit with every OS release.

    Yes, we consider that a bug, but Apple does not.

    But as long as you're using the system font code, you are at the mercy of the system changes.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2011 1:42 PM   in reply to Chris Cox

    Thanks for taking the effort of trying to explain it to me Chris, appreciate it. I  get what you are saying about the OSX changes. But I'm still having a hard time figuring out what this should mean for the CS4/5 font problems.

     

    I have CS4 and CS5 installed side by side. If I open a file in CS4, everything is fine. If I open it in CS5 it is messed up. I didn't change any options regarding text in any of the CS versions (wouldn't even know how).

     

    So how can this mean that changes in OS's can have impact? It's the same OS?

     

    And on a completely different note, not related to the above. But although it's not meant to finger point to Adobe or Apple, try my thought on this. If my (costly) software is not working on a supported platform of the creator of that software, shouldn't i be able to expect a tiny bugfix-update through it's auto-update feature? Despite the fact that the cause of this bug is not related (directly) to that software itself?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2011 2:18 PM   in reply to Ben Smeets

    CS4 uses Carbon APIs.  Those work like you expect.

    CS5 uses Cocoa APIs, and Apple changed the behavior of the APIs for Cocoa.

     

    Apple changed the behavior in a way that affects CS5 differently from CS4.

    And system spacing relies on the OS behavior, which changed.

     

    Again, there is a workaround if you set the width to 99% or 101%, then you get something closer to the expected behavior.

     

     

    If my (costly) software is not working on a supported platform of the creator of that software, shouldn't i be able to expect a tiny bugfix-update through it's auto-update feature?

    If it were a bug in Photoshop, sure.

    But this is an issue in the OS.

    Again, you asked for OS spacing, and you're suffering problems because the OS changed it's behavior.

    And code changes to Photoshop aren't going to fix the OS behavior.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points