Skip navigation
skybluerock
Currently Being Moderated

Unable to change flash player settings on firefox (Window XP SP3)

May 23, 2010 5:55 AM

I got the lastest flash player (ver 10.0.45.2) on my firefox.

i use modzilla firefox v3.5.9, windows xp serv pack 3.

im having problems with my flash player settings.. the flash player doesnt save any of my settings(those in Settings Manager and those in  Adobe Flash Player Settings[the one with Display Settings, Local Storage Settings, Microphone Settings, Camera Settings, Privacy Settings] )

 

im also having problems with the  Settings Manager. all setting cant seem to load (one patch of empty space)

 

 

I have no problem watching youtube and flash that don't seem to use local storage,

but i have problems playing flash that require to use local storage

 
Replies
  • Currently Being Moderated
    May 23, 2010 8:26 AM   in reply to skybluerock

    Hi, Do you have adblock active? If so you would need to Disable it, then try your Settings and then you can Enable it.

     

     

    This is just something to try first. If that doesn't solve it, post back and we'll take a look at your Flash files to make sure

    they are correct.

     

    Another thing you can check is to make sure the SWF vs 10.0.45.2 in the plug-ins is there and Enabled.

     

     

    Thanks,

     

    eidnolb

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2010 9:17 AM   in reply to skybluerock

    Hi, thanks. I think the best thing to do is check your Flash folder and see what Flash files are installed. Perhaps an old file

    didn't get Uninstalled or one didn't get Installed. Do you know how to go to C:\Windows\System32\Macromed\Flash?

     

    If not I can give you the directions. If you do, post back all files installed. The ones for Firefox, NPSWF you will have to right click on and then click on Properties in order to obtain the version numbers, which I need. The Flash files for IE will show the version numbers.

     

    IE and FF (or other browsers) both have a Control that works with the Flash files. IE, an ActiveX Control and FF, a SWF.

     

    Shockwave Player which is different than Flash Player also has an ActiveX Control, the difference being for FP, it says Shockwave Flash "Object".

     

     

    Thanks,

     

    eidnolb

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2010 10:45 AM   in reply to skybluerock

    Hi, thanks for the screenshots. Your IE & FF Flash files are correct. However, the FlashPlayer Trust, I don't often see. From what I can tell this was something similar to the current Settings Manager, but for FP(Flash Player) 8 & 9 from Macromedia. I don't know if it is conflicting with the current Settings Manager or not. Cannot get a clarification on that.

     

    All I can tell you is that most systems that I see have certain Flash files for FF and other browsers and the FlashPlayer Trust is rarely among them. Usually there are 4 Flash files for IE, 4 for FF plus the Flash Player.xpt.

     

    In the IE add ons, did you find the Shockwave Flash Object...ActiveX Control...Flash10e.ocx (vs 10.0.45.2) and Enabled?

    This will be listed as I've typed it except it may or may not list the version #, but everything else will be listed.

     

    Now on the AVG, do you have the AVG free edition? It and the paid versions also have the LinkScanner, which causes problems. You said you Disabled AVG, did you just right click on the icon in the system tray and disable/turn off/exit?

    Or did you Untick the Resident Shield active?

     

    The LinkScanner component consists of 2 features and each needs Disabled.

     

    With Spybot, do you use the Tea Timer?

     

    Since FP is a browser plug-in, anything added to the browser has to be considered.

     

    Thanks,

     

    eidnolb

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2010 11:24 AM   in reply to skybluerock

    Hi, thanks for the info. The AVG free edition from what I see, has only the Resident Shield and the LinkScanner.

     

    Let me get the info on the Tea Timer for you. Ok, so Shockwave Flash Object is there, that is important since FP would not work without that for IE.

     

    I wouldn't venture into the Registry, no more than I would reformat the HD:-) for a Flash Player issue.

     

    On the FlashPlayer Trust, I suggested that to another person that had it and no problems without it. I can't remember if that was the main issue or something else. I would remove it.

     

     

    Tea Timer info -- Open Spybot>Click Mode-Advanced Mode, Click Yes, Click Tools, on the bottom left pane, click Resident.

    Then UNcheck teatimer, protection over all systems active. Close Spybot and Restart your computer. Teatimer is no longer active.

     

     

    Let me know if this works on TeaTimer.

     

    thanks,

     

    eidnolb

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2010 11:52 AM   in reply to skybluerock

    Hi, ok. Did you remember to restart your computer? It is always a good habit to do that anytime when you Install or Uninstall anything.

     

    IE and FF are both working properly on the websites, correct?

     

    This is the Global Settings link:

     

    http://www.macromedia.com/support/documentation/en/flashplayer/help/se ttings_manager02.html

     

    I use this link and have set mine sometime ago, so I never need to use a website. You may want to try that. When the page opens, the Global Privacy Settings opens, I set that. Then I go to the left side and click on the next one, which is

    the Global Storage Settings Panel. Then just set the bar where you want it, click on the 2 options. Now when I am finished

    with the Settings Manager Panels, I restart my computer. I have all of the panels set to my choice and check them whenever I think about it and they are still the same.

     

     

    See if doing it that way makes a difference. 

     

    eidnolb

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2010 12:35 PM   in reply to skybluerock

    I have both options with a check mark in them and have the bar set at 10KB. Below the Setting Panel, the article explains what each option does. Keep in mind this panel is for websites that you haven't yet visited. Read the second paragraph that pertains to sites that you have ALREADY visted. Now if you chose the Never ask again, then read the third paragraph and the fourth, which gives you another option.

     

    I just go down the various panels listed on the left and set each one how I want. Mine stay the same and have never had a problem.

     

    It does take some time to understand what each setting does.

     

     

    I understood that you wanted some websites to be able to use that setting.

     

     

    Hope this helps.

     

    Thanks,

     

    eidnolb

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2010 1:34 PM   in reply to skybluerock

    Hi, there is another possible solution and I'll need to find the thread to give you. Have you tried the Settings using IE?

     

    You do have the correct Flash files for IE.

     

     

    Will find that info for you after dinner.

     

     

    Thanks,

     

    eidnolb

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2010 3:15 PM   in reply to skybluerock

    Hi, I don't know if you tried the settings with IE or not. This is the thread to look at, post#2.

     

     

    Thanks,

     

    eidnolb

     

    There has been a few solutions, but can't find anywhere what the cause is.

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2010 6:30 PM   in reply to skybluerock

    Problems with Flash Player Settings are often cured by deleting the Flash Player folders in %APPDATA%.  Try the following

    • close all browser windows
    • open Windows Explorer, and make sure the Address Bar is visible (View | Toolbars)
    • type %appdata% [Enter] in the address bar
    • double-click on the Adobe folder
    • delete the Flash Player folder
    • go back up to the %appdata% folder
    • double-click on the Macromedia folder
    • delete the Flash Player folder
    • close Windows Explorer

     

    Now try the Flash Player Settings again.

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2010 6:42 PM   in reply to Pat Willener

    Thanks Pat! I see I had forgotten to post the thread with your instructions, glad you did

     

     

     

    eidnolb

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2010 9:49 PM   in reply to skybluerock

    Hi skybluerock, are you saying that you have no Flash files in the Flash folder? I know you had the correct IE & FF Flash files. So using IE, you still couldn't save the settings. I'll check on something for you and post it tomorrow.

     

     

    Let me know about your Flash files. Also did you disable the Tea Timer? (see post 9 I think it was)

     

     

    Thanks,

     

    eidnolb

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2010 10:24 PM   in reply to skybluerock

    Hi SBR,  Ok, hasta manana.............

     

    Thanks,

     

     

    eidnolb

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2010 11:40 PM   in reply to skybluerock

    skybluerock wrote:

     

    i have disables all the skybot and avg side program.

    the folders i didnt have is the one that ʇɐb ɹəuəllıʍ suggest to delete

     

    %appdata%>Adobe>Flash Player and %appdata%>Macromedia>Flash Player

     

    That is weird!  Could this be the reason that you are unable to change FP Settings?

     

    Can you create these two folders (from Windows Explorer, using File | New):

    1. %appdata%\Adobe → create Flash Player folder
    2. %appdata%\Macromedia → create Flash Player folder
     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2010 8:08 AM   in reply to skybluerock

    Hi SBR, sorry you are having these additional problems. I thought that "fix" about deleting those folders worked or I would not have recommended that thread. Perhaps Pat has a fix for the fix:-) He will have to tell you, since I don't know

    how to fix that.

     

     

    Hope you will be able to have your issues resolved.

     

     

     

    Thanks,

     

    eidnolb

     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2010 7:01 PM   in reply to skybluerock

    It is a mystery to me why these folders didn't exist in the first place.  However, I just remember another problem with the Flash Player settings when the username starts with a '.' (dot) - is that the case?

     

    Also, are you running as an Administrator user?  (Don't know if this question has already been answered in this long topic.)

     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2010 7:37 PM   in reply to skybluerock

    Do you have any other Adobe software installed on your computer?

     

    Can you again open Windows Explorer and go to %appdata%\Adobe - do you have any other folders in there (apart from the Flash Player folder you created)?

     

    What I am trying to find out is if you have a permission problem somewhere in your Application Data folder(s).

     

    One more question: is your C: drive NTFS or FAT32?  (You can right-click on the C: drive, then select Properties; it should tell you under 'File System'.)

     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2010 10:50 PM   in reply to skybluerock

    Very curious!  The presence of all these subfolders shows that there is no permission problem.  But is your Flash Player folder (that you created) also there?

     

    Anyway, then only thing I can think of now is a complete reinstall of Flash Player.  Or have you already done that?

    • Open http://kb2.adobe.com/cps/191/tn_19166.html
    • download the uninstaller mentioned in section 1 (save to disk);
    • download the executable installer(s) from section 5 (save to disk);
    • close all browser windows, then run the downloaded uninstaller, followed by the installers.
     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2010 11:09 PM   in reply to skybluerock

    If it is a registry problem, then I would try to uninstall one more time, with the /clean option.  Open a command prompt, then navigate to the location where you have downloaded the FP uninstaller.  Type

    uninstall_flash_player.exe /clean
    

     

    then reinstall FP again.  If that does not help, then I have no more ideas.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points