Skip navigation

Background PDF export Help

May 28, 2010 9:26 AM

  Latest reply: John Hawkinson, Feb 22, 2012 2:29 PM
Replies 1 2 3 4 5 Previous Next
  • Currently Being Moderated
    May 20, 2011 4:56 AM   in reply to [Jongware]

    Like an InDesign Ninja?

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 5:18 AM   in reply to Eugene Tyson

    Nah, more like the original Tron.

     

    http://www.collider.com/uploads/imageGallery/Tron/tron_movie_image__3_.jpg

     

    (If you can recall who he was fighting for ...)

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 5:35 AM   in reply to Marijan Tompa

     

    I created a script which will integrate in InDesign menu,

    right under Export option and allow you to enable/disable background export.

     

    Surprised, but I have to report that after InDy restart, this script enabled, export succeeded. I will test this some more, and in other machines, to see if the cure persists.

     

    Is the folder to place this script same /Scripts/startup scripts/ in win platform (I assume this should work in both platforms)?

     

    And to former query: no Suitcase, I use FEX. I am quite convinced problem is connected to handling of placed graphics (vector AND pixel) as reimporting often corrects the bug (for a while).

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 5:53 AM   in reply to Fixx

    Great! Glad it's working fine.

    Once script is installed, you don't have to restart InDesign

    when enabling/disabling background export.

     

    --

    Marijan (tomaxxi)

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 6:11 AM   in reply to Marijan Tompa

    I can't seem to get it to work here on Win 7 64 bit. The menu item is there but it doesn't disable the background export.

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 6:23 AM   in reply to Bob Levine

    Hey Bob,

     

    Hmm... Strange... I'm also using Win 7 64-bit

    and it's working fine with CS5 and CS5.5...

    Maybe it's because Windows UAC...

     

    --

    Marijan

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 6:23 AM   in reply to Bob Levine

    A bit more testing. I created the text file manually and the menu item changed to enable background export, but again, clicking it does nothing. Strange.

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 6:28 AM   in reply to Bob Levine

    Ok, when it says "Enable Background Export" then do regular export!

    Clicking menu item just create/delete text file from InDesign app folder

    --

    Marijan

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 6:32 AM   in reply to Marijan Tompa

    Just tried it on my Win 7 32 bit machine and it doesn't work there either. I wonder if something is conflicting with it.

     

    When will you be getting into DC? I'll be there Sunday afternoon.

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 6:34 AM   in reply to Marijan Tompa

    That's the thing...it doesn't toggle the command on or off and it doesn't write the text file to the folder.

     

    I tried putting the text file there myself and the menu item changes to enable background export. But then clicking it doesn't kill that text file and it doesn't change the menu command.

     

    This on two different machines.

     

    I think I'll check my test machine with CS5.5 and see if that works.

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 6:40 AM   in reply to Bob Levine

    BobLevine wrote:

     

    I wonder if something is conflicting with it.

     

    Suitcase?

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 6:47 AM   in reply to Peter Spier

    I thought about that but I just tried it with CS5.5 on my other machine and it doesn't work there either. Hmmmm. Looks I'm going to have track down tomaxxi on Sunday. :-)

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 6:51 AM   in reply to Bob Levine

    Definitely Win 7 UAC...

    It's working fine here and also on Win XP.

     

    I'm arriving tomorrow evening to the DC if everything goes well

     

    --

    Marijan

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 7:19 AM   in reply to Marijan Tompa

    That's what it is, but I don't recommend turning UAC off in Win 7.

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 7:20 AM   in reply to Bob Levine

    Funny it's the first thing I turn off - it's so obtrusive.

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2011 7:45 AM   in reply to Eugene Tyson

    It's intrusive in Vista for sure. I don't find it so in Win 7 and I don't recommend turning it off.

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2011 10:11 AM   in reply to webheads1835

    OK, the PDF export problem persists, foreground exporting enabled. No cure so far. And this time last page, which had no images, linked or otherwise, refused to export. Breaking links to styles in text frames and saving allowed to export. Go figure.

     
    |
    Mark as:
  • John Hawkinson
    5,572 posts
    Jun 25, 2009
    Currently Being Moderated
    May 23, 2011 10:58 AM   in reply to Fixx

    Fixx: please start a new thread, your problem is different. Also, I think I asked you some questions that went unanswered, like whether you are using 7.0.4? Does removing your font manager change anything [unlikely I know], etc. (But please answer in a new thread).

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2011 9:49 AM   in reply to webheads1835

    Can I ask how you fixed the font issue?

     
    |
    Mark as:
  • John Hawkinson
    5,572 posts
    Jun 25, 2009
    Currently Being Moderated
    Jun 20, 2011 7:54 PM   in reply to Richt93

    Can I ask how you fixed the font issue?

    I'm not webheads1835, but the general answer to a corrupt font is to remove the corrupt font and reinstall it from a known-good source.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 1, 2011 1:03 PM   in reply to John Hawkinson

    Thank you, Matthew!!!!

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 22, 2012 8:58 AM   in reply to webheads1835

    This problem has something to do with an error regarding the linked files within it.

     

    This happened to me and the only way I fixed it was first by replacing certain enlarged PSD files. That worked for one InDesign project. I assumed that this one PSD was corrupt, but even after updating the PSD to the new version (in a whole separate InDesign project) still didn't work; when making a PDF it would freeze.

     

    THEN, WHILE the PDF was being created, I nudged this PSD file to be slightly smaller and the PDF suddenly went through. From then on, after making this PSD a hair smaller in the InDesign project, I could make PDF's.

     

    Horrible Experience. Glad it finally worked.

     

    I also created all new versions of evey linked file and linked the project to the new version at one earlier step in the process. Didn't help until I tried the above.

     

    ADOBE: please look into this!!

     
    |
    Mark as:
  • John Hawkinson
    5,572 posts
    Jun 25, 2009
    Currently Being Moderated
    Feb 22, 2012 2:29 PM   in reply to LuckeydogsDay

    Luckey:

    ADOBE: please look into this!!

    At the risk of being repetitive, I just want to remind you that posting in this thread is not an effective way to communicate with Adobe.

    The best way is to open a support case with them, at http://adobe.com/go/supportportal.

    An alternative, if you can come up with a clear reproducible test case, is fill out http://adobe.com/go/wish and file a bug report, but that interface does not permit attachments.

     
    |
    Mark as:
1 2 3 4 5 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points