Skip navigation
Currently Being Moderated

The always wonderful "Cannot complete operation because of program error"

Jun 1, 2010 9:52 AM

So, I've followed all the advice here and nothing has changed:

http://kb2.adobe.com/cps/331/331627.html

 

It's to the point that I open a PSD and I get the error as soon as I click on any tool. Effectively, I can't do anything in Photoshop except view files.

 

Any other tips?  CS4 / 10.6.3

 
Replies
  • Currently Being Moderated
    Jun 1, 2010 9:58 AM   in reply to Navarro Parker

    Have you disabled plugins? (all of them, not just third party)

     

    And what are the last 8 or so lines in the PSErrorLog.txt file in your Photoshop preferences folder?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2010 4:06 PM   in reply to Navarro Parker

    ResourceImp problem is a red herring from the scripting support plugin.

     

    The error from EXIFSupport means that some metadata couldn't be read from a file - because the EXIF tag count was bad, which means some part of the file was corrupt.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2010 4:07 PM   in reply to Chris Cox

    All program errors should be logged to that file, but it doesn't sound like the errors in that file can explain what you are seeing.

     

    Errors that occur that easily and often are usually due to corrupt preferences, and sometimes to corrupt fonts (you can try disabling font previews in prefs and see if it goes away).  Once in a while we see problems like that due to bad plugins (but you already removed them, so that isn't it).

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 5, 2010 3:46 PM   in reply to Navarro Parker

    Haha, I've seen that pop up quite a few times in the past, it always succeeds in making me simeltaneously facepalm and laugh.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 9, 2010 3:12 PM   in reply to Chris Cox

    Just wanted to let you know what worked for me.

     

    I was just experiencing this same error after updating my CS5 to version 12.0.2 this morning. I tried everything to get Photoshop to work again, from reinstalling the app from scratch, to disabling all but my core fonts, to running through every Onyx routine. I checked error logs, deleted caches manually, and really started getting my hands dirty...

     

    And that’s how I zeroed in on the one single file causing this error. (FTR, I understand that this is a “generic” error message, so it may be caused by a number of things. Still, answers are frustratingly sparse, and my solution *did* work.)

     

    There is a folder located here:

     

    /Users/[username]/Library/Adobe Photoshop CS5 Settings

     

    with about 21 files that PS needs to get situated on startup, and which it refers to whilst running. I copied all of them to a new folder, then started Photoshop over and over again, moving one file over at a time, until I could get the error to happen again. The guilty file, in my case, is “Adobe Photoshop CS5 Prefs.psp”

     

    Remove this file, and everything else works as before. As far as I can see, this only resets a few of the preferences in the Command-K panel, which are fairly trivial to customize again.

     

    Anyway, back to work.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points