Skip navigation
Currently Being Moderated

Change language in After Effects CS5

Jun 10, 2010 8:44 AM

Hi guys,

 

I have AE CS5 and installed the whole thing in German (because I am German^^) but now I realize that for tutorials and so on it would be much easier in Englisch. So is there a way to change the language without reinstalling? I had a look for some answers, but the "Languages"-folder isn't located at
"C:\Program Files\Adobe\After Effects CS5"

 

I use the 64-bit-Version

 

I hope someone can help me,

Greets, GFXer

 
Replies
  • Currently Being Moderated
    Jun 10, 2010 9:52 AM   in reply to _GFXer_

    Create a file called ae_force_english.txt in your user home directory's Documents sub-folder.

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 10, 2010 11:42 AM   in reply to _GFXer_

    As I wrote, it needs to be in the Documents (Dokumente) sub-folder, not the root of the user home dir.

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 10, 2010 5:37 PM   in reply to _GFXer_

    Will this work for two-byte versions?  I've always been interested in  seeing Adobe products in Japanese.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 10, 2010 5:46 PM   in reply to Mylenium

    is there a similar solution on Mac?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 10, 2010 7:01 PM   in reply to Pigumon

    At least in Win 7 Ultimate you can run AE CS5 in Japanese by changing the OS region/language settings to Japanese.

     

    It would be great if someone knows an easier way like the ae_force_english trick though

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 10, 2010 11:46 PM   in reply to jspence2

    This is as easy as it gets. Sorry to disappoint, but you rather be glad it is actually there and  it's not like in other programs where you cannot switch languages at all. For all intents and purposes, this is not meant to provide an all out solution for flexible language switching, it is merely a fallback measure when the user needs to use prefab projects from the web or follow tutorials as wel las providing a compatibility fix for some plug-ins and scripts thatr do weird things in foreign language environments. Your program is still tied to the serial number you bought it with and that ultimately dictates any language settings. This also means that you cannot enforce other languages other than English. Would be pointless, anyways - you would have to have the proper Asian installer in the first place to even get the specific language files on your system. Same for otehr languages - a US/ North America installer will never give you Italian or German, just US English, Canadian French and possibly Spanish.

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 11, 2010 12:31 AM   in reply to Mylenium

    On Mac OS, you just have to show the app info (cmd-i) and switch the language.

     

    On a general note, Adobe restricted the language available in all it's app since CS3 (and since CS4 for AE), you only have 2 options: run AE in the language you bought it (your localised version) and in internationnal english.

     

    As a side note, and Todd will correct me if I'm wrong, the ability to switch to english is here thanks to the expressions not being always compatible from a language to another (like the slider controls for exemple). If it was not the case, I guess we'll all be stuck with our localised versions (and that would be extremely bad by the way).

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 11, 2010 4:25 AM   in reply to Sébastien Périer

    well, yes, cmd + I is quite handy on Mac Os 10.5 and previous versions, but it's not an option for Snow Leopard ( OS X 10.6 ). Is there any solution that doesn't require to show package content and manually edit inside aftereffects.app ?  thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 11, 2010 4:27 AM   in reply to GAntico
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 11, 2010 1:55 PM   in reply to GAntico

    In Snow Leopard 10.6 just drag English to the top of the list in the Language & Text tab in the System Preferences. Once you relaunch AE (or any other localized program) it will launch in English.  Once it is launched you can switch it back to your language or everything else will start to switch to english :-)

     

    -Lloyd

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 12, 2010 5:05 PM   in reply to lloydalvarez

    hi lloydalvarez,

    what you are describing is a standard procedure for OS X 10.6, but it doesn't work for After Effects CS5. I even tried to remove completely Italian from Language & Text panel (and logged out...) but AE CS5 seems to run always in the language chosen during the installation.

     

    I was able to force the app launching in English only in this way:

    1) right click on "Adobe After Effects CS5.app"

    2) click on "Show package contents"

    3) navigate to "Contents/Resources/AMTLanguages"

    4) delete or move the file "it_IT.txt"

    5) launch the application and work with English interface

     

    For switching back to Italian I just move back the deleted file in its original place. Even if this workaround is working, I was wondering if there was a better way to manage the switch between my local language and English.

     

    thanks for any advice.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 13, 2010 6:19 AM   in reply to GAntico

    Not sure why it is not working for you.  I switch back and forth all the time while I am authoring scripts to test the localization.  It is one of the nicest new features in 10.6 in my opinion.  You don't even need to log out, just drag the language to the top of the list and restart AE.

     

    -Lloyd

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2010 2:17 AM   in reply to GAntico

    I just tried it out and voilá: the solution for Snow Leopard is the one described by Mylenium.

     

    Simply create an empty "ae_force_english.txt" in your user's "~/Documents" folder, ie "/Users/[username]/Documents"

     

    "ps_force_english.txt" didn't work though I wonder, if there's a way to start Photoshop (and all the other applications) in English, too.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2010 6:05 AM   in reply to lloydalvarez

    @Llyod

    I've tried several other times with different installations on different Macs, testing before and after activation, but I never managed to get the language switch working in your way. I've used  OS X 10.6.3 and 10.6.4, After Effects downloadable trial and final version, with English, English US and English UK in languages, but it didn't work in any case. I always get it in Italian, unless I go for other tricks.  Did you install it in English and then switched to local languages or the opposite? Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2010 6:27 AM   in reply to jackgoldfinch

    @jackgoldfinch

    thank you very much for sharing it, I finally got it working with the txt file. Good to know that the solution for Win is usable on OS X as well.

     

    ps

    In Photoshop you can go to "preferences" > "interface" > "UI text options" > "UI language" and choose from the drop-down menu language items, but I'm afraid that it could work only for multivolume/multilanguage lincenses...

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 6, 2012 2:20 PM   in reply to _GFXer_

    Oh this was very helpful, its working so far... I dont know who would use after effects in anything other than english, since all the good tutorials are in english and its a mess to try to follow them in another language. Thanks.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points