Skip navigation

Profiler stopped once intstalling flash player debug 10.1

Jun 11, 2010 2:41 AM

  Latest reply: Anand Gaurav, Mar 10, 2011 2:42 AM
Replies 1 2 3 2 Previous Next
  • Currently Being Moderated
    Nov 4, 2010 10:19 AM   in reply to Adobe Joe Kenobi

    OK, so I just found out some bad news. I thought that it was working in Burrito, but it was because it was launching in Chrome. It does work in Chrome just not in Firefox.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2010 10:38 AM   in reply to Adobe Joe Kenobi

    Work-around Found!!!

     

    If you go to your profile perspective and select Profile -> Profile External Application then select the option to Launch the app manually outside Flash Builder then navigate to your app in Firefox that works. Kind of crappy to have to do it that way, but it works.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2010 12:41 PM   in reply to Adobe Joe Kenobi

    Kenobi. What worked for me was mentioned here by malab36. FlashBuilder is looking in an incorrect location on your machine if you have a network home drive and where that mm.cfg file is it does not have the required PreloadSwf line for the profiler to work. Below is the line I added matching my workspace and now profiling works for me with the latest version of the flash player.

     

    PreloadSwf=D:/workspace/metadata/.plugins/com.adobe.flash.profiler/Pro filerAgent.swf?host=localhost&port=9999

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2010 12:59 PM   in reply to Christopher VA

    Hey thanks Christopher! That worked. I appreciate you taking time to make that post more obvious to me!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2010 9:02 AM   in reply to Adobe Joe Kenobi

    Ok, so I don't mean to keep going on this one, but I found one other thing that might help people. With Firefox I've noticed that I get inconsistent results if I have it open already and it attempts to profile my swf in a new tab of Firefox. I read somewhere that this could cause issues and from what I've seen it does. For best results with Firefox make sure it's closed before you profile. The profiler will launch Firefox and begin to profile. Most of y'all probably know this, but if anyone else is still having issues this might be the reason why.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 2, 2010 4:50 AM   in reply to Lemtz

    I'm on a mac and have the same problem - no profiling with flash debug player 10.1

     

    When profiling, mm.cfg gets updated with "PreloadSwf=/Users/tcaspersen/Documents/Adobe Flash Builder 4/.metadata/.plugins/com.adobe.flash.profiler/ProfilerAgent.swf?host= localhost&port=9999"

     

    This points to a non-exisiting folder, actually there is no ProfilerAgent in the Documents folder at all - it resides in Applications/Adobe Flash Builder 4/and so on.

     

    Is there a way to change this path?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2010 9:57 PM   in reply to Lemtz

    This issue has been fixed in Flash builder Burrito. If you are part of CAB forum, please download the latest Flash Builder Burrito build and provide the feedback.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2010 11:34 PM   in reply to Kishan M V

    What? Does this mean that one of the major selling points for Flash Builder Professional just remains broken and the answer from Adobe is "wait for the next version"? I can't rely on beta software for doing my day job and as far as I'm aware there is no release date for Burrito.

     

    I hope I've misunderstood something here, because as it stands, it looks very unsatisfactory.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 7, 2010 1:05 AM   in reply to casper_no

    Hi,

     

    Work around for this issue are

     

    If you have configured active directory domain and  home path is set on the user network drive, manually creating the mm.cfg file http://livedocs.adobe.com/flex/3/html/help.html?content=logging_04.htm l

     

    Another work around is, you can roll back to 10.0 player.

     

    Please let us know if this solves your issue.

     

    Thanks,

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 7, 2010 1:26 AM   in reply to Kishan M V

    Hi,

     

    Thanks for helping.

     

    The page: http://livedocs.adobe.com/flex/3/html/help.html?content=logging_04.htm doesn't specifically address my issue  - I'm on a mac so the the domain and home path issues don't apply.

     

    But I tried to manually create a mm.cfg and inserting  "PreloadSwf=[correct path here]/ProfilerAgent.swf?host= localhost&port=9999". I put the mm.cfg first in Library/Application support/Macromedia and when that didn't make a difference I moved it to /user/. Where it didn't make a difference either, but got overwritten when I launched a profiling session from FB.

     

    So I'm back to square one. It seems like mm.cfg get the wrong path to profilerAgent.swf and manually editing mm.cfg doesn't help.

     

    Reverting to 10.0 would help for this project, but I need 10.1 for other so that would make for an awfully cumbersome workflow.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 15, 2010 2:31 AM   in reply to casper_no

    Does this mean that when you downgrade to 10.0 all works fine but when you are back to 10.1 Profiler doesn't work ?

    I am asking this because at first glance it doesn't seem to me like the 10.1 issue (the issue for which this thread started). Since Profiler is able to find the mm.cfg properly and is updating it implies its not the same 10.1 issue. I guess there might be some problem with the installation. Ideally the file ProfilerAgent.swf should be present in the /User/... location.

     

    What's the correct path of ProfilerAgent.swf as of now ?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 7, 2011 9:05 PM   in reply to Lemtz

    I'm having this issue as well. I tried all the suggestions here but none of them seem to work.

    My setup:

    Flash Builder: 4.5

    Flash Player: Mac 10,0,45,2

    Debug Player: Yes

    OS: Mac OS 10.6.6

     

    I downgraded from Flash Player 10.1 so now  i have 10.0 but that didn't fix the problem.... any help?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 7, 2011 10:23 PM   in reply to sanggpark

    Which browser are you using ?  If its chrome, then go to "chrome://plugins"  in the chrome address bar; expand the flash player plugin by clicking on the "details" link and then disable the release flash player.

     

    +Anand

    "angaurav at adobe dot com"

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 8, 2011 11:17 AM   in reply to Anand Gaurav

    no browser, i'm building an air app

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 10, 2011 2:42 AM   in reply to sanggpark

    Try to locate the mm.cfg file and check if its updated with something like:  "PreloadSwf=/Users/..../../Adobe Flash Builder 4.5/.metadata/.plugins/com.adobe.flash.profiler/ProfilerAgent.swf?hos t= localhost&port=9999"  ?

     

    Note: this is appear only momentarily.

     

    Send me whats it is updated with (along with other contents of mm.cfg). Also do send me the location of the FlashBuilder install on your machine.

     

    +Anand

     
    |
    Mark as:
1 2 3 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points