Skip navigation
etrevino75
Currently Being Moderated

Issues with Flash CS5 in a networked Mac environment

Jun 14, 2010 7:53 PM

Hello,

 

There seem to be some bugs with certain features in Flash 5; perhaps somebody might want try to reproduce it or might have experienced the same issues.

 

We have a college lab with several iMacs; the students log into any of the computers (with OSX 10.6.3 or 10.5.8) and they are authenticated through a Mac OS X server (10.6.3) which also provides file services. So the students' files are on the server, not in the local hard disks. All CS5 updates have been applied.

 

The first problem our users have detected is that when students are logged into their accounts and open the Code Snippets panel, the panel is completely blank, that is, where the "Actions", "Timeline Navigation" and other folders should be:

 

no code snippets.jpg

 

When using a local account these folders appear correctly in the panel area. This happens both on accounts with administrative and non-administrative privileges so the only problem appears to be when using the networked accounts.

 

The students' accounts do not have privileges to write on the local hard disks except for the /Users/Shared and /tmp directories.

 

I thought it might be that Flash is trying to write somewhere in the hard disk where the students' accounts can't write, but testing for this using local non-administrative accounts the issue doesn't happen and these local accounts are not supposed to write files elsewhere either other than their own home directories.

 

The second issue happens with the welcome screen. When opening Flash with a local account we get this:

 

welcome screen.jpg

 

But when opening Flash with one of the student networked accounts, we get this:

 

no welcome screen.jpg

 

And the third issue our users have found is that    Control > Test Movie > Test     doesn't work correctly either; the users get an error message such as this:

Error opening URL 'file:////Volumes/alumnos/996657/Desktop/dori.swf'

 

(in the example above, "alumnos" is the name of the networked volume and "996657" is the username which is also the name of the home folder).

 

So far these are some issues that seem to happen only in a networked environment that uses server authentication and file services such as this lab. Flash CS4 works correctly in this environment.

 

Regards

 
Replies
  • Currently Being Moderated
    Sep 3, 2010 1:35 PM   in reply to etrevino75

    You need to redirect this directory : ~/Library/Application Support/Adobe/Flash CS5 to somewhere local.

     

    I used Workgroup Manager, Folder redirection.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 16, 2010 7:32 AM   in reply to Damon Vogel

    I have further determined that this will get Flash to run, but you will have problems trying to preview your movies.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 27, 2010 10:29 AM   in reply to etrevino75

    Any progress with this issue?

     

    We are currently having difficulties publishing any FLAs that are housed on a network.

     

    TIA

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 27, 2010 11:01 AM   in reply to ap_team

    Actually, Yes.

     

    I determined that you have to have a shortcut to your home directory shared drive in the /Volumes/ folder of your workstation.

     

    To get to /Volumes/ use Go, then Go To Folder.

     

     

    You should see other shortcuts to your networked drives in there, but not for your home directory.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 27, 2010 11:38 AM   in reply to Damon Vogel

    Hey Damon Vogel,

     

    Thanks for the quick reply.

     

    We actually do have an Alias to our network in the volumes folder.

     

    But we are still having the same problem, is there anything else you can suggest to try to debug this error.

     

    Sample of the error : Error opening URL 'file:////Volumes/Websites/OurServer/test.swf'

     

    Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 27, 2010 11:55 AM   in reply to ap_team

    I wish that I could be more help, but that's what cleared up that issue for me. To use your Error as the example, as soon as I included an alias to the "Websites" directory to my Volumes folder, it started working for me.

     

    Can you navigate via the Volumes folder all the way to your test.swf?

     

    Have you tried the test.swf with a local account to confirm that it is an issue with Flash and not your file?

     

    Besides that kind of elimination troubleshooting, I don't have that much more for you.

     

    Hope it helps...

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 27, 2010 12:23 PM   in reply to Damon Vogel

    I actually just figured out what the problem was,

     

    It had to do with permission accessing the folder, the folder was a super mac user (Wheel) and as a staff account I was not granted access.

     

    So if anyone else is having this same problem just make sure you create a new Alias that is accesible within your account.

     

    Thanks for the help DV.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 20, 2010 11:45 AM   in reply to etrevino75

    I'm having this exact same problem except I'm not running Flash on a network. Code snippets opens blank, and Flash won't open the .swf file. I get 'error opening url...'

     

    Also I see the same white square instead of the normal welcome screen on launch.

     

    My Mac is running File Vault as it is required by my company. I've tried making sure all the permissions to the library allow access, but nothing I have tried has fixed the problem. I had our help desk reinstall Flash twice to try to get it to work, but I have had no success.

     

    Any help is appreciated.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 20, 2010 1:01 PM   in reply to bryanco

    In researching my issue, I came up with a lot on how FileVault causes this problem, but I didn't look into it because it wasn't pertinent to me. Sorry...

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 24, 2010 12:38 PM   in reply to etrevino75

    Just adding my 2 cents as I encountered this exact issue and solved via this helpful post.

     

    For me the solution was to use Workgroup Manager and adjust the managed preference for the machine with CS5's Login items.

     

    I had previously been adding several useful AFP shares at login in this manner, but the option to "Add network home share point"  was unchecked.  Checking this item and rebooting the dev machine resolved the issues noted in the post.

     

    Best and HTH.

     

    -Koof

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)