Skip navigation
chillycub
Currently Being Moderated

Photoshop CS4 "Could not save as...because file is already in use or was left open"

Jun 19, 2010 4:53 PM

I have been using Photoshop for years, and CS4 for about a year now.  I have never had this error message pop up until this week.  It started happening right after I did the Adobe update to 11.0.2.  Everytime I try to save a PSD or JPG file now (which are the only two types of files I work with), I get this message preventing me from being able to save;

 

"Could not save as... because file is already in use or was left open."

 

I have to attempt to Save as about a dozen times before it will finally save the file.  Any suggestions on what could be wrong and how to remedy it?  Is it the update that caused this problem?

 
Replies
  • Currently Being Moderated
    Jun 19, 2010 11:19 PM   in reply to chillycub

    No, the update has nothing to do with this.

     

    Some other application on your system has that file open, so it can't be saved over.

     

    Photoshop is just letting you know that some other application is holding the file open, and that Photoshop cannot save over the file until that other application let's go of the file.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 19, 2010 11:39 PM   in reply to chillycub

    That's not it... I have obviously thought of that.

    No, that is it entirely.

     

    You have the Windows Explorer running, anti-virus (I hope), and lots of other little services -- any of which could have a problem and keep files held open longer than they should.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 9, 2010 9:56 PM   in reply to Chris Cox

    I'm having the same problem this week as well. I've been using

    photoshop for years and I've never had to close windows explorer

    in order to save a file.  This is definitely a new glitch.

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Oct 10, 2010 5:15 AM   in reply to chillycub

    Turn off Caching of Thumbnails in Hidden thumbs.db Files

     

    People sometimes report that they cannot manipulate their folders as they want to because Explorer has a thumbs.db file open.  Windows 7 apparently generates these files for compatibility with older software that may expect such files to exist in folders with, for example, photos in them.

    The good news is that (with Windows 7 Professional and above) you can disable this through the Group Policy editor:

     

    • Click the Start orb

     

    • Enter gpedit.msc in the search box and hit Enter.

     

    • Expand User Configuration - Administrative Templates - Windows Components.

     

    • Click on Windows Explorer.

     

    • Right-click the entry "Turn off the caching of thumbnails in hidden thumbs.db files" and choose Edit.

     

    • Enable the setting.

     

    -Noel

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points