Skip navigation
Currently Being Moderated

CS5 "Not enough scratch memory available" error when there's plenty of it.

Jul 7, 2010 1:11 PM

Illustrator CS5 throws this error:

 

---------------------------
Adobe Save For Web AI Error
---------------------------
Could not complete this operation. There is not enough scratch memory available.
---------------------------
OK  
---------------------------

 

when trying to save for web. The content has a lot of linked images, around 1000x1000 px each, used with clipping masks, drop shadows and glows at 300dpi.

 

I realize that this might be hard to flatten for JPEG and I'd be fine with long processing times (which I get) but out of memory?.. Here's my config:

 

Illustrator CS5

Windows 7 x64 Ultimate

Intel Core i7 920

6GB RAM

Total pagefile size: 24GB.

Primary scratch disk - 155GB free.

Secondary scratch disk - 544GB free.

 

Those are all gigabytes, not megabytes, no mistake. There's NO WAY that there's not enough scratch memory available.

 

And this is how the process looks:

IllCS5process.png

Physical memory usage at this point is 62%, Commit charge - 15%.

 

Currently, I can work around this by making a screenshot of "Original" tab in Save for Web dialogue when it's there - because sometimes it's just a pink-filled window.

 

So, Adobe, any suggestions, please?

 
Replies
  • Currently Being Moderated
    Jul 7, 2010 3:32 PM   in reply to Asmodeus Dhoine

    Sorry from what but you are wrong 24 GB file page size is immense for AI from what you describe I would think AI could not even open the file.

     

    You're shooting for save for the web and exactly why do you need 300ppi images.

     

    I would say Illustrator is working as design and if one considered you have very limited resources to work on such a huge file it would expected.

     

    You simply do not have enough resources you need a very large and powerful RAID 0 for a scratch.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 7, 2010 4:05 PM   in reply to Wade_Zimmerman

    I had the same issue with Photoshop CS3 working on a 300MB file.

    My solution was to work with CS instead - no memory problems.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 7, 2010 8:59 PM   in reply to Asmodeus Dhoine

    Asmodeus,

     

    Illustrator CS5 has some improvements to how Raster Effects are rendered on screen. So even if you use 72ppi DRES, you would see very little/no difference compared to 300ppi DRES - i.e., pixelization issues would be almost non-existent.

     

    Could you try this out & come back with your findings?

     

    Also if you just want to send something to other people for Previews, maybe a PDF with the 'Smallest File Size' Preset be good enough. These can be viewed with the (free) Adobe Reader.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 7, 2010 11:06 PM   in reply to Asmodeus Dhoine

    I think I will sit back on this and wait and see…

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 8, 2010 12:53 AM   in reply to Asmodeus Dhoine
    There's NO WAY that there's not enough scratch memory available.

     

    There is, if it cannot create a temp file, which indeed is tied to the limitations for 32bit apps and in Save for Web cannot exceed 2GB, if I remember correctly. That's what it's telling you and this has absolutely nothing to do with your system swap file. A possible solution may be to manually flatten the file before exporting, but as pointed out by others, your workflow is not particulalrly sensible and effective to begin with and certainly doesn't fall withing what Save for Web was designed for in the first place. Saving PDFs may be much less troublesome. Also simply consider using Bridge to create derivatives of the actual AI files for review.

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 6, 2010 4:37 PM   in reply to Mylenium

    OK, I just attempted to export an illustrator file to a layered PDF to follow the instructions Adobe staff have recommended as a workflow to create a 3D file from an illustrator file. The original file is 266K, and I'm working on a system with 32gb of memory, and I have a completely empty 2TB Barracuda drive that's currently serving as my scratch disk. I use this machine for editing massive videos, so it's got 1000 times the horsepower needed to process an Illustrator file. It needs to be a layered file and I'm otherwise using the default settings. I did, however, change the resolution from 300 to 150 and then to 72 dpi just to see if it would have an effect. Nothing.

     

    I rebooted the system to clear up any memory errors. Nothing.

     

    I created a whole new file just in case there's a legacy issue. Nothing.

     

    I shut every application to avoid conficts and compatibility issues, and still nothing.

     

    I'm running CS5 Master Collection on a really powerful machine, which I don't think is the issue, but just want to be clear that it's not due to lack of processing power, memory, scratch disks or anything else obvious. Any help would be much appreciated.

     

    Just to be clear, my issue is not directly related to scratch memory - the error I get is "Not enough memory to save the file." I can't see that as being remotely possible.

     

    Any help would be much appreciated.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2013 3:11 AM   in reply to Asmodeus Dhoine

    Solved: Clear temporary files ( Type %temp% in run and hit enter)

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2013 6:59 AM   in reply to Asmodeus Dhoine

    CS6 supports 64-bit.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points