Skip navigation
Currently Being Moderated

Streaming Video in Captivate 5 (mac) with Amazon S3 and CloudFront

Jul 14, 2010 1:52 PM

Has anyone successfully gotten this to work?

 

I'm able to Insert FLV/F4V video and add a video type: Streaming Video. The Server URI is rtmp://streaming.skillq.com/cfx/st and the Stream Name is elearning-overview-short.flv.

 

It won't play in Captivate but I can get this stream to play in JW Player. It took several hours just to set up my S3 and CloudFront Accounts because frankly, their help is almost always too general or vague. I could really appreciate some specific answers to get this set up working.

 
Replies
  • Currently Being Moderated
    Jul 15, 2010 2:14 AM   in reply to geotrice

    Just a few tips that took me a few days to work out that hopefully will help others...

    1 Remove the trailing / from the URI field i.e.

    rtmp://xxxxx.cloudfront.net/cfx/st

    2. Remove the .flv from the filename in the Stream Name field

    3. Set Auto Play and Auto Rewind unless you know you don't need to

    4. Set a few seconds for buffer time (for small clips, longer clips will need more buffering)

    5. Choose a skin (AFAICT it seems like it won't Stream unless a Skin is specified)

    6. Set the option to Pause the slide till the end of the video (unless you know you don't need to)

    After a lot of experimenting these settings worked for me. There might be others that work too,

    Best of Luck.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 15, 2010 8:23 AM   in reply to geotrice

    I tried the Detect Size on a Stream that's working and it timed out on me as well so do worry about that too much (might be a Cp5 design limitation). You could have a problem with Permissions or with Flash playing of your local drive. It might be worth trying from a Server. That's about all I can think of. There might be some sort of Debug Mode/Network Packet Sniffer that might help see the communications handshaking but I haven't come across anything like that so far. Sorry I can't be more helpful,

    Best of luck.

    Fergal

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 5, 2010 8:30 AM   in reply to geotrice

    Has anyone found a workaround or fix to this problem?

     

    I am having the exact same issue.   Projects that streamed FLV files perfectly in Captivate 4 are not in Captivate 5.   FLV files are streaming from the Amazon S3 server disappear in Captivate 5.  Tried this through a second streaming provider (Uvault) and had the same exact problem.

     

    Contacted Adobe Tech Support and they were able to replicate the problem locally.  They escalated the case # and now they are MIA.

     

    Has anyone tested this on both OS platforms?  

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 3, 2010 8:39 AM   in reply to scottwmiller

    I'm having the same issues with Captivate 5. I can stream my FLV/F4V using Flash CS5 but the exact same URI going to my Flash Media Streaming Server will NOT work in Captivate.

     

    I know with CP3 it was a headache to figure this out, but I got it to work. I thought by upgrading to CP5 that this whole process would be a lot easier. It is because they automatically separate the stream name from the Server URI for you, but it no worky worky. What a bummer.

     

    So, hopefully Adobe can fix this sometime soon. Anyone have any luck?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 3, 2010 9:19 AM   in reply to MtnBiker1966

    There is a fix to this bug.   Adobe identified a problem in the  CPSwf9Template.dll.   They sent a replacement .dll to me.   I can forward you the fix via email if you contact me at   scott  at  millercreativemedia   dot com.    Not sure why this has not been included within an update.

     

    Scott

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Nov 6, 2011 8:15 PM   in reply to scottwmiller

    Could you please send that .dll to me?  I am having this same issue and need to resolve it asap.

     

    Shocking that this is yet another file issue in Captivate (anyone tried used the "internalserverread.php" that comes package with Captivate on a linux-based server?)

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 10, 2011 7:34 AM   in reply to ryan_etn

    You would think this would have been fixed by now....  Hope this helps.

     

    Good luck.

     

    Attached is the new .dll .  This fixes a very specific bug in Captivate 5

    (PC) only.    We were using alpha channeled flv's to place actor

    performances within the interface.   We inserted flvs and assigned a skin

    of "none."   Worked in Cp4 but not in Cp5.  If you are using a skin with

    your streaming video then this .dll probably won't make a difference.

     

    I have included the emailed instructions from Vikranth from Adobe below my

    sig.

     

    Good Luck!

     

    =============================================

     

    I have attached the CPSwf9Template.dll along with this E-mail.

     

    Please take the DLL and replace in <-Installation Folder->\swf_templates\

    CPSwf9Template.dll

     

    (You can take a back-up of old dll, just for safety purpose)

     

    Use this dll and let us know whether your issue is resolved.

     

    Thanks,

     

    Vikranth.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points