Skip navigation
Currently Being Moderated

How Do I delete the Photoshop Temp File For Good? (PS CS 4)

Aug 19, 2010 2:59 AM

Hi,

 

I have a problem on my PC. Since This Saturday if gives me the error "Unable to complete because Disks full..."

 

I've read every blog/forum and even called the photoshop call centre without any help...

 

Some of the solutions I've tried are these:

- Deleted all my Temp files (as I normally do every week)

- Defragmented all my Hard Drives (done every week)

- Removed all unused Software

- Bought and installed a new Hard Drive (1 TB) to use as storage for this Temp File

- Cleared All Cache & Cookies on my browers

- Increased Photoshop Memory usage to 70%

- Unistalled Photoshop (Shutdown PC) then re-installed it and the Temp File is still there and it's much bigger than before

 

Basically I've tried everything I could.

 

What happens is that this Photoshop Temp 12389772616 file (44.6 gigs & increasing) can only be seen when Photoshop is active or running and cannot be deleted in those circumstances. When Photoshop is closed it Vanishes as well. I just don't know what else to do on this matter. When I re-allocate this so called Virtual File/Drive to another hard drive, Photoshop slows down and crashes even more...I was thinking of Buying the New Photoshop CS 5 but I'm now NOT willing to take that risk though it has served me well for a year until now.

 

NB QUESTION: Is there a way I can reduce the size of this Virtual File (Temp File) or Delete it Completely?

 

My PC Specs are:

 

Processor - Dual Core (2.3 GHz)

Operating System - Windows 7

Hard Drive Space - 1 TB, 500 GB and 250 GB x2 (Space is not an issue)

Graphics - G-Force 8800 (512 MB) with GPU (PCI Express)

 

Can anyone please help me or guide me on how to go about this mess?

 
Replies
  • Currently Being Moderated
    Aug 19, 2010 3:13 AM   in reply to Mo2Base

    What you are describing is quite normal.


    Photoshop always creates a Scratch file when you start the program and deletes it when Photoshop is closed properly.


    The Scratch file size is based on recent usage and often goes up in the GB range.


    Try opening a few small files in PS and the next time you start PS the Scratch file should be much smaller. Repeat if necessary.


    You should not select an external drive as the primary scratch disk unless it has a high speed connection – ie not USB2.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 19, 2010 11:52 AM   in reply to John Joslin

    As John says, the Scratch Disk TMP file is created automatically, and PS needs that.

     

    Now, if you have several, from other dates, those CAN be Deleted to clear space. PS should clean up after itself, even with a systemic crash, but I've found a few of the old guys hanging around. This happened more often with older versions of the program

     

    Sounds like it's time to get more HDD space. If you add a new physical HDD, and direct your Scratch Disks to that, you should also see a speed increase of doing most operations.

     

    It is also bad practice to fill up a HDD to much above 70%. Bad things can be waiting just around the corner.

     

    Good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 19, 2010 11:57 PM   in reply to Mo2Base

    Mo2Base wrote:

    But then I still find a problem when opening a new document that is (1000 x 1000 and above). Photoshop either gives me the same "...scratch disks full" or it simply lags and doesn't open. I've assigned one of my Physical hard drives to handle this virtual memory/ drive instead of my C:/ drive

     


    Just to clarify; is your Primary Scratch disk, as nominated in Edit > Preferences > Performance an Internal drive? If so, what space is available on it?


    Is the RAM allocation within the "Ideal Range" recommended in Edit > Preferences > Performance ?



    Slow file opening may be due to the default printer. This is a known bug and has been reported many times in the forum.


    The solution, weird as it sounds, is to make a generic printer driver your default printer. If you don't have one, download it here:


    http://www.adobe.com/support/downloads/product.jsp?product=pdrv&platfo rm=win

     

    I hope some of ths helps.

     

     


    Oh yes, and try resetting your preferences (again) as described in the FAQ.


    http://forums.adobe.com/thread/375776?tstart=0


    You either have to physically delete (or rename) the preference files or, if using the Alt, Ctrl, and Shift method, be sure that you get a confirmation dialog.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2010 8:08 AM   in reply to Mo2Base

    Well, my CS5 behaves quite different than the OP's. With PS closed, the scratch is empty. I open PS, the scratch says 32,736 KB, not many MB. I open a 60M file, the scratch says 378 MB. I close the file and the scratch remains the same. I close PS, the folder is empty. I open PS and the scratch says 32 736 KB. It does not open automatically to some large number, based on the last size of the scratch.

     

    Does CS4 behave differently?

     

    Also, what is in that file when you first open PS? 32KB (or whatever the number is) of what?

     

    Message was edited by: Hudechrome

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2010 11:23 AM   in reply to Mo2Base

    I'm glad you are back in business!

     

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points