Skip navigation
Currently Being Moderated

Dreamweaver CS5 file view always pops up on top

Sep 30, 2010 1:34 AM

If I'm working on a file in DW CS5, and switch to the browser on my Mac using the command-tab (or alt-tab on Windows) switcher and then back again, the file browser comes up from the back and covers the file I was working on.

 

The same thing happens if I click a browser from the tray, and then click back to DW CS5 again - the file browser pops up over the file I was working on.

 

I'm coming from every past version of DW through CS3 and this is a new very annoying behavior.

 

I have CS3 and CS5 both open, and I can replicate this. Doing this on CS3 acts as it should - the file I was working on stays focused when I come back but CS5 always pops the file browser on top.

 

This is very frustrating.

 

How can I stop this? Why does it do this by default when a decade of DW versions did not do this?

 
Replies
  • Currently Being Moderated
    Sep 30, 2010 8:44 AM   in reply to dbonneville

    I don't use a Mac so I am just guessing based on what you are posting, but could it be a layout problem? Have you tested it using different DW UI layout presets?

     

    Brad Lawryk

    Adobe Community Professional: Dreamweaver

    Northern British Columbia Adobe Usergroup: Manager

    Thompson Rivers University: Dreamweaver Instructor

    My Adobe Blog: http://blog.lawryk.com

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 30, 2010 11:49 AM   in reply to dbonneville

    There are several ways to communicate this directly to Adobe

    http://www.adobe.com/aboutadobe/contact.html details the myriad of ways that you can contact Adobe

     

    But perhaps the most productive method is by submitting a detailed bug report here:

    https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 10, 2011 5:38 PM   in reply to dbonneville

    I'm having the same issue.  It sure is annoying.  Did you ever sort it out?

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 10, 2011 5:44 PM   in reply to acymru

    First, I got a lobotomy. That helped. After that wore off, I maximized the FTP window to the size of my screen and simply use the icon to pop back and forth. It occassionally gets out of sync with the properties panel on top of the FTP window at the bottom, but I can live with that. It's as close to being like the PC version as I can get it, and I'm in the PC version everyday.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 13, 2011 2:18 PM   in reply to acymru

    I have a similar issue - if I copy some text in Firefox or Safari and use "Command Tab" to hop back to Dreamweaver (CS5 version 11 build 4993) in code view it will paste the copied text  into the code after a closed TAG. Very annoying!! Never had a problem until CS5.

    Anybody else experiencing this?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 16, 2011 8:52 PM   in reply to dbonneville

    Just curious - what are your system specs & are you running any 3rd pary extensions?

    Maybe something wacky is happening because of an extension or machine configurations?

     

    Imac Specs:

    -----------------------------------------

    My machine specs:

      MAC OSX version 10.6.7

      Model Name:    iMac (27" with 8 terabytes)
      Model Identifier:    iMac11,1
      Processor Name:    Intel Core i7
      Processor Speed:    2.8 GHz
      Number Of Processors:    1
      Total Number Of Cores:    4
      L2 Cache (per core):    256 KB
      L3 Cache:    8 MB
      Memory:    12 GB 1067 MHz DDR3
      Processor Interconnect Speed:    4.8 GT/s
      Boot ROM Version:    IM111.0034.B02

      SMC Version (system):    1.54f36

     

    I am also running:
    Suitcase Fusion 3 - Version 14.0.5 (162)

     

    -----------------------------------------

    3rd Party Extensions running:

    DREAMWEAVER HTML5 PACK

    Mail Spam Blocker

    ADOBE AIR Extension for Dreamweaver

     

    The mouse that I am using the newly designed wireless Apple mouse and wireless mini keyboard

     

    Something is causing this.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 19, 2012 6:44 AM   in reply to macfreak@tampabay.rr.com

    I'm getting the same behaviour after an upgrade - any answers please?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 19, 2012 12:30 PM   in reply to chrisibrow

    Hi chrisibrow,

     

    I'm trying to reproduce the problem so it can be further investigated, but so far I have not been able to do so. I tried switching between apps using CMD+Tab and also by clicking on the application icon in the Dock.

     

     

    I assume you have the Files panel undocked, and also in its "expanded" mode. Is that correct?

     

    Can you give me a step-by-step of what you're doing when the issue occurs?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 20, 2012 4:51 AM   in reply to Carey Burgess

    Hi Carey,

     

    Thanks for responding.

     

    Mac OS 10.8.2

    Dreamweaver 12

     

    The problem is not about switching between apps. The problem is the inability to have a dreamweaver document (.html, .css etc) sit in front of the dreamweaver Files pane. The Files pane always sits on top. This really slows me down when working on large sites.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 20, 2012 2:26 PM   in reply to chrisibrow

    Ah, OK. All panels will float on top of the document window.

     

    There are two options I could see working well to solve this for you.

    With the first. you would need to turn off the Application Frame (uncheck it under the Window menu), undock the Files panel, and then put the panel in its expanded view (click the icon labeled "M" here: http://help.adobe.com/en_US/dreamweaver/cs/using/WSc78c5058ca073340dcd a9110b1f693f21-7ed0a.html).

    In this mode, it will sit behind the document, and when you need it you could go to Window > Files (or use a keyboard shortcut -- the default is the F8 key) or minimize/close the document.

     

    Alternatively, you could just go to Window > Files (or use the keyboard shortcut) to open and close the panel as needed.

     

    Hope that helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2012 2:23 AM   in reply to Carey Burgess

    Thank you Carey the first option worked perfectly for me

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 12, 2012 2:40 AM   in reply to Carey Burgess

    I work on a Mac and have the same problem which is not solved with the above. I am used to work with the Files panel undocked and expanded and I switch between the documents and the Files panel with Cmnd+Shift+F. This works from document to panel Files but no more the other way. Plus that it not always works, I can't see any logic in the circumstances when I cannot switch from document to panel Files with the shortcuts, but this regulary happens. Another thing that happens is that I open a document from the Files panel and it does not show but instead stays covered with the Files panel. Most of the time I can avoid all this by using the expand/collapse icon but not always (again the inconsequent behavior), plus that I prefer using the shortcut instead.

     

    This problem is not something special on my computer, same thing happens on other Mac's with a complete different configuration that I work on with my students. With CS6 something has changed in the behavior of the Files panel and this is very annoying. I hope Adobe takes this serious and comes with a solution. Looking very much forward to your reply!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points