Skip navigation
riddler275
Currently Being Moderated

Unable to open documents in Adobe Reader 9.4 - showing as not 'currently installed'?

Oct 11, 2010 7:38 AM

Hi,

 

This problem has been driving me crazy all day...

 

I installed the patch to opgrade Adobe Reader 9.3 into 9.4 this morning; as soon as I did I was unable to open PDFs, getting an error message along the lines of "you are not authorised to view this".  To try and resolve this, I uninstalled reader and installed it again directly from the Adobe website.

 

I'm now getting the following error:

 

"This action (i.e. opening the file) is only valid for products that are currently installed".

 

I uninstalled and reinstalled twice more, same issue.

 

I have tried repairing the installation in Adobe.  To clarify, I can't double click/right click open PDFs.  However, if I drop them onto the Adobe Desktop icon they open normally.  I am also unable to open PDFs which are attached to emails without dropping them on desktop, then dropping them on Adope icon.

 

I'm using 64 bit Windows 7, and it is my work desktop that is affected.

 

Does anyone have any advice?

 
Replies
  • Currently Being Moderated
    Oct 11, 2010 10:47 AM   in reply to riddler275

    Looks like the association to your .pdf files has been changed or has been altered incorrectly for some reason.

    Can you please try the following steps to rectify the same:

    1. Click on the Start button.

    2. In the right hand menu click on default programs.

    3. In the window that opens up, click on "Associate a file type or or protocol with a program".

    4. That will open a list of file extensions such as .pdf etc.  Double click on the .pdf extension

    5. A window will open giving you a choice of programs to choose from.

    6. Click on the browse button. Scroll through the folder structure and select AcroRd32.exe from the appropriate installation directory. (By Default it would be located at C:\Program Files (x86)\Adobe\Reader 9.0\Reader\AcroRd32.exe unless you have installed it at some other location.)

     

    Hope that works out successfully for you.

     

    Thanks

    Ankit

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 11, 2010 12:21 PM   in reply to Ankit_Jain

    I'm having the same problem.

     

    When I get to the "Assocaiate a file type... with a program" screen, .pdf is not listed.

     

    In addition, after "successfully" installing Reader 9.4 from the Adobe site, I cannot see it in my Program Files folders.

     

    I am running Windows7 64bit.  I just opened pdf files from this PC last week.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 11, 2010 3:23 PM   in reply to thelakers

    On 64bit systems Adobe Reader is installed under C:\Program Files (x86)\Adobe

     

    To see if it is properly installed use Control Panel\Programs\Programs and Features

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 11, 2010 5:36 PM   in reply to LeoAdobeX

    I tried to download/install 9.4 again.

    Got the same error message again (see below) followed by, "Installation Complete".  Still not showing in Program Files (x86) or in Control Panel\Programs...  So i guess it's not really Installed.

     

    The error message I get at 99.9% is:

    "Error 1406.Could not write value to key \Software\Classes\CLSID\{98D9A6F1-4696-4B5E-A2E8-36B3F9C1E12C}\LocalS erver32.  Verify that you have sufficient acess to that key, or contact your support personnel."

     

    Any ideas please?  Should this be a new thread?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 11, 2010 11:22 PM   in reply to thelakers

    Hi,

     

    Well seems now you are stuck with 2 different problems at once..

     

    To tackle the first problem i.e. your PDFs not opening on double click. Can you right click on any PDF and click on the "Open With... > Choose Default Program" option. (Incase, the option doesnt appear in the context menu, try holding "Shift" and then right clicking the PDF file). In the dialog box that appears, click "Browse" and locate the AcroRd32.exe at "C:\Program Files (x86)\Adobe\Reader 9.0\Reader\AcroRd32.exe". Make sure that "Always use the selected program to open this kind of file" checkbox is checked. Click OK to close all windows.

    Now try executing the instructions in the previous post, the .PDF extension will be visible to you in the "Associate a file type or or protocol with a program" dialog box.

     

    As far as the second problem goes, i.e. your installation failing cause of error 1406, Can you please try out the below mentioned steps:

    1. Download Microsoft's SubinACL tool from http://www.microsoft.com/downloads/details.aspx?FamilyID=e8ba3e56-d8fe -4a91-93cf-ed6985e3927b&displaylang=en

    2. Install the same by double clicking on the "subinacl.msi" just downloaded.

    3. Open Command Prompt window through the Run Dialog Box (Start -> Run and type "cmd" and click OK)

    4. In the Command Prompt window, type in the following commands:

        i. cd /d "%ProgramFiles%\Windows Resource Kits\Tools" (Hit Enter)

       ii. subinacl  /subkeyreg  HKEY_LOCAL_MACHINE\\Software\Classes\CLSID\{98D9A6F1-4696-4B5E-A2E8-36B3F9C1E12C}\LocalSe rver32 /grant=administrators=f /grant=SYSTEM=f /grant=USERS=f  /grant="Creator Owner"=f (Hit Enter)

      iii. subinacl  /subkeyreg  HKEY_CURRENT_USER\\Software\Classes\CLSID\{98D9A6F1-4696-4B5E-A2E8-36B3F9C1E12C}\LocalSe rver32 /grant=administrators=f /grant=SYSTEM=f /grant=USERS=f  /grant="Creator Owner"=f (Hit Enter)

     

     

    For more details please have a look at the below post:

    http://forums.adobe.com/message/3080878#3080878

     

    Hope all this works out..!!!

     

     

    Thanks

    Ankit

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points