Skip navigation
dmcgovern
Currently Being Moderated

Dreamweaver CS5 FTP issues, can't connect to remote server

Dec 16, 2010 10:45 AM

i can connect to many remote servers but one. I put all the right information in the manage sites, and it appears to connect for 10-30 seconds then for some unknown reason, it disconnects. i have looked at the ftp log with no insight..it shows the right user connecting with the correct password, then does two PWD and disconnects.

 

note that i can connect with my regular ftp client inside of windows 7 and it does not disconnect (tho strangely it will not print the LS directory for the root, only anomaly)

 

any advise... (note that i did unload both the firewall and the local anti-virus to see if that helped, it did not...

 
Replies
  • Currently Being Moderated
    Dec 16, 2010 4:36 PM   in reply to dmcgovern

    Have you checked Passive FTP?  Have you tried adding or removing the forward slash in the Path field?

     

    J.S.
    http://www.ultrasuite.com/
    http://twitter.com/dwUltraSuite

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 17, 2010 7:33 AM   in reply to dmcgovern

    Hi,

     

    excuse me, but 'cause of your great difficulties is it worth to go a different way, maybe: My various opinions expressed to this much discussed subject, are showing that I prefer a program which works "outside" of the DW. My reason is: for each task in whatever area we work, we search for the experts, we don't charge a "jack of all trades".

     

    So I prefer to upload my files and sometimes for the opposite way, for a necessary download from my server, by using filezilla. It simply looks easier for me to keep track of all operations precisely and generate or reflect easily the desired tree structure.

     

    Above all, FileZilla has a feature (translation from my German FileZilla) called "compare file list". Here it's possible to use file size or modification time as a criterion. There is also the possibility to "hide identical files", so that only these files which you want to redact remain visible.

     

    Here is the link to get it and where you can read informations about how it works:

     

    http://filezilla-project.org/ and
    http://wiki.filezilla-project.org/Tutorial#Using_the_site_manager

     

    Of course, you also need all the access data to reach your server. What concerns the attributes, so I can show you mine:

    FileZillaAttr.jpg


    In addition, I'll quote a hint from Nancy O.:


    Try toggling Passive and/or Secure FTP on/off.
    Your web host might have changed upload requirements to improve security.
    Another thing to check is your Anti-virus and Firewall settings. If they are too restrictive, DW may not have permission to connect to the remote server.

     

    Hans-G.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 4, 2011 8:36 AM   in reply to dmcgovern

    Help yes I have EXACT same problem.  You are not alone with this I have the identical issue. (in fact when I googled it - your topic came up)

     

    On Dreamweaver I have ten websites which I work on.  I flick backwards and forwards to while working in dreamweaver.   Then overnight ONE site decides to cause dreamweaver to hang.

     

    All the other sites I can edit my pages, save them, ftp them and then disconnect. (Just like normal)


    However in this one site I can edit the pages ,save them.  But when I click [connect] to fpt the page just hangs.


    When looking at the ftp it does appear to be logging in find.  So the PC says something like:
    Retrieving remote folder information for /,

    Then after 30 seconds a box [An FTP error occured - cannot get remote folder information] appears

     

    The connect/disconnect button is set to [disconnect] which basically is telling me that I AM in the system.  Its just that the files wont load.

    Then the system finally sends message [The connection to the remote host has been lost]

     

    What is going on is that I am able to connect with the right passwords and username.  But this one site refuses to load.

    TO SOLVE IT I TRIED THESE

    1) create a second account in Dreamweaver with duplicate files.  Try to connect: Same problem

    2) Recreate site cache on main site and also backup - No joy.

    3) Install ANOTHER FTP program on the PC and try that (Yes this other FTP works fine)

    4) Delete the site from dreamweaver and restart again.  -No joy.

    5) Turn off the wireless router and BT INFINITY hub from the mains.

    6) Reboot the PC

    7) Instead of using the words [ftp.website.com] changed to [66.111.999.2]

     

    So what works?

    1) If I install another FTP client I have access to my files.

    2) If I use Dreamweaver to access other websites it works fine.

     

    Thats telling me that it must be a program setting on bug.  It must be something dreamweaver is getting stuck on.  I have not as yet tried to uninstall dreamweaver then reinstall.  Thats sort of the last thing.

     

    But the bottom line is this bug is not confined to your experience.  I have the same issues.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 21, 2011 2:56 AM   in reply to 365Drills

    I have just discovered the solution to my awful CS5 FTP problems. It would work fine on some sites, but refuse to connect me on others. For these, I successfully used Fetch, but frankly, that's a workaround.

     

    Then on another forum, I discovered the answer. The timeout default had been set to 2 seconds. I'm not Robinson Crusoe on this, even though the defauklt should be apparently 60 seconds. Anyway, I set it to 30 seconds, tried connecting to a previously inaccessible site and bingo - it worked!

     

    Thanks for nothing Adobe - in your FTP troubleshooting guides this is not even mentioned.

     

    If anyone else has this problem go to Dreamweaver > Preferences > FTP Time Out.

     

    Cheers

     

    Ian

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 21, 2011 3:21 AM   in reply to ianvectis

    Perfect.

     

    That one worked for me. 


    Edit> Preferences> Site FTP>  FTP Time Out:  15 Seconds

     

    Changed to

     

    Edit> Preferences> Site FTP>  FTP Time Out:  20 Seconds

     

    And amazing.....  I can now connect to this website.  And FTP my files.

     

    Result!

     
    |
    Mark as:
  • Currently Being Moderated
    May 16, 2011 4:13 PM   in reply to dmcgovern

    I still have the issue... Its been a week me trying to solve this... did every posible thing that I found online.. Nothing works!! Please help :'(

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 27, 2013 8:05 PM   in reply to BANDO Designs

    i had the same problem and i solve in a ridiculus solution hopefully it will work out for you

    DO NOT CHANGE ANYTHING keep all the information the same

     

    JUST instead of putting in the Ftp Address :

                ftp.your site name.com

        try : www.Your site name.com

    it will change too on the WEB URL and show like

    http://www.Your site name.com

     

    and dont ask me how or why is that, it works for me perfect, Of course, i thank you guy very much for trying to help but i tried everything the guys said in the comments, nothing works. but this worked perfect, i wish it will work for you too.

      all the respect and regards for the members 

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 28, 2013 1:29 AM   in reply to very biggener

    I tried all these things and get nothing.

     

    1) ftp.clapperboard.net  (An FTP error occured - Cannot make connection to host.  The remote host cannot be found.)

    2)www.clapperboard.net  (An FTP error occured - Cannot make connection to host.  The remote host cannot be found.)

    3) http://www.clapperboard.net  (An FTP error occured - Cannot make connection to host.  The remote host cannot be found.)

    4) clapperboard.net  (An FTP error occured - Cannot make connection to host.  530 Login authentication failed.)

    5) 109.73.169.82 (An FTP error occured - Cannot make connection to host.  530 Login authentication failed.)

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 28, 2013 5:27 AM   in reply to 365Drills

    Am getting closer....   I think its a Firewall issue.  I went into my system and reset the firewall in my XP software.

     

    How to reset Windows Firewall settings in Windows XP SP2

    There are situations where-in you need to reset your Windows Firewall settings, after removing a Trojan etc. Resetting the Windows Firewall sets the configuration to factory defaults by removing all the programs / port / exceptions settings.

    To reset the Windows Firewall to the factory default state, try this:

    • Type firewall.cpl in Start, Run dialog.
    • Click the Advanced tab.
    • Click the Restore Defaults button.
    • Click Yes to continue when you see this dialog

    Restoring the default settings will delete all settings of Windows Firewall that you have made since Windows was installed. This may cause some programs to stop working.

    Do you want to continue?

    The Windows Firewall is now turned ON, and set to factory default state.

    Alternately, you can use the NETSH command-line to accomplish this:

    Open a Command Prompt window and type NETSH FIREWALL RESET

    This command resets firewall configuration to default. This provides the sa

     

    ===========================



    Then I went into my Control Panel of the server and reset the password

     

    Once I did that Dreamweaver was getting very strange.  It said it wanted to block some content.

     

    And then now the system just hangs. So the green light is "On" to say "connected" but no files load into the panel.



    I have to press it to "off" to get the [Connect] Button again.

     

    So I am back to square one but messing about with the thing is generating some strange results.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 28, 2013 3:24 PM   in reply to 365Drills

    Have you tried to connect using a 3rd party FTP app like Filezilla? 

     

     

     

    Nancy O.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 1, 2013 6:39 AM   in reply to Nancy O.

    Nancy - Yes in fact Filezilla is the one I am using for now so its working perfect.

     

    But what is annoying me is having to do  my work in Dreamweaver then switch over to Filezilla to upload the new page.

     

    It gets very confusing.  And of course out of the EIGHT websites that I have listed in Dreamweaver there is only ONE that refuses to connect.


    Its so frustrating.  But at least I can work using Filezilla to upload pages.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 10, 2013 9:00 AM   in reply to dmcgovern

    I have the solution.. I actually thought reformatting the computer and do a clean install of windows 7 and cs5 dreamweaver might fix it... I was wrong... So I changed the preference from 30 sec to 60 and no luck.. I did the usual matrix combinations of checking - not checking - adding .com - removing .com... WHAT WORKED FOR ME, WAS TO CHANGE FROM FTP TO SFTP and keep the root directory /  and make sure your port is 22.   I did order an SSL and probably had to select this option for it to work.

     

    But hey, my computer runs faster and I found out gateway has a recovery feature that does the clean install for ya.. yeah.. hope it helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 10, 2013 2:50 PM   in reply to nazca13

    Well I have tried changing it to sftp.clapperboard.net and nothing happens...  I tried the route directory to /  too.     Not sure how to change the ports?

     

    But then as if by magic.... I simply tried ticking the box [X] Use Firewall (In Preferences) just under the password.

     

    And then HEY PRESTO -  I am logged in.


    So thanks for the post above.  It didnt quite help me but it did get me playing about with the settings again and to find out its a simple [X] Click of the Use Firewall (In Prefrences) selection is crazy!

     

    Note if you are looking for this tick box go to Define Sites and then its at the bottom of Web Server Info (Just under Password) GGRRRRRRR

     

    Haha !  SORTEEEEDDDDDD

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points