Skip navigation
Currently Being Moderated

Text Frame Inset spacing and Corner Option

Jan 28, 2011 8:46 AM

I can set Text Frame Inset spacing in the Text Frame Options dialogue box. But when I go back to change the settings: all the Inset Spacing for bottom, left and right are greyed out. I can't change them.

 

This only happens when I have applied a Corner option to the Text Frame.

 

When I apply any Corner option to the Text Frame, the Inset Spacing defaults to a constant for Inset, bottom, left and right: i can change only the Inset and it changes all four.

 

If I remove the Corner Option: I get access again to all Inset Spacing.

 

Thanks,

Cam

 

InDesign CS5

 
Replies
  • Currently Being Moderated
    Jan 28, 2011 5:19 PM   in reply to Cam Reesor

    That's the way it works.


     
    |
    Mark as:
  • Currently Being Moderated
    Feb 6, 2013 10:29 AM   in reply to Peter Spier

    if you create a box, change the corner option to what you need, then save the box as an object style, then open the object style options box and click on Text Frame General Options ....and you can set the inset spacing for all sides!

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 7, 2013 12:22 AM   in reply to rjallenamec

    @rjallenamec – did you try that with different values for top, bottom, left and right?

     

    That will not work.
    Ok, the values are stored in the object style, but:

     

    On the object itself the value for "top" will always win and is applied on every side…

    Your object style, that is defined the other way is showing a nasty + for override.

    And a alt+click will not help to apply the different values.

     

    (At least it does notwork in InDesign CS5.5 where I did a quick test. Would be nice, if that will work in InDesign CS6, but I am in doubt…)

     

     

    Uwe

     
    |
    Mark as:
  • jmlevy
    478 posts
    Oct 30, 2004
    Currently Being Moderated
    Feb 7, 2013 12:50 AM   in reply to Laubender

    No, it does not work in CS6. Tried it yesterday evening.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 7, 2013 4:06 AM   in reply to Laubender

    Did you try it this way????

     
    |
    Mark as:
  • jmlevy
    478 posts
    Oct 30, 2004
    Currently Being Moderated
    Feb 7, 2013 5:12 AM   in reply to rjallenamec

    Yes. I followed step-by-step your instructions. Same result as Laubender described.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 7, 2013 5:18 AM   in reply to jmlevy

    What is amazing is, I figured this out yesterday, I showed a co-worker it, and it worked fine for both of us, when I went to do the

    Same effect today, it is doing what Laubender said, I asked my co-worker …. Was that a dream and he said no, we both did it and

    It worked, he tried it again today and it didn’t not work, (in the image I sent I didn’t have corner options on, but when we did it yesterday

    We both used the same image, on different machines where the corners of the box were rounded and we placed the text via the insert

    Text setting….

    We here are both stumped that NOW its now working, (maybe adobe only gives you one chance to make it work and then drops the feature!!!)…

     

    If you do figure out a way to make this work, please let me know!

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2013 6:22 AM   in reply to rjallenamec

    Confirmed it does not work either on Mac or PC. The character styles procedure lets you think it is going to work, showing the unlink icon and allows you to unlink all sides but nothing happens when you change the insets. Only workaround I can find is to put a box in a box which I consider sloppy. Seems like a bug to me!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2013 3:15 PM   in reply to Cam Reesor

    I had same problem. But then I discovered it works if you uncheck the preview button first, then make your changes and click ok (without previewing it first).

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2013 2:15 AM   in reply to kōtuku

    Can you show us some screen shots with edges highlighted and hidden characters visible?

     

    Are you working with CS6 or CC ?

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 28, 2013 2:55 PM   in reply to Laubender

    Hi Uwe

     

    I’m working in CS6 on a PC. I tried to replicate it, but it wouldn’t work. Then I discovered there was one more thing I was doing. There needs to be a stroke.

     

    Create a text box with no stroke and fill with text. Set the inset spacing even for all sides (5mm in my example). Then set corner options to the same size as the inset spacing. Then save as a new object style. Go into the object style settings, and change the side you want to make bigger. Make sure the effects are set for stroke. Click ok.

     

    cid:image001.jpg@01CE8C41.B8148B00

     

    Then add the stroke and the spacing should change. For some reason, the stroke had to be at least .75pt to work. To change the size, you need to reset it back to the original 5mm inset and clear overrides, and then set it again with a different size.

     

    cid:image004.jpg@01CE8C41.B8148B00

     

     

    Hope this helps.

     

    R.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points