Skip navigation
novadar_sat
Currently Being Moderated

Flash Player - Disable Hardware Acceleration - Apple TV-Mac OS 10.4.7/Firefox

Feb 1, 2011 9:14 AM

Hello all,

 

I have been going down a fun path getting my 1st Generation Apple TV (160 GB HD) to run Hulu natively (without PlayOn restreaming).  After fun times getting Firefox and Flash Player working, I blasted through setting up Hulu Widget to keep the video size small (Apple TV in 480p defaults to an 800x600 res).   Things look pretty good. I maxed out buffering/cache for all Hulu related sites within Global settings, this produced nice improvements.  I found a GreaseMonkey script that forces the Flash Player to always render Low Quality video.  This helps immensely at stopping stuttering with little trade off in quality.  My last piece to try to tweak video playback (aside from monkeying around with the OS X kernel) is the disable Hardware Acceleration.

 

BUT, I am having a major problem with mouse support or something.  Everytime I bring up the Display settings via a Right Click, I cannot uncheck "Enable hardware acceleration".  Surprisingly clicking it 500 times still does not make it uncheck.

 

I have searched high and low but have not found a clearcut way to disable it via script or other non-interactive means.

 

I wonder if there might be a javascript that could be plugged into GreaseMonkey to accomplish the end goal.   This blog and Adobe document refer to the wmode parameter and how to use it to disable HA.

 

http://niquimerret.com/?p=159

 

http://www.adobe.com/devnet/flashplayer/articles/fplayer10_1_hardware_ acceleration.html

 

I am thinking perhaps I can take the Low Quality JS (http://userscripts.org/scripts/review/38994) and replace "quality" with "wmode".  Am I on track?    It  seems "opaque" might be the right one.  http://kb2.adobe.com/cps/127/tn_12701.html

 

There is a case related to my question:  https://bugs.adobe.com/jira/browse/FP-5748

 

Any tips, clues, pointers, commiserations?

 
Replies
  • Currently Being Moderated
    Feb 1, 2011 10:53 AM   in reply to novadar_sat

    Hi, I'm certainly not as Technically inclined as you are, but did you try this site?

     

    You may want to go to this site: http://www.adobe.com/software/flash/about/. Right click on the Flash logo, Settings,
    then UNcheck the hardware acceleration in Display Settings.

    I don't know why you aren't able to UNcheck this on any Flash content, so this may not work either. That's just the site we usually cite.

     

    You may find more information and others of like mind on one of the other Adobe Forums, depending on which Adobe Programs you use.

     

     

    500 clicks, LOL

     

     

    Thanks,

     

    eidnolb

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 1, 2011 10:59 AM   in reply to novadar_sat

    Hi, you did post to the correct Forum for the hardware acceleration issue.  I should have been clearer in my previous post to you. Since you have done so much more with your system than the average user does, maybe those other forums would be able to help in those. Perhaps they could see something that affects that hardware acceleration issue, that I wouldn't.

     

     

    Thanks,

     

    eidnolb

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 1, 2011 1:27 PM   in reply to novadar_sat

    Hi, LOL at my screen moniker. That's interesting that the FF beta has an Option for that. The only problem, is that I have heard that each browser must UNcheck the H.A. I'm sure you'll find out.

     

    Hope that works at least for FF. Let me know if you have time.

     

    I've been checking out Apple TV and Google TV. Just saved the links and some info, haven't had time to go further. I'd prefer Apple TV over Google tho.

     

    I have a 55" HD Sony/Blu-ray Surround Sound Speakers, etc. I hooked up the VGA cable for Internet, and WOW on the Screen/Monitor!! Now I'm thinking about the iPhone 4 with VZ too, on their pre-order list for 2/3/11!

     

    Hard to keep up with the Technology, moving faster today for some reason.

     

    We are under the Snow & Ice warning, getting it now. Hope I don't lose power! If so, I'll be offline for sure.

     

    If I find anything on that H.A. for IE, I'll let you know.

     

     

    Thanks,

     

    eidnolb

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 6, 2011 3:24 PM   in reply to novadar_sat

    If everything works fine in another user account, the issue is with your user account. (As a troubleshooting measure you can create a new account and test video streaming.)

    Otherwise:

    Navigate to your User Account > Library > Preferences and trash the Macromedia Folder. After restarting the computer and relaunching the browser, these will be rebuilt.

    Other Preference files to consider trashing are Safari, Quicktime, Chrome, Silverlight.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points